No wIfI after Mobian update
Hello, after updating Mobian three days ago wifi and bluetooth ceased to exist.  I have the convergence dongle so was still able to connect to net.  Pinephone does not have a SIM at this time.  I have reflashed with Postmarket Phosh, Postmarket Smxo, (both are snappy but did not help with the wifi), and am now sitting with Manjaro Phosh.  Hitting the wifi icon does nothing in Manjaro.  Hitting it in Mobian would toggle but would not find any network.  Manjaro just sits there greyed out.  I am not familiar with Arch commands but have done the following:
inxi -n results in wlan0 state: down
nmcli g (and r) results WIFI  enabled
ip a results in wlan0 DOWN

I have toggled the hardware micro DIP switch at the back on the Pinephone.

Bluetooth in Mobian and Postmarket said to insert a dongle.  It's the same chip and switch, but I would just like wifi up.  Do I have a wifi brick?

Any ideas anyone?
I have a very similar issue, my pinephone has no wifi or bluetooth, they just stopped working suddenly, and booting into a new OS doesn't fix the issue, and I tried a lot of different images. Started happening a few months ago. Only the cellular works.
Similar problem. Here is my post where I describe it with some detail :
Count me as another dead wifi+bt on PinePhone.
I've barely used this phone, just up and stopped working.
Never got around to getting it even usable as a phone, then hardware fault.
I've not done anything like firmware changes or anything particularly challenging.

I recently revisited it after giving up on making it useful, tried a few different images and then *poof*, up and stopped working.
This seems very much like a fundamental hardware flaw and seems to not be an uncommon problem that probably should find some people getting refunds...  You'd hope.

It would seem from all those threads however that no one has had any positive resolution other than, the hardware is dead.
Maybe I'm not seeing those positive responses but it seems everyone has simply purchased their own replacement hardware?

Possibly Related Threads…
Thread Author Replies Views Last Post
  Can't get Mobian on PinePhone to recognise USB-C docking bar duncan_bayne 9 6,359 12-04-2023, 02:14 AM
Last Post: Peter Gamma
  Mobian PIN changed after update! Mwo87 21 16,477 12-02-2023, 11:53 PM
Last Post: Karrenbrady
  Cellular Data, Mobian - "No WWAN Adapter Found" justneedsomedatathanks 3 4,034 05-25-2023, 09:03 PM
Last Post: justneedsomedatathanks
  No longer waking up from sleep after recent update gamerminstrel 2 1,163 01-23-2023, 08:33 AM
Last Post: gamerminstrel
  No sound after Mobian upgrade arbocenc 1 668 11-28-2022, 11:02 AM
Last Post: arbocenc
  no sdcard boot and manjaro update failed Gwen 3 1,247 11-27-2022, 07:56 AM
Last Post: fxc
  pinephone-support package not upgradable on Mobian fhireman 4 2,165 09-24-2022, 08:01 AM
Last Post: dante404
  update kills keyboard ludgate 1 1,087 05-18-2022, 12:43 AM
Last Post: programmin
  WIFI doesn't stay connected Matt73 0 763 03-10-2022, 08:10 AM
Last Post: Matt73
  PinePhone running Mobian - Malware extraction? names_fold 1 1,532 01-24-2022, 12:00 PM
Last Post: tophneal

Forum Jump:

Users browsing this thread: 1 Guest(s)