Cellular Data, Mobian - "No WWAN Adapter Found"
When going to Settings > Mobile, I see "No WWAN Adapter Found. Make sure you have a Wireless Wan/Cellular deivce"

I live in Australia. Using a Telstra prepaid SIM card. The SIM card works in my other phone fine, so it's not the SIM card.

I had some trouble inserting the SIM card originally. First, I inserted it twice without the nano-micro sim converter (having gotten nano/micro sim sizes confused), which didn't work on Manjaro KDE (obviously). I then tried inserting it with the adapter 4 times, and it still didn't work. There was no real feedback on KDE, but I tried placing a call and receiving one from my other number, which didn't work. I should mention that Wi-Fi does work, so obviously the modem is functioning correctly. I've tried Plasma, Ubuntu Touch, and Mobian. Mobian is the only one of the three that actually has a section for mobile data (Plasma does have one, kinda, but it didn't work for me), which is progress.

I've checked the SIM card slot for damage, and all the pins seem to still be fine. A little surprising given how much of an ordeal it was to remove the SIM card after each failed attempt, but I'm thankful for it.

However, this message, "No WWAN Adapter Found. Make sure you have a Wireless Wan/Cellular device" leads me to believe that it can't detect the SIM tray component of the phone existing anymore? Or does this just mean that the SIM card is not detected?

It was difficult to insert the nano SIM into the slot with the micro SIM adapter. I've tried inserting the SIM card in various ways, but I settled on the one that the picture above the SIM/TF slot seems to suggest: the cutoff corner on the top left of the SIM/adapter, meaning that the SIM is on the bottom, not the top, of the adapter. Which obviously means that it falls out pretty easily. This did...not seem entirely right, but it matched the picture, so I went with it...

Everything else works fine. Wi-Fi works, if somewhat slow. Bluetooth is fine. Battery life is pretty good. Performance on Mobian Phosh is pretty great compared to Manjaro KDE (Ubuntu Touch was also pretty good, but had a weird issue where, whenever it would go into screensaver mode, I'd have to hard-power off the phone and turn it on again to get into it, so that was a no-go). Axolotl seemed to work on Ubuntu Touch (not on Manjaro KDE, couldn't even get the app to open). I was able to successfully attach the dock and thus the keyboard/mouse, which worked. Charging works. I tried plugging an ethernet cable into the dock, which...I don't know if that worked? There wasn't any feedback on the OS.

The only thing that doesn't work is, well, the thing that makes it a mobile phone. Cellular data has a clear slash through it in the top bar of Mobian.

I've tried installing the Modemmanger GUI, and it tells me "No devices found in system". Like it can't detect that the modem lives?

I tried going to King's Cross, typing in:

sudo systemctl enable modemmanager
sudo systemctl enable modem-manager
sudo systemctl stop ofono
sudo systemctl enable networkmanager

The result is the same: ".service could not be found".

I would have tried entering the APN, but because it doesn't detect a WWAN, there's no other options in settings, so I guess I can't do that.

Can anyone help me?
Have you tried to toggle the hardware switch for the modem (switch #1)?

If that does not work the next thing I would try is to flash an OS to a uSD and boot from it to see if it recognizes the modem.

If it still is not booting you may want to look at a firmware recovery method:

(There are 2 ways to unlock the bootloader, I recommend shorting the pins rather than the ADB method but it depends on what's easiest for you.)

I broke my modem's firmware a while back and managed a reasonable recovery using Biktorgj's procedure. Wink

This command will power cycle the modem on Mobian. Commands are case-sensitive.

sudo systemctl restart eg25-manager.service

Then check the log by running:

sudo journalctl -u eg25-manager.service -n 100

If the modem is detected you will get something like this
systemd[1]: Stopped Quectel EG25 modem.
systemd[1]: Started Quectel EG25 modem.
eg25manager[5586]: Opening config file: /usr/share/eg25-manager/pine64,pinephone-1.2.toml
eg25manager[5586]: Starting modem...
eg25manager[5586]: Executed power-on/off sequence
eg25manager[5586]: taking systemd sleep inhibitor
eg25manager[5586]: ModemManager appeared on D-Bus
eg25manager[5586]: inhibitor sleep fd is 21
eg25manager[5586]: Response: [RDY]
eg25manager[5586]: taking systemd sleep inhibitor (blocking)
eg25manager[5586]: inhibitor block fd is 20
eg25manager[5586]: ModemManager object `/org/freedesktop/ModemManager1/Modem/3' added
eg25manager[5586]: ModemManager interface `org.freedesktop.ModemManager1.Modem.Simple' found on object `/org/freedesktop/ModemManager1/Modem/3'
eg25manager[5586]: ModemManager interface `org.freedesktop.ModemManager1.Modem.Firmware' found on object `/org/freedesktop/ModemManager1/Modem/3'
eg25manager[5586]: ModemManager interface `org.freedesktop.ModemManager1.Modem.Modem3gpp' found on object `/org/freedesktop/ModemManager1/Modem/3'
eg25manager[5586]: ModemManager interface `org.freedesktop.ModemManager1.Modem.Voice' found on object `/org/freedesktop/ModemManager1/Modem/3'
eg25manager[5586]: ModemManager interface `org.freedesktop.ModemManager1.Modem.Time' found on object `/org/freedesktop/ModemManager1/Modem/3'
eg25manager[5586]: ModemManager interface `org.freedesktop.ModemManager1.Modem' found on object `/org/freedesktop/ModemManager1/Modem/3'
eg25manager[5586]: Adding new modem `/org/freedesktop/ModemManager1/Modem/3'

If it did not work, posting a log might help figure out the situation.
Ended up RMA-ing it. Board was dead. Got replacement, and works now.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Can't get Mobian on PinePhone to recognise USB-C docking bar duncan_bayne 9 5,708 12-04-2023, 02:14 AM
Last Post: Peter Gamma
  Mobian PIN changed after update! Mwo87 21 15,408 12-02-2023, 11:53 PM
Last Post: Karrenbrady
  how to backup user data? Uturn 1 437 08-30-2023, 05:23 AM
Last Post: Kevin Kofler
  New Zealand network providers mobile data Linux2thabone 3 2,968 08-05-2023, 06:17 AM
Last Post: SchizoPinePhone225
  US cellular service (as I understand it as of post date) freebsd 17 8,092 07-23-2023, 04:57 PM
Last Post: kb-zealot
  No sound after Mobian upgrade arbocenc 1 567 11-28-2022, 11:02 AM
Last Post: arbocenc
Exclamation No wIfI after Mobian update crakabeats 3 1,766 11-03-2022, 04:16 AM
Last Post: wifinoworkie
  cell data and MMS on AT+T prepaid ossands 2 1,166 10-13-2022, 07:28 AM
Last Post: ossands
  pinephone-support package not upgradable on Mobian fhireman 4 1,973 09-24-2022, 08:01 AM
Last Post: dante404
  Cannot Remove SIM Adapter CheeseEBoi 1 943 07-09-2022, 04:07 PM
Last Post: mcjonmor

Forum Jump:

Users browsing this thread: 1 Guest(s)