eMMC frequently not found by Linux kernel (especially on low battery)
#11
(10-21-2020, 08:08 AM)Arwen Wrote: @v-man You might modify your "/boot" on the SD card to use the root file system on the eMMC. This might not be too bad as a work around.

This would not work in my case, I suppose, since strangely enough the kernel first started booting, and then the eMMC was not found to mount as the root device. Once the eMMC even 'disappeared' from a running system. I wrote these observations in my first post already, about nine months ago.

Having used the Pinebook running from an SD-Card only, I now finally got myself a replacement eMMC (just 32 GByte again), and in addition the NVMe adapter as well, just to have an alternative in case the eMMC replacement would not solve the problems.

I think the eMMC is more reliable now, but a problem is still there. So far I had four cases where the system would not boot successfully in about two weeks with maybe around 20 boots. The situation is different from before: I switched to Armbian (Debian Bullseye, by updating from the Buster image), which is working quite well. When the system hangs during boot-up, the screen stays completely blank (whereas before I would already get console output). At least last time, maybe before as well, the LED stayed red, did not even turn green, so I guess the Linux kernel was not even found?

Somewhere I read a comment about "silicon lottery" with the PineBookPro... and I guess I'm not a winner in this. ;-)

Especially in cases where the PineBook gets stuck some output on the display would be nice. Too bad, progress with u-boot is not fast enough for this to have come to Armbian or Manjaro images yet.

But my PineBook is quite usable again. Smile I also have a 'powerbank' now, a 10.000 mAh usb charger, which I need for my half-broken old Android phone anyway. This could probably help me boot the PineBook if at some point it won't boot without extra power, and I'm not near a power outlet.
  Reply
#12
Quote:Especially in cases where the PineBook gets stuck some output on the display would be nice. Too bad, progress with u-boot is not fast enough for this to have come to Armbian or Manjaro images yet.

You can get early (initrd) console output if you build a Manjaro image with encryption enabled, this was enabled to show the cryptsetup password prompt correctly. This isn't working yet in Armbian (https://forum.armbian.com/topic/17367-lu...pro-focal/).

Manjaro installer Instructions here: https://gitlab.manjaro.org/manjaro-arm/a...-installer
Background on that early boot work: https://forum.pine64.org/showthread.php?tid=9052

I've also been wrestling with the same behaviour of inconsistent eMMC booting when not plugged into the mains power. I'm now going to switch to Manjaro w/ LUKS so I get the console messages early on and see if that sheds any light on the problem day to day. I have noticed over the UART serial console that sometimes the eMMC is just not visible at all.
  Reply
#13
I am having this same issue. My pbp is from the latest batch. The power level doesn't matter. It can happen at 100% battery and plugged in.

The initrd output in manjaro explains that the EMMC can't be found.

I have tried uboot that came with manjaro, twisteros, the bsp uboot, and a random one from the internet. I get this problem more times than not.

Sometimes after the monitor outputs a few failed attempts, it finds the emmc and boots.

Also when booting from sd, the emmc doesn't appear as attached.

How can I make the uboot keep trying indefinitely? Has another solution been found? It's pretty annoying to have to attempt booting 6 times.
  Reply
#14
@djhnsn  Their is an experimental version of U-Boot which supports NVMe, USB and video menus, as well as installation in SPI flash. It may work for you. I tried it, and worked okay. But, I had some other specialty things so I more or less returned to the normal U-Boot.

Here is a link to the thread, (I think), that describes it;
https://forum.pine64.org/showthread.php?tid=10694
--
Arwen Evenstar
Princess of Rivendale
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Question Building custom kernel (5.11.x) for Manjaro? ppafin 0 76 05-07-2021, 11:44 PM
Last Post: ppafin
  NVMe timeout when booting from eMMC but not SD satwell 4 1,142 05-06-2021, 10:12 AM
Last Post: alexeymin
  A true mainline Linux Kernel for the Pinebook Pro tsys 152 83,400 04-26-2021, 04:38 PM
Last Post: kalpazanius
  Battery charge threshold xNix 1 242 04-17-2021, 07:13 AM
Last Post: Damon
  Battery gauge issue (mainline kernel) lfourquaux 0 201 04-03-2021, 10:12 AM
Last Post: lfourquaux
  Kali Linux password fail Wawe 5 811 03-23-2021, 11:09 AM
Last Post: Wawe
Question Manjaro arm + sway - battery indicator broken mfashby 6 1,123 02-20-2021, 04:07 AM
Last Post: mfashby
  Effects of adjusting coherent_pool kernel parameter value moonwalkers 3 664 02-12-2021, 03:13 PM
Last Post: xyzzy
  PBP won't boot from eMMC or SD card: a saga archaicmeander 18 2,203 02-06-2021, 07:40 PM
Last Post: wdt
  kernel module that supports usb-c hdmi alexandre 12 2,139 01-31-2021, 08:01 AM
Last Post: alexandre

Forum Jump:


Users browsing this thread: 1 Guest(s)