[split] U-Boot with NVMe support, keyboard & display working
#1
This was just posted by @sigmaris on IRC.

https://lists.denx.de/pipermail/u-boot/2...07894.html

And the patches (quite fresh):

http://people.hupstream.com/~rtp/pbp/20200706/patches/
  Reply
#2
Actually, I'd put the builtin USB keyboard at a higher priority than the eDP.

With USB keyboard support, (builtin and or external), we can setup a sequence of events at boot:
  • Pause & blink LED, (which one?), for a short time, (5 seconds?). Perhaps power LED, alternating red & green.
  • During this time, accept keyboard input
  • Select boot device of:
    1. USB
    2. MicroSD card
    3. NVMe
    4. eMMC
With this, we can leave an SD card installed, and over-ride booting to it.

Or even allow re-arranging the default boot order to be fastest first, since we can select something else if needed.
  1. NVMe
  2. eMMC
  3. MicroSD card
  4. USB
--
Arwen Evenstar
Princess of Rivendale
  Reply
#3
I tried to build uboot with patches from @pcm720 + patches from Arnaud to enable eDP support in uboot.

I failed miserably. All the patches apply correctly (on top of 2020.07) and uboot builds ok but resulting SPI image does not boot. Probably something missing in config.

Unfortunately i'm away from home and don't have my serial cable with me Sad
  Reply
#4
OK, so I finally was able to build working (sort of) uboot with nvme boot, display and keyboard thanks to Arnaud and @samueldr work.

It boots my 5.8-rc5 but inconsistently. In 15 tries I have 5 failed boots.

If someone is brave enough to test it - I can share SPI image or images for SD/eMMC.
  Reply
#5
(07-15-2020, 12:59 PM)as400 Wrote: OK, so I finally was able to build working (sort of) uboot with nvme boot, display and keyboard thanks to Arnaud and @samueldr work.

It boots my 5.8-rc5 but inconsistently. In 15 tries I have 5 failed boots.

If someone is brave enough to test it - I can share SPI image or images for SD/eMMC.
I'd be happy to try the SPIFLASH build--I can always back it off and rewrite the working one.  I do have serial output enabled so I can probably help debug.  if you are still without your serial cable.   I would be using a standard Manjaro 5.7 kernel.  I think we are using the same brand/model of NVME  SBXe  except mine is only a 480G.
  Reply
#6
@as400, Is there really any reason why it can't be on the eMMC for testing?

Even if testing, (and further modifications), takes months, putting on the eMMC is both easier to recover, (via the disable switch). And might actually be faster. Whence it's working with all the features we want, then put it in the SPI.

As for the display and keyboard support, wonderful.
Now can I get greedy and ask for a simple menu to select the boot device?
Then a timeout to boot the default order, (whatever that ends up being).
--
Arwen Evenstar
Princess of Rivendale
  Reply
#7
EDIT 16.07.2020 - included images with menu

EDIT 29.07.2020 - new version posted on page 3


So if someone wants to test here are the images (there is NVME boot included in all of them):

REMOVED

Maybe we should move this discussion to another thread so we don't hijack this one ? @Arwen  ?
  Reply
#8
@as400, Split done.

Notify other user, @belfastraven

On the main subject, I'll try and see if I have time over the next week to install and test.
--
Arwen Evenstar
Princess of Rivendale
  Reply
#9
Great - testing needed.
Especially those random kernel lockups are annoying.
  Reply
#10
@as400, oh, in my rush to learn forum post splitting, I forgot to say;

Thank you!
--
Arwen Evenstar
Princess of Rivendale
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  uboot wont boot to SD card after upgrade jbradley419 7 771 01-19-2024, 02:29 PM
Last Post: wdt
  Video Flashing/adjusting on boot and reboot jbradley419 0 281 01-16-2024, 09:17 AM
Last Post: jbradley419
  Brand new Pinebook Pro doesn't boot after Manjaro update johnboiles 8 2,190 12-15-2023, 02:11 PM
Last Post: wdt
  PBP won't boot after trying to reinstall Manjaro ARM soupgirl 3 669 12-13-2023, 08:17 PM
Last Post: trillobite
  Various freezes during boot & while running several Linux distros - hardware error? donuts 1 572 11-22-2023, 11:47 AM
Last Post: fxc
  Selling my Pinebook Pro with a bootable NVMe WD SSD drive pinemouth 0 751 09-27-2023, 08:53 PM
Last Post: pinemouth
  Cannot boot to Kali SD card after uboot upgrade jbradley419 4 1,155 09-19-2023, 08:48 AM
Last Post: dachalife
  Dead Pinebook Pro Keyboard Keys calinb 2 1,038 09-02-2023, 12:31 PM
Last Post: calinb
  Does latest Tow-Boot install/work correctly for everyone? tophneal 4 1,849 08-03-2023, 03:30 PM
Last Post: tophneal
  power on Pinebook Pro mainboard without keyboard? papable 0 833 07-20-2023, 11:06 PM
Last Post: papable

Forum Jump:


Users browsing this thread: 1 Guest(s)