screen doesn't turn on atll
#1
Hi, my pinebook pro recently stopped working.

Symptoms:
1. when https://forum.pine64.org/member.phpbooting from built in memory, power led lights red and thats all - there is no image on the display (display does not turn on at all)
2. when booting from sd card with manjaro, pinebook turns on, power led starts red, but after some time turns green. Then i can toggle num lock/caps lock leds (works with both internal and external keyboard), but still - display is not enabled.

I've tried starting pinebook using either original adapter or usb c power adapter or with no external power - no luck.

Additionally I've tried to turn on pinebook with all internal plugs disconnected (excluding display and keyboard), but this changed nothing.

Before the notebook stopped working I've replaced default, old manjaro repositories with new and started update. The update failed to updated some things (cant remember which, but I don't remember it being anything important/system related). I can't remember exactly- I think after the update i managed to reboot the netbook, but something was not working so I decided to make clean install using SD card. I mange to boot into GUI from SD card, copy files from  /home to NVMe drive. Then i flashed manjaro installer onto sd card and installed the OS. It finished, but i couldn't boot OS (there were some glitches). I switched  sd cards (the same model) and repeated process with the second card.

At some point the display stopped turning on. 

I have soldered myself audio->uart adapter, switched internal uart switch, but i got no luck seeing any messages on the debug console (maybe i have to do something to enable debug output?)

Is there anything i can do to debug/repair the problem?

Thanks in advance for your help ;]


Possibly Related Threads…
Thread Author Replies Views Last Post
  Screen refresh delay with kernel errors shawnanastasio 31 16,516 04-27-2021, 02:57 AM
Last Post: james64
  Pinebook Pro won't turn on when unplugged decisivedove 7 2,793 02-28-2021, 09:44 AM
Last Post: mattpenn
  Forgot my Pinebook password. Booting from MIcroSD doesn't work. ksfoodforest 0 461 01-30-2021, 11:08 AM
Last Post: ksfoodforest
  Novice question: Pinebook Pro does boot (does it?) but black screen Gert V. 21 4,853 01-27-2021, 10:48 PM
Last Post: rimaille
  Screen flicker with USB-C charging bchenlee609 5 1,497 01-25-2021, 08:48 PM
Last Post: bchenlee609
  HELP: PBP screen blanked iscmob 5 1,059 01-19-2021, 10:00 AM
Last Post: KC9UDX
  All White Screen on Manjaro I3 nomadicoder 1 1,040 12-31-2020, 11:44 AM
Last Post: nomadicoder
  NVMe doesn't show up Seferi 19 6,092 10-30-2020, 07:08 AM
Last Post: ReddestDream
  Screen adjustment michael82 16 7,291 10-21-2020, 09:22 AM
Last Post: moonwalkers
Photo Remove activity manager bar on right side of screen - plasma kde motezart 3 1,527 10-20-2020, 10:36 AM
Last Post: motezart

Forum Jump:


Users browsing this thread: 1 Guest(s)