emmc image will not flash
#1
if I load (on OSX, with Balena Etcher or Pine64 Installer) Manjaro-ARM-xfce-pbpro-20.02-emmc-installer-20.02.img.xz to my SDcard and boot my PBP, i will see the Manjaro logo plus spinning circles for ever ( 2 hours then stopped ). Images like Manjaro-ARM-xfce-pbpro-20.02.1.img.xz however will boot ok but I don't know how to flash that on the emmc.
What am I missing in the process of flashing to emmc?
#2
There are 3 options maybe more hopefully someone with more experience can chime in. The first one I haven't tried. Because you downloaded the emmc one and it's now booting from sdcard I think when you first power up after the first 10 seconds of black screen you press ESC and it should start the installer.

Option 2 is to get a usb emmc adapter and flash to emmc using Etcher.

Option 3 is after you booted Manjaro from sdcard download the image again and dd it to your emmc, once completed power down then remove sdcard and power back up. In this thread look at post#7 and replace the debian image with your Manjaro image in the wording of the code.
https://forum.pine64.org/showthread.php?tid=8229
Hope this helps.
#3
There's a known bug in the Majaro image.
It remains stuck on the logo, a simple press on escape should make you see the menu.


too slow Big Grin
#4
'simple press on escape' helped. Now, if oly I knew if to point at mmcblk2 or mmcblk2boot0 or mmcblk2boot1 (or mmcblk1 which is the SD card?
#5
selected mmcblk2 and it works very well, Thanks to all!
#6
(03-25-2020, 03:32 AM)FeMike Wrote: There are 3 options maybe more hopefully someone with more experience can chime in. The first one I haven't tried. Because you downloaded the emmc one and it's now booting from sdcard I think when you first power up after the first 10 seconds of black screen you press ESC and it should start the installer.

Option 2 is to get a usb emmc adapter and flash to emmc using Etcher.

Option 3 is after you booted Manjaro from sdcard download the image again and dd it to your emmc, once completed power down then remove sdcard and power back up. In this thread look at post#7 and replace the debian image with your Manjaro image in the wording of the code.
https://forum.pine64.org/showthread.php?tid=8229
Hope this helps.

Thank you option 2 worked for me
#7
(03-28-2020, 12:35 PM)SlowJoe Wrote:
(03-25-2020, 03:32 AM)FeMike Wrote: There are 3 options maybe more hopefully someone with more experience can chime in. The first one I haven't tried. Because you downloaded the emmc one and it's now booting from sdcard I think when you first power up after the first 10 seconds of black screen you press ESC and it should start the installer.

Option 2 is to get a usb emmc adapter and flash to emmc using Etcher.

Option 3 is after you booted Manjaro from sdcard download the image again and dd it to your emmc, once completed power down then remove sdcard and power back up. In this thread look at post#7 and replace the debian image with your Manjaro image in the wording of the code.
https://forum.pine64.org/showthread.php?tid=8229
Hope this helps.

Thank you option 2 worked for me

Which adapter did you use? I only ask as I have lost the one I purchased from pine store.
#8
(04-02-2020, 04:05 AM)FeMike Wrote:
(03-28-2020, 12:35 PM)SlowJoe Wrote:
(03-25-2020, 03:32 AM)FeMike Wrote: There are 3 options maybe more hopefully someone with more experience can chime in. The first one I haven't tried. Because you downloaded the emmc one and it's now booting from sdcard I think when you first power up after the first 10 seconds of black screen you press ESC and it should start the installer.

Option 2 is to get a usb emmc adapter and flash to emmc using Etcher.

Option 3 is after you booted Manjaro from sdcard download the image again and dd it to your emmc, once completed power down then remove sdcard and power back up. In this thread look at post#7 and replace the debian image with your Manjaro image in the wording of the code.
https://forum.pine64.org/showthread.php?tid=8229
Hope this helps.

Thank you option 2 worked for me

Which adapter did you use? I only ask as I have lost the one I purchased from pine store.

I got mine from here but I believe the pine store is cheaper. I saw a thread somewhere here where there is a list of other sources for the adapter.
https://www.joom.com/en/products/1514200...3155020101
#9
(04-02-2020, 04:42 AM)SlowJoe Wrote:
(04-02-2020, 04:05 AM)FeMike Wrote:
(03-28-2020, 12:35 PM)SlowJoe Wrote:
(03-25-2020, 03:32 AM)FeMike Wrote: There are 3 options maybe more hopefully someone with more experience can chime in. The first one I haven't tried. Because you downloaded the emmc one and it's now booting from sdcard I think when you first power up after the first 10 seconds of black screen you press ESC and it should start the installer.

Option 2 is to get a usb emmc adapter and flash to emmc using Etcher.

Option 3 is after you booted Manjaro from sdcard download the image again and dd it to your emmc, once completed power down then remove sdcard and power back up. In this thread look at post#7 and replace the debian image with your Manjaro image in the wording of the code.
https://forum.pine64.org/showthread.php?tid=8229
Hope this helps.

Thank you option 2 worked for me

Which adapter did you use? I only ask as I have lost the one I purchased from pine store.

I got mine from here but I believe the pine store is cheaper. I saw a thread somewhere here where there is a list of other sources for the adapter.
https://www.joom.com/en/products/1514200...3155020101

Thank you, I'll try finding the thread. I don't know how long it would take pine to ship another one.
#10
Isn't it easier to work with a micro SD? It also saves you from opening the PBP.


Possibly Related Threads…
Thread Author Replies Views Last Post
  eMMC for Odroid C4 work in PBP? dieselnutjob 6 680 04-05-2022, 10:10 AM
Last Post: jiyong
  Pinebook Pro bricked after flashing eMMC User 24592 0 523 02-17-2022, 07:55 AM
Last Post: User 24592
  2021.10 u-boot broken on emmc clonex10100 3 1,604 12-14-2021, 04:24 PM
Last Post: jiyong
  U-Boot with direct NVMe boot support for eMMC/SPI Flash pcm720 122 144,249 12-13-2021, 03:48 PM
Last Post: wdt
Question Just purchased a used PBP (with no eMMC!) - any tips for a new user? pinemouth 15 2,912 12-07-2021, 08:23 PM
Last Post: wdt
  eMMC disconnecting for no reason? overlisted 1 864 10-26-2021, 03:08 PM
Last Post: overlisted
  PInebook not booting with eMMC enabled aragaer 4 1,583 10-25-2021, 09:11 PM
Last Post: wdt
  How can I flash SPI so that I can boot from NVMe? codingpanic 5 2,586 08-24-2021, 05:07 AM
Last Post: codingpanic
  Pinebook Pro not powering on when eMMC hardware switch is off vgrimaldi 2 1,409 06-29-2021, 05:19 AM
Last Post: KC9UDX
  UK Pinebook Pro for sale (UK buyers only, 64GB, eMMC reader, NVME add-on) Z0rua 0 1,068 06-01-2021, 12:51 PM
Last Post: Z0rua

Forum Jump:


Users browsing this thread: 1 Guest(s)