How to install Skype on PBP?
#1
When I try to download and install i get the following:

Code:
rock@Debian-Desktop:~/Downloads$ sudo dpkg -i skypeforlinux-64.deb
Selecting previously unselected package skypeforlinux:amd64.
(Reading database ... 131101 files and directories currently installed.)
Preparing to unpack skypeforlinux-64.deb ...
Unpacking skypeforlinux:amd64 (8.55.0.141) ...
dpkg: dependency problems prevent configuration of skypeforlinux:amd64:
skypeforlinux:amd64 depends on libasound2 (>= 1.0.16).
skypeforlinux:amd64 depends on libatk-bridge2.0-0 (>= 2.5.3).
skypeforlinux:amd64 depends on libatk1.0-0 (>= 2.2.0).
skypeforlinux:amd64 depends on libatspi2.0-0 (>= 2.9.90).
skypeforlinux:amd64 depends on libc6 (>= 2.17).
skypeforlinux:amd64 depends on libcairo2 (>= 1.6.0).
skypeforlinux:amd64 depends on libcups2 (>= 1.4.0).
skypeforlinux:amd64 depends on libexpat1 (>= 2.0.1).
skypeforlinux:amd64 depends on libgcc1 (>= 1:3.0).
skypeforlinux:amd64 depends on libgdk-pixbuf2.0-0 (>= 2.22.0).
skypeforlinux:amd64 depends on libglib2.0-0 (>= 2.35.8).
skypeforlinux:amd64 depends on libgtk-3-0 (>= 3.9.10).
skypeforlinux:amd64 depends on libnspr4 (>= 2:4.9-2~).
skypeforlinux:amd64 depends on libnss3 (>= 2:3.22).
skypeforlinux:amd64 depends on libpango-1.0-0 (>= 1.14.0).
skypeforlinux:amd64 depends on libpangocairo-1.0-0 (>= 1.14.0).
skypeforlinux:amd64 depends on libsecret-1-0 (>= 0.18).
skypeforlinux:amd64 depends on libuuid1 (>= 2.16).
skypeforlinux:amd64 depends on libx11-6 (>= 2:1.4.99.1).
skypeforlinux:amd64 depends on libx11-xcb1.
skypeforlinux:amd64 depends on libxcb1 (>= 1.6).
skypeforlinux:amd64 depends on libxcomposite1 (>= 1:0.3-1).
skypeforlinux:amd64 depends on libxcursor1 (>> 1.1.2).
skypeforlinux:amd64 depends on libxdamage1 (>= 1:1.1).
skypeforlinux:amd64 depends on libxext6.
skypeforlinux:amd64 depends on libxfixes3 (>= 1:5.0).
skypeforlinux:amd64 depends on libxi6 (>= 2:1.2.99.4).
skypeforlinux:amd64 depends on libxrandr2 (>= 2:1.2.99.3).
skypeforlinux:amd64 depends on libxrender1.
skypeforlinux:amd64 depends on libxss1.
skypeforlinux:amd64 depends on libxtst6.
skypeforlinux:amd64 depends on apt-transport-https.
skypeforlinux:amd64 depends on libfontconfig1 (>= 2.11.0).
skypeforlinux:amd64 depends on libdbus-1-3 (>= 1.6.18).
skypeforlinux:amd64 depends on libstdc++6 (>= 4.8.1).

dpkg: error processing package skypeforlinux:amd64 (--install):
dependency problems - leaving unconfigured
Processing triggers for desktop-file-utils (0.23-1) ...
Processing triggers for mime-support (3.60) ...
Processing triggers for hicolor-icon-theme (0.15-1) ...
Errors were encountered while processing:
skypeforlinux:amd64
rock@Debian-Desktop:~/Downloads$
#2
Uh, that appears to be trying to download AMD64 files. Pinebook Pros use ARMv8 / ARM 64bit.
--
Arwen Evenstar
Princess of Rivendale
#3
And if you're using the default Debian, you're going to need to be looking for the armhf version of the package(s).
#4
I don't think there is an arm64 armhf build of skype, but this may work on Chromium: https://chrome.google.com/webstore/detai...fpfgnpldfl
You can find me on IRC, Discord and Twitter


#5
(01-20-2020, 01:06 PM)tophneal Wrote: And if you're using the default Debian, you're going to need to be looking for the armhf version of the package(s).

Yes I'm using default everything. I won't change that as I want to remain on what Pine64 devs setup by default.

That said, I plan to use this laptop daily but fore light apps. What I need are:

Skype
Dropbox (sync app)
Termius

Possible with default setup? If not, any workarounds?
#6
(01-20-2020, 02:04 PM)james64 Wrote:
(01-20-2020, 01:06 PM)tophneal Wrote: And if you're using the default Debian, you're going to need to be looking for the armhf version of the package(s).

Yes I'm using default everything. I won't change that as I want to remain on what Pine64 devs setup by default.

That said, I plan to use this laptop daily but fore light apps. What I need are:

Skype
Dropbox (sync app)
Termius

Possible with default setup? If not, any workarounds?

Hard to say for sure, as I personally switched to Chromium/Manjaro, but if you can't find those for Linux, there is an Android image you could use.
#7
(01-20-2020, 01:10 PM)Luke Wrote: I don't think there is an arm64 armhf build of skype, but this may work on Chromium: https://chrome.google.com/webstore/detai...fpfgnpldfl

Thanks, works. Anyway to launch at boot or when opening Chromium?

I'm using Remmina for now as I cannot get Termius installed. 

Dropbox, no luck. I can access the files via website but really would like to save locally when editing files/code. So need to gett dropbox installed.
#8
Chromium apps should be visible the same as other apps, and appear in your Menu. You should also be able to set it as a Startup Application.
#9
(01-21-2020, 07:10 AM)tophneal Wrote: Chromium apps should be visible the same as other apps, and appear in your Menu. You should also be able to set it as a Startup Application.

It does not show up. Remember I'm using the recommended Chromium Browser extension. Not the Chromium OS.
#10
(01-21-2020, 08:49 AM)james64 Wrote:
(01-21-2020, 07:10 AM)tophneal Wrote: Chromium apps should be visible the same as other apps, and appear in your Menu. You should also be able to set it as a Startup Application.

It does not show up. Remember I'm using the recommended Chromium Browser extension. Not the Chromium OS.

It should still show up. I use Chromium in my Manjaro install, and the apps I install are available through my menu, and can be added to the dock. If they don't appear on their own, or are just hard too find (sometimes the app category is WAY off) you also go to the Extensions page in Chromium, right click on SKype, and select Create Shortcut. That will put it in the Menu and make it available to put into the dock/panel.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Fresh Manjaro+KDE install, strange bug hovering over the interfaces-systray icon QuinTeknoLife 1 261 04-29-2021, 07:13 PM
Last Post: carlosqueso
Heart PBP Arrives Tmmro, Manjaro 20.12 xfce, Seeking Install Notes/Tips/Tricks/Advice SpaceLord 4 708 03-01-2021, 06:00 PM
Last Post: SpaceLord
  Install Manjaro from SD motezart 2 817 12-22-2020, 07:11 PM
Last Post: jiyong
  trying to install packages to debian onlyjediontheweekend 1 718 12-09-2020, 03:25 PM
Last Post: nas
  Possible to install KDE Neon on PinebookPro? Pinoideae 11 3,200 10-27-2020, 10:09 AM
Last Post: firefox-58
  Failing to install usb wifi adapter Debian older PBP AaronMFeld 0 719 09-14-2020, 07:42 PM
Last Post: AaronMFeld
  Does anyone know if it is possible to install a devuan gnu/linux ? erosketak 5 2,637 08-19-2020, 11:46 AM
Last Post: xmixahlx
  I have a manjaro 20.03 install from march, now pacman does not work Ilia3101 5 2,513 08-17-2020, 02:19 AM
Last Post: erchache2000
  Failure to install gcc hvdkooij 1 921 07-22-2020, 08:29 AM
Last Post: slyecho
  Can't install Manjaro Bismarck 10 4,404 07-06-2020, 05:03 PM
Last Post: Bismarck

Forum Jump:


Users browsing this thread: 1 Guest(s)