Armbian for the Pinebook Pro [WIP]
#21
perhaps my experience is an outlier, but when i tried armbian the wireless didn't work, and it also didn't have u-boot to boot from SD card.
  Reply
#22
(02-05-2020, 09:18 PM)xmixahlx Wrote: perhaps my experience is an outlier, but when i tried armbian the wireless didn't work, and it also didn't have u-boot to boot from SD card.

Maybe it is because you run Armbian Debian? I use Armbian Ubuntu and wireless works without a problem.
  Reply
#23
i did download armbian debian, yes.
  Reply
#24
(02-06-2020, 01:27 AM)xmixahlx Wrote: i did download armbian debian, yes.

I also tried both versions of Armbian. Wifi did not work on Debian version but is fine on Ubuntu. 

Armbian Ubuntu has no way to get battery status, and has some problems with video/audio causing it to lock up when watching in a browser. It is the only version that I have tried that has Wireguard capability. Most everything works when installing from the supplied packages. It is also the smoothest and probably the most responsive of the distributions that I have tried. The 64 bit arm requirement means that some programs are just not available yet (Vivaldi browser for example). The screen brightness keys need a file to be added ( /etc/X11/xorg.conf ) that is documented in the posts. 

I would be using it as my default distribution if the battery status was available in some manner. 

Hope this helps.
  Reply
#25
vivaldi does have arm64 packages. found under snapshots.
  Reply
#26
(02-06-2020, 03:46 PM)xmixahlx Wrote: vivaldi does have arm64 packages. found under snapshots.

Thank you for that information. I don't know why I could not see that on their web page. 

Downloaded, installed, and using Vivaldi for arm64 to send this post! I haven't had much time to use this version of Vivaldi, but the first thing I did was load a bookmarks.html file. It loaded, but when I selected a bookmark it would not load the site. I then tried a sync and that worked and no problems loading the bookmarked sites. 

This moves Arbian closer to being my default distribution. As I said, it is the smoothest and fastest of those that I have tried.

The lack of battery support is still the killer problem however. I will keep using it from an SD card to monitor the progress. As I have managed to get wireguard working in Bionic Mate (Ubuntu), that distro now has all of the features that I want.

Thanks again for your help.
  Reply
#27
(01-22-2020, 03:05 PM)Wizzard Wrote: Nobody using Armbian Ubuntu?
Today I upgraded to 20.04 and it runs fine, accelereation and sound works, battery not. Stella runs fast! Smile

Would you mind to describe briefly how to upgrade with Armbian Ubuntu.
I have no experience with Armbian and experimented a bit with not so much success and don't want to break the system.
  Reply
#28
(02-14-2020, 12:37 PM)Surehand53 Wrote: Would you mind to describe briefly how to upgrade with Armbian Ubuntu.
I have no experience with Armbian and experimented a bit with not so much success and don't want to break the system.

Just edited /etc/apt/sources.list and replaced "bionic" with "focal" and then run: "sudo apt update" and "sudo apt dist-upgrade" and it is, like in regular Ubuntu.
  Reply
#29
(02-14-2020, 01:03 PM)Wizzard Wrote:
(02-14-2020, 12:37 PM)Surehand53 Wrote: Would you mind to describe briefly how to upgrade with Armbian Ubuntu.
I have no experience with Armbian and experimented a bit with not so much success and don't want to break the system.

Just edited /etc/apt/sources.list and replaced "bionic" with "focal" and then run: "sudo apt update" and "sudo apt dist-upgrade" and it is, like in regular Ubuntu.


Hmm. When I do that I get this error message with sudo apt update:

Code:
Traceback (most recent call last):
 File "/usr/lib/cnf-update-db", line 26, in <module>
   col.create(db)
 File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 93, in create
   self._fill_commands(con)
 File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 127, in _fill_commands
   self._parse_single_commands_file(con, fp)
 File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 165, in _parse_single_commands_file
   suite=tagf.section["suite"]
KeyError: 'suite'
Error in sys.excepthook:
Traceback (most recent call last):
 File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 145, in apport_excepthook
   os.O_WRONLY | os.O_CREAT | os.O_EXCL, 0o640), 'wb') as f:
FileNotFoundError: [Errno 2] No such file or directory: '/var/crash/_usr_lib_cnf-update-db.0.crash'

Original exception was:
Traceback (most recent call last):
 File "/usr/lib/cnf-update-db", line 26, in <module>
   col.create(db)
 File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 93, in create
   self._fill_commands(con)
 File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 127, in _fill_commands
   self._parse_single_commands_file(con, fp)
 File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 165, in _parse_single_commands_file
   suite=tagf.section["suite"]
KeyError: 'suite'
Reading package lists... Done
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/lib/command-not-found/ -a -e /usr/lib/cnf-update-db; then /usr/lib/cnf-update-db > /dev/null; fi'
E: Sub-process returned an error code


Something with Python it seems.
This is basically a fresh install, nothing changed really.

Any idea?
  Reply
#30
I get the same, but I can upgrade anyway.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  pinebook pro tools xmixahlx 51 25,261 04-05-2021, 09:22 AM
Last Post: mjhammel
  An unofficial Debian Installer for Pinebook Pro danielt 437 177,545 03-25-2021, 04:29 AM
Last Post: ab1jx
  postmarketOS/Alpine edge image for the Pinebook Pro MartijnBraam 63 36,560 03-14-2021, 05:26 AM
Last Post: MartijnBraam
Sad Help me w/ my Pinebook Pro setup Lyrixcaz 4 459 03-11-2021, 12:58 PM
Last Post: moonwalkers
  OpenMandriva to release ARM builds for PineBook Pro and Pi ludix 11 1,566 03-02-2021, 07:06 PM
Last Post: BronzeBeard
  Pinebook Pro wifi not working seyo-iv 1 365 02-01-2021, 11:00 AM
Last Post: seyo-iv
  slarm64 (unofficial slackware) Pinebook Pro RK3399 (aarch64) mara 25 5,142 01-30-2021, 11:03 AM
Last Post: mara
  volume keys on armbian pine76 0 250 01-23-2021, 08:03 AM
Last Post: pine76
  FLOSS pinebook pro linux set-up misha64 3 1,416 01-14-2021, 04:05 PM
Last Post: kuleszdl
  My Debian journey on the Pinebook Pro schwarzwieweiss 32 5,434 01-07-2021, 09:35 AM
Last Post: schwarzwieweiss

Forum Jump:


Users browsing this thread: 2 Guest(s)