Armbian for the Pinebook Pro [WIP]
#1
WIP Armbian OS images for the Pinebook Pro are now available.

Download Page
You can find me on IRC, Discord and Twitter


  Reply
#2
very pleased with the pace of things with the pbp, i haven't seen anything like it before outside raspberry pi stuff. i'm spending a lot of time lurking here just to see things develop in front on my eyes.
  Reply
#3
Looks good for now. Konsole does not crash on dmesg, Stella runs fine on software rendering, Kubuntu PPA works fine. Tomorrow I can try KDE Neon and upgrade to 19.10. For now, it looks very stable and usable. OpenGL renderer is just llvmpipe, but the performance is nice.

edit: sound does not seem to work
edit2: neither I do not see the battery percentage
edit3: sleep is not supported (or disabled)
  Reply
#4
(01-19-2020, 04:05 PM)Wizzard Wrote: Looks good for now. Konsole does not crash on dmesg, Stella runs fine on software rendering, Kubuntu PPA works fine. Tomorrow I can try KDE Neon and upgrade to 19.10. For now, it looks very stable and usable. OpenGL renderer is just llvmpipe, but the performance is nice.

edit: sound does not seem to work
edit2: neither I do not see the battery percentage
edit3: sleep is not supported (or disabled)

You checked the Bionic image, right? On Buster I had a problem with wifi, but the whole overall also looked good (also without sound, battery and sleep).
  Reply
#5
Yes, Bionic, I installed all of the KDE packages I use on regular Ubuntu install. Will play with that tonight to check the sound issue.
  Reply
#6
Ok, so this is what I found;
- there is no problem upgrading to 19.10 also with Kubuntu PPA enabled
- sound works after some playing. I installed all Phonon packages and played with Audio settings in KDE and it finally works.
- Stella finally runs at full speed also in OpenGL and OpenGL ES mode
- Konsole does not crash on dmesg command
- I can install Krita (there is arm64 package available)
- Sleep mode is supported (but waking up does not work, there are some error messages in console after and I have to reboot)
- battery status is not shown yet

This looks to be an ideal OS for me so far.

Also, I am trying to solve this issue:

Code:
sudo apt update               
Hit:1 http://ppa.launchpad.net/kubuntu-ppa/backports/ubuntu eoan InRelease
Hit:2 http://ports.ubuntu.com/ubuntu-ports eoan InRelease
Hit:4 http://ports.ubuntu.com/ubuntu-ports eoan-security InRelease                     
Hit:5 http://ppa.launchpad.net/libretro/stable/ubuntu eoan InRelease               
Hit:6 http://ports.ubuntu.com/ubuntu-ports eoan-updates InRelease
Hit:7 http://ports.ubuntu.com/ubuntu-ports eoan-backports InRelease                    
Hit:8 http://ports.ubuntu.com/ubuntu-ports eoan-proposed InRelease                     
Hit:3 https://apt.armbian.com eoan InRelease                                           
Traceback (most recent call last):                                    
  File "/usr/lib/cnf-update-db", line 26, in <module>
    col.create(db)
  File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 93, in create
    self._fill_commands(con)
  File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 127, in _fill_commands
    self._parse_single_commands_file(con, fp)
  File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 165, in _parse_single_commands_file
    suite=tagf.section["suite"]
KeyError: 'suite'
Error in sys.excepthook:
Traceback (most recent call last):
  File "/usr/lib/python3/dist-packages/apport_python_hook.py", line 145, in apport_excepthook
    os.O_WRONLY | os.O_CREAT | os.O_EXCL, 0o640), 'wb') as f:
FileNotFoundError: [Errno 2] No such file or directory: '/var/crash/_usr_lib_cnf-update-db.0.crash'

Original exception was:
Traceback (most recent call last):
  File "/usr/lib/cnf-update-db", line 26, in <module>
    col.create(db)
  File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 93, in create
    self._fill_commands(con)
  File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 127, in _fill_commands
    self._parse_single_commands_file(con, fp)
  File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 165, in _parse_single_commands_file
    suite=tagf.section["suite"]
KeyError: 'suite'
Reading package lists... Done
E: Problem executing scripts APT::Update::Post-Invoke-Success 'if /usr/bin/test -w /var/lib/command-not-found/ -a -e /usr/lib/cnf-update-db; then /usr/lib/cnf-update-db > /dev/null; fi'
E: Sub-process returned an error code


Attached Files
.png   Screenshot_20200120_203754.png (Size: 58.59 KB / Downloads: 212)
.png   Screenshot_20200120_204036.png (Size: 76.28 KB / Downloads: 202)
  Reply
#7
Armbian, Running debian, not ubuntu. Anyone have any luck getting wifi to connect? it's on, and sees networks, but fails on connection, as if the password was wrong. (It's not, tried three different networks I control, and failed connecting to any of them)


I'd love to have 'pure' debian stable (sort of) running on my pinebook pro, instead of oldstable.
  Reply
#8
Yesterday I made another test with Armbian Ubuntu, installed KDE Neon on Bionic and it also runs well, including acceleration and sound. Sleep does work too, but does not wake up. Battery status does not work.

I found out that the following previous error is caused by changing bionic to eoan of focal in sources list. When I change that, this error appears after running apt update.

Code:
Traceback (most recent call last):                                    
 File "/usr/lib/cnf-update-db", line 26, in <module>
   col.create(db)
 File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 93, in create
   self._fill_commands(con)
 File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 127, in _fill_commands
   self._parse_single_commands_file(con, fp)
 File "/usr/lib/python3/dist-packages/CommandNotFound/db/creator.py", line 165, in _parse_single_commands_file
   suite=tagf.section["suite"]
...
  Reply
#9
Seems that KDE Neon does not have kernel module working.


Attached Files
.png   Screenshot_20200121_184801.png (Size: 57.73 KB / Downloads: 200)
  Reply
#10
Nobody using Armbian Ubuntu?
Today I upgraded to 20.04 and it runs fine, accelereation and sound works, battery not. Stella runs fast! Smile
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  pinebook pro tools xmixahlx 51 25,600 04-05-2021, 09:22 AM
Last Post: mjhammel
  An unofficial Debian Installer for Pinebook Pro danielt 437 177,801 03-25-2021, 04:29 AM
Last Post: ab1jx
  postmarketOS/Alpine edge image for the Pinebook Pro MartijnBraam 63 36,803 03-14-2021, 05:26 AM
Last Post: MartijnBraam
Sad Help me w/ my Pinebook Pro setup Lyrixcaz 4 483 03-11-2021, 12:58 PM
Last Post: moonwalkers
  OpenMandriva to release ARM builds for PineBook Pro and Pi ludix 11 1,614 03-02-2021, 07:06 PM
Last Post: BronzeBeard
  Pinebook Pro wifi not working seyo-iv 1 376 02-01-2021, 11:00 AM
Last Post: seyo-iv
  slarm64 (unofficial slackware) Pinebook Pro RK3399 (aarch64) mara 25 5,252 01-30-2021, 11:03 AM
Last Post: mara
  volume keys on armbian pine76 0 254 01-23-2021, 08:03 AM
Last Post: pine76
  FLOSS pinebook pro linux set-up misha64 3 1,436 01-14-2021, 04:05 PM
Last Post: kuleszdl
  My Debian journey on the Pinebook Pro schwarzwieweiss 32 5,529 01-07-2021, 09:35 AM
Last Post: schwarzwieweiss

Forum Jump:


Users browsing this thread: 1 Guest(s)