Fresh Manjaro does not boot from eMMC
#1
Hi,

I put Tow-boot on the SPI. Then I flashed Manjaro-ARM-gnome-pbpro-22.02.img to a SD card, booted from it and used the manjaro-arm-installer to put Manjaro on my eMMC. I selected the minimal version with FDE. The installer finishes and I turned of the PBP. I removed the SD card and turned it on again. Tow-boot showed up and I pressed ESC to select to boot from eMMC (I guess this is not required since the eMMC is higher up in the boot order than the SD). Booting however fails each time and gives the errors that are visible in the following image: https://imgur.com/Wek8KNw
Did this happen to anyone else? I tried multiple times now with tow-boot and u-boot. I tried with the minimal and gnome versions with and without FDE. Can somebody help please?
  Reply
#2
(03-22-2022, 06:59 PM)pentamassiv Wrote: Hi,

I put Tow-boot on the SPI. Then I flashed Manjaro-ARM-gnome-pbpro-22.02.img to a SD card, booted from it and used the manjaro-arm-installer to put Manjaro on my eMMC. I selected the minimal version with FDE. The installer finishes and I turned of the PBP. I removed the SD card and turned it on again. Tow-boot showed up and I pressed ESC to select to boot from eMMC (I guess this is not required since the eMMC is higher up in the boot order than the SD). Booting however fails each time and gives the errors that are visible in the following image: https://imgur.com/Wek8KNw
Did this happen to anyone else? I tried multiple times now with tow-boot and u-boot. I tried with the minimal and gnome versions with and without FDE. Can somebody help please?

Hello,

I won't be able to help you but similar thing happened to me after I flashed Tow-boot on the SPI. Booting from a USB flash-drive or SD works though.
When listing block devices the eMMC is not showing. Unfortunately I'm out travelling and my USB adapter eMMC module is not with me.
I'll be back home in a couple of weeks and I'll try some things but right now I'm in a bad spot. I remember seeing some error messages showing up regarding the eMMC when booting NixOS from a USB flash-drive.
  Reply
#3
Hi Janoz,
it sounds like there are different underlying issues for our problems. My eMMC shows up when booting from the SD and I also had the same issue even before installing Tow-boot. Maybe the eMMC module became lose while you were traveling?
I don't want to be impolite, but I think it becomes confusing when different problems are discussed in the same thread. Could you possibly open a new thread for your issue?

Regarding my issue, I tried a few more things. Since the error complains about something being wrong with the GPT, I ran
Code:
sudo gdisk /dev/mmcblk2
followed by the commands p and w. I tried booting and it failed with the same error.

WoC suggested in the chat that I should try running gparted. I booted Manjaro from the SD card, installed gparted and mtools and ran gparted. I then checked the partitions. There were no errors or anything. I also decrypted the LUKS partition and checked it. No errors. I also compared the sizes between the partitions on the eMMC and the SD and they are the same sizes (except that the LUKS partition on the eMMC is bigger since the SD only has 16 GB).
  Reply
#4
p and w ??? that would do nothing really, v at least to see what gdisk 'thinks'
maybe i for information, then r -recovery and then v and maybe b (or maybe f)
if v (again) says everything OK, then w
  Reply
#5
(03-22-2022, 06:59 PM)pentamassiv Wrote: Hi,

I put Tow-boot on the SPI. Then I flashed Manjaro-ARM-gnome-pbpro-22.02.img to a SD card, booted from it and used the manjaro-arm-installer to put Manjaro on my eMMC. I selected the minimal version with FDE. The installer finishes and I turned of the PBP. I removed the SD card and turned it on again. Tow-boot showed up and I pressed ESC to select to boot from eMMC (I guess this is not required since the eMMC is higher up in the boot order than the SD). Booting however fails each time and gives the errors that are visible in the following image: https://imgur.com/Wek8KNw
Did this happen to anyone else? I tried multiple times now with tow-boot and u-boot. I tried with the minimal and gnome versions with and without FDE. Can somebody help please?

I currently have the exact same problem, except that I am trying to use the default U-Boot that comes with Manjaro and have nothing on my SPI. I have tried both directly flashing the EMMC and flashing the EMMC from the manjaro-arm-installer (KDE version both times). I have even tried completely zeroing out the EMMC before writing the image, but I still get errors similar to the ones in your photo. Finally, I gave up, and just use Manjaro from a MicroSD card.
  Reply
#6
Well,, you could do it manually, since you have a bootable uSD
gdisk emmc to match SD, expand fs later
then save emmc boot sector, 34 sectors for gpt,,, dd 1st 16M -> emmc, restore emmc bootsector
Then copy partitions, however you like (cp -a, gzip|zcat|dd, clonezilla externally)
then edit extlinux.conf, fstab (or boot.scr??) on emmc
if it doesn't work, you still have SD to fall back to
  Reply
#7
The exact same issue occurs to me as well. I assume it is either Manjaro issue or Tow-Boot issue.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Manjaro PBP stable update 2022-06-19 bricked wpeckham 1 114 06-21-2022, 06:13 PM
Last Post: wpeckham
  How to make manjaro sleep or hibernate? KDE? regretfulpineuser 0 63 06-20-2022, 12:56 AM
Last Post: regretfulpineuser
  Help with Kali Linux wifi not working but works with Manjaro PineSupporter 0 111 05-27-2022, 10:24 PM
Last Post: PineSupporter
  PBP won’t boot from eMMC after Debian update / Tow-Boot installer won’t boot from SD Pino64 21 1,017 05-12-2022, 05:00 AM
Last Post: Pino64
  Broken eMMC boot annahellrothsparent 3 317 04-28-2022, 07:31 AM
Last Post: tophneal
  Manjaro and Arch repository with privacy oriented software as400 86 66,681 04-27-2022, 07:44 AM
Last Post: annahellrothsparent
  Dual boot Manjaro and Debian? dieselnutjob 3 487 03-26-2022, 07:17 AM
Last Post: dieselnutjob
  Pinebook Pro w/ Manjaro KDE Random Freeze/Crash BenniTec 1 472 03-18-2022, 04:03 PM
Last Post: BenniTec
  Manjaro Gnome on Pinebook Pro Review! - My New Favourite Pinebook Pro Distro! ImmyChan 0 490 02-18-2022, 12:59 PM
Last Post: ImmyChan
Question Manjaro with Full Disk Encryption and GRUB dumetrulo 0 533 02-11-2022, 04:21 PM
Last Post: dumetrulo

Forum Jump:


Users browsing this thread: 1 Guest(s)