Manjaro Crashes after entering password.
I bought the Pinebook Pro and was just running the Manjaro Linux default operating system. I installed all of the most amazing programming tools and games and it was running fine....until today. I was trying to install the updates using the default graphical package manager that appears on the desktop. However it just froze during it and I could not even close it or get other things working. So I tried to force a shutdown by holding the power button. Then when I booted it up again and hit enter, it completely froze. I could not login to KDE Plasma anymore. However I had installed the Gnome Desktop environment last month so next time I selected the Gnome session and then entered my password and hit enter. It successfully booted me into Gnome. So I know the problem probably lies with something in KDE.

For now I have a workaround. I ran these commands to disable the default login screen and replace it with gdm.

systemctl disable sddm
systemctl stop sddm
systemctl enable gdm
systemctl start gdm

So I can successfully log into Gnome but only a few of my installed programs load at all. I can browse in firefox, run commands in a terminal, and open the file manager to move files around, but other programs don't open at all from the menu. I'm not sure what went wrong and I spent two hours trying things before giving up for the night. Has anyone else encountered similar problems? I think I may have a half installed update because the crash seemed to happen when I first installed the updates. I broke something and I'll try again when I have the strength. I'm wondering if anyone has any suggestions for how to get things back the way they were.
You could try reinstalling Manjaro. You just need to flash a MicroSD card with a Manjaro eMMC installer image using the dd if command or using GNOME Disks (in which case you would want to restore disk image on the entire device and not just a partition).
I hope it doesn't come to reinstalling especially after installing gigabytes of awesome stuff and customizing it the way I like. However I did discover something. Apparently the KDE environment and some of the other installed environments are using something called wayland. I did get a plasma wayland session installed via pacman so I got a kde environment started, but then guess what, none of my opengl or SDL programs worked under wayland as they appear to depend on xorg instead. I'd like to be able to figure out how I can get everything working because I was using the kate text editor to edit my opengl source code and run it. Now konsole, kate, kwrite, and konqueror don't work under xorg and opengl doesn't work under wayland. I remember the good old days when everything was just xorg and everything worked. Maybe I'm just missing something somehow.

Also, I did put a microsd card into the slot. It's not bootable and I was only using it for extra storage, but if I have that sd card in there, would the dd command work t copy the OS images onto it and then boot from it when rebooting? I'm a little bit afraid to try it because I know that one mistake and typing in the wrong device name would totally blow the whole system and lacking another computer to prepare a bootable sd card I would really screw myself over if I tried that. Still I'm impressed with what the pinebook pro can do although I'm not very good at using it yet.
When your SD card has a different size than your eMMC, you can identify them by typing lsblk on the command line.
One other option is to open Dolphin (file manager) and right click on your removable devices to see the properties.
That way you can see if you have to use /dev/mmcblk1 or 2 with dd.
When you do get everything running the way you want, it's good to make a backup right away so that you don't have to worry about losing anything by reinstalling.
You could try
cd (moves you to ~)
mv .config .config.bak (all files here should be owned by you)
(usually new configs will be automatically made when needed)
login as root, make a new user

Possibly Related Threads…
Thread Author Replies Views Last Post
  Working suspend on Manjaro brzegorz 3 923 12-03-2021, 01:39 PM
Last Post: rik-shaw
  Manjaro -box64 and wine -Help Mangled 0 121 11-20-2021, 01:51 PM
Last Post: Mangled
  RAM deficiency after recent large Manjaro update? stozi 1 174 11-12-2021, 06:19 AM
Last Post: maxjrh
  Yubikey 5C on manjaro zeb11 3 518 10-02-2021, 09:33 AM
Last Post: zeb11
  Manjaro - Internet connection sharing requires dnsmasq (but the dep isn't declared) Dendrocalamus64 0 318 09-11-2021, 05:25 PM
Last Post: Dendrocalamus64
  Pinebook pro nearly unusable after using manjaro-arm-installer TheCounselor 2 1,239 09-07-2021, 08:34 PM
Last Post: TRS-80
  Manjaro and Arch repository with privacy oriented software as400 78 51,657 07-28-2021, 05:24 AM
Last Post: llsf
  Manjaro [ARM Stable Update] 2021-07-23 issues Bocanila 0 457 07-24-2021, 09:09 AM
Last Post: Bocanila
  Sound stuttering on Manjaro gnome after latest kernel upgrade? pjsf 0 561 07-13-2021, 10:37 PM
Last Post: pjsf
  Kernel crash on Manjaro ARM mfashby 0 467 07-06-2021, 03:17 PM
Last Post: mfashby

Forum Jump:

Users browsing this thread: 1 Guest(s)