Boot issue (red light)
#1
I have recently installed a fresh copy of Manjaro using the manjaro-arm-flasher, but when I try to boot the machine it shows a red light on the left status indicator, then I have to wait for a few moments, hold the power button for a couple of seconds and then it gets started with running the OS and showing a green light.

Why is that and how can I fix that so it would start itself directly after the first time I push the start button?

Thanks!
  Reply
#2
>Why is that and how can I fix that
A slightly wrong uboot
install uboot-pinebookpro-bsp
  Reply
#3
(10-27-2020, 09:06 AM)wdt Wrote: >Why is that and how can I fix that
A slightly wrong uboot
install uboot-pinebookpro-bsp

I installed it and the red light thing still happens. What am I doing wrong?
It does boot to the right thing after 20 seconds or so, but before I reflashed the OS it didn't have this lag.
  Reply
#4
Unless they say what the red light means, it's hard to say, obviously turned on by uboot
Do you still have to push pwr button a second time?
Myself, I'm still on uboot from 19.12, on SD, emmc uboot blanked
I think this (19.12) must be bsp uboot because s3 sleep works, not quite as well as mrfixit
  Reply
#5
(10-27-2020, 09:27 PM)wdt Wrote: Unless they say what the red light means, it's hard to say, obviously turned on by uboot
Do you still have to push pwr button a second time?
Myself, I'm still on uboot from 19.12, on SD, emmc uboot blanked
I think this (19.12) must be bsp uboot because s3 sleep works, not quite as well as mrfixit
The red light is on as long as uboot is in command. This takes about 15 seconds on my pbp. As soon as the kernel takes over, the led switches to green.
This behavior has been confirmed by a Manjaro dev (@strit).
  Reply
#6
(10-28-2020, 10:04 AM)vfr400racer Wrote:
(10-27-2020, 09:27 PM)wdt Wrote: Unless they say what the red light means, it's hard to say, obviously turned on by uboot
Do you still have to push pwr button a second time?
Myself, I'm still on uboot from 19.12, on SD, emmc uboot blanked
I think this (19.12) must be bsp uboot because s3 sleep works, not quite as well as mrfixit
The red light is on as long as uboot is in command. This takes about 15 seconds on my pbp. As soon as the kernel takes over, the led switches to green.
This behavior has been confirmed by a Manjaro dev (@strit).
I see. So why was it so much shorter, pretty much immediately green after pressing the boot button, on the default installation coming from pine64 before any modifications? Isn't there a way to redo the same setup?
  Reply
#7
>Isn't there a way to redo the same setup?
Find the package archive on web, it exists,,, OR
In /var/cache/pacman/pkg/uboot-p* I see 6 uboots one is bsp
Earliest mainline is jul31 .....07-1
I am still on original,, 2019,, I have only a 16M dump as backup (but actually that is easier)
But you probably don't have more than 1 or 2
Actually dolphin will offer to install !!! or you can do cmd line way instead
2 gotcha's,,
1st, make a backup of extlinux.conf FIRST,, some change it, wrongly, (LABEL=......)
2nd, only puts them, 2 or 3 files into boot, you have to dd

You can "pull" the archive apart, with a little permission difficulty. put them wherever, which ver is best?
You will have to experiment and find out
("ark" is not capable of dealing with a xz'd tar, so expand 1st, then use ark, it still had to be w/ sudo???)
FWIW
  Reply
#8
You need to install the bsp uboot and ALSO flash it to the emmc drive. See other threads about it on this or the Manjaro forum. Once that is done it works great (here).
  Reply
#9
There seems be another problem related to uboot with the new batch, did you try to reboot your pbp?
Occasionally when I use reboot, I get a grey screen. Appreciate if you could test and report back. Here is the corresponding manjaro thread:
https://forum.manjaro.org/t/problem-with...o/33497/32
  Reply
#10
Yeah I reboot all the time, not sure what it has to do with the issue
I'm not clear on how to get about to resolve this uboot config with the new manjaro installation
Can anybody kindly give advice here?

Thanks
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  U-Boot with direct NVMe boot support for eMMC/SPI Flash pcm720 117 85,433 5 hours ago
Last Post: tophneal
  Pinebook Boot CharlesBunders 12 406 05-09-2021, 08:39 PM
Last Post: CharlesBunders
  Broken Boot djhnsn 15 526 05-05-2021, 04:14 PM
Last Post: djhnsn
  PBP won't boot (no amber or green LED) ian-s-mcb 46 8,910 04-15-2021, 09:58 AM
Last Post: SnowyMountainWeb
  PIneBook Pro - Boot from SD mcdomx 12 9,681 03-29-2021, 01:13 AM
Last Post: 5825bc9762
  Novice question: Pinebook Pro does boot (does it?) but black screen Gert V. 21 3,436 01-27-2021, 10:48 PM
Last Post: rimaille
  [split] U-Boot with NVMe support, keyboard & display working as400 83 31,478 01-27-2021, 12:48 AM
Last Post: as400
  Sudden Pinebook Pro boot problems ndp 3 850 01-21-2021, 09:51 AM
Last Post: ndp
  [SOLVED] Red light flashes next to barrel-port Carl 31 11,618 01-18-2021, 09:34 AM
Last Post: dsimic
  How to determine which U-boot I am using edandjeanmcknight@gmail.com 0 375 01-15-2021, 08:25 AM
Last Post: edandjeanmcknight@gmail.com

Forum Jump:


Users browsing this thread: 1 Guest(s)