Boot issue (red light)
#1
I have recently installed a fresh copy of Manjaro using the manjaro-arm-flasher, but when I try to boot the machine it shows a red light on the left status indicator, then I have to wait for a few moments, hold the power button for a couple of seconds and then it gets started with running the OS and showing a green light.

Why is that and how can I fix that so it would start itself directly after the first time I push the start button?

Thanks!
#2
>Why is that and how can I fix that
A slightly wrong uboot
install uboot-pinebookpro-bsp
#3
(10-27-2020, 09:06 AM)wdt Wrote: >Why is that and how can I fix that
A slightly wrong uboot
install uboot-pinebookpro-bsp

I installed it and the red light thing still happens. What am I doing wrong?
It does boot to the right thing after 20 seconds or so, but before I reflashed the OS it didn't have this lag.
#4
Unless they say what the red light means, it's hard to say, obviously turned on by uboot
Do you still have to push pwr button a second time?
Myself, I'm still on uboot from 19.12, on SD, emmc uboot blanked
I think this (19.12) must be bsp uboot because s3 sleep works, not quite as well as mrfixit
#5
(10-27-2020, 09:27 PM)wdt Wrote: Unless they say what the red light means, it's hard to say, obviously turned on by uboot
Do you still have to push pwr button a second time?
Myself, I'm still on uboot from 19.12, on SD, emmc uboot blanked
I think this (19.12) must be bsp uboot because s3 sleep works, not quite as well as mrfixit
The red light is on as long as uboot is in command. This takes about 15 seconds on my pbp. As soon as the kernel takes over, the led switches to green.
This behavior has been confirmed by a Manjaro dev (@strit).
#6
(10-28-2020, 10:04 AM)vfr400racer Wrote:
(10-27-2020, 09:27 PM)wdt Wrote: Unless they say what the red light means, it's hard to say, obviously turned on by uboot
Do you still have to push pwr button a second time?
Myself, I'm still on uboot from 19.12, on SD, emmc uboot blanked
I think this (19.12) must be bsp uboot because s3 sleep works, not quite as well as mrfixit
The red light is on as long as uboot is in command. This takes about 15 seconds on my pbp. As soon as the kernel takes over, the led switches to green.
This behavior has been confirmed by a Manjaro dev (@strit).
I see. So why was it so much shorter, pretty much immediately green after pressing the boot button, on the default installation coming from pine64 before any modifications? Isn't there a way to redo the same setup?
#7
>Isn't there a way to redo the same setup?
Find the package archive on web, it exists,,, OR
In /var/cache/pacman/pkg/uboot-p* I see 6 uboots one is bsp
Earliest mainline is jul31 .....07-1
I am still on original,, 2019,, I have only a 16M dump as backup (but actually that is easier)
But you probably don't have more than 1 or 2
Actually dolphin will offer to install !!! or you can do cmd line way instead
2 gotcha's,,
1st, make a backup of extlinux.conf FIRST,, some change it, wrongly, (LABEL=......)
2nd, only puts them, 2 or 3 files into boot, you have to dd

You can "pull" the archive apart, with a little permission difficulty. put them wherever, which ver is best?
You will have to experiment and find out
("ark" is not capable of dealing with a xz'd tar, so expand 1st, then use ark, it still had to be w/ sudo???)
FWIW
#8
You need to install the bsp uboot and ALSO flash it to the emmc drive. See other threads about it on this or the Manjaro forum. Once that is done it works great (here).
#9
There seems be another problem related to uboot with the new batch, did you try to reboot your pbp?
Occasionally when I use reboot, I get a grey screen. Appreciate if you could test and report back. Here is the corresponding manjaro thread:
https://forum.manjaro.org/t/problem-with...o/33497/32
#10
Yeah I reboot all the time, not sure what it has to do with the issue
I'm not clear on how to get about to resolve this uboot config with the new manjaro installation
Can anybody kindly give advice here?

Thanks


Possibly Related Threads…
Thread Author Replies Views Last Post
  upgrading u-boot--what version? where to get it? bsammon 11 624 05-22-2024, 09:33 AM
Last Post: wdt
  uboot wont boot to SD card after upgrade jbradley419 7 1,236 01-19-2024, 02:29 PM
Last Post: wdt
  Video Flashing/adjusting on boot and reboot jbradley419 0 414 01-16-2024, 09:17 AM
Last Post: jbradley419
  Brand new Pinebook Pro doesn't boot after Manjaro update johnboiles 8 2,628 12-15-2023, 02:11 PM
Last Post: wdt
  PBP won't boot after trying to reinstall Manjaro ARM soupgirl 3 933 12-13-2023, 08:17 PM
Last Post: trillobite
  Various freezes during boot & while running several Linux distros - hardware error? donuts 1 746 11-22-2023, 11:47 AM
Last Post: fxc
  Cannot boot to Kali SD card after uboot upgrade jbradley419 4 1,423 09-19-2023, 08:48 AM
Last Post: dachalife
  Does latest Tow-Boot install/work correctly for everyone? tophneal 4 2,195 08-03-2023, 03:30 PM
Last Post: tophneal
  Boot into NVME drive, no wifi, sound, buttons... PaulQ 0 902 07-13-2023, 01:50 PM
Last Post: PaulQ
  Blinking Tiny Blue Indicator Light? ArchiMark 3 1,353 06-30-2023, 03:15 PM
Last Post: Samurai_Crow

Forum Jump:


Users browsing this thread: 1 Guest(s)