HELP: PBP screen blanked
#1
HELP: I got Pinebook Pro last May & it's a great. In last Nov Manjaro update, my PBP couldn't work. After  usual login, the screen went blank w a speaker blip. I received help fr the Support to flash  eMMC or boot fr a microSD card. None yield resolution.
I need HELP
  Reply
#2
What *have* you done so far?

You did a November update to Manjaro.

Did you reflash the eMMC?
Did you try to boot from micro SD?

I don't have experience with this problem, but it seems to be widely reported that a Manjaro update can cause your symptom, and that the U-Boot that comes with Manjaro can disallow booting from micro SD.

Have you read any of the other threads here about this?

What I expect is that you'll need to put a bootable image on a micro SD card, disable the eMMC by hardware switch, boot to said SD card, and reflash the eMMC.
  Reply
#3
(01-16-2021, 08:21 AM)KC9UDX Wrote: What *have* you done so far?

You did a November update to Manjaro.

Did you reflash the eMMC?
Did you try to boot from micro SD?

I don't have experience with this problem, but it seems to be widely reported that a Manjaro update can cause your symptom, and that the U-Boot that comes with Manjaro can disallow booting from micro SD.

Have you read any of the other threads here about this? 

What I expect is that you'll need to put a bootable image on a micro SD card, disable the eMMC by hardware switch, boot to said SD card, and reflash the eMMC.
Hi, thanks for your concern.

1. The usual Manjaro software update and rclone backup
But the rclone stuck for a while, so I hit Ctrl-X to exit and reboot PBP manual by pressing the power button.
Once it rebooted and done with the login, the screen went blank after a very soft blip sound from the speaker.

2. Pine Support's advice
I didn't get any advice from the Forum for resolution and I went to the Support.
Support told me to reflash the eMMC. I didn't have a tool. I followed online's advice to reflash the eMMC using a microSD and also boot PBP from a microSD. Both methods couldn't have PBP in Manjaro login with a normal screen. The screen went blank with a soft blip speaker sound after the usual login.
Then Support advised me to put this on Forum to seek advice as my PBP bought last May has expired warranty period.

These what really happened. I'm kinda lost now and my PBP is as good as useless.
  Reply
#4
I think then that my last statement was correct. I'm short on time at the moment, else I could find a post explaining how to do this. Perhaps you can find one, we've had quite a few of them I suppose.

To summarise though, this is what you'll need to do:
1) make a bootable SD, but not Manjaro. I like to use the Debian Desktop image from the wiki.
2) take the bottom cover off the PBP.
3) switch the eMMC off
4) boot from SD
5) download a bootable eMMC image, preferably just use the same Debian image from step 1.
6) turn the eMMC on
7) "bind" the eMMC
8) install the new image to the eMMC
9) power down
10) reassemble the PBP
  Reply
#5
(01-17-2021, 11:10 AM)KC9UDX Wrote: I think then that my last statement was correct.  I'm short on time at the moment, else I could find a post explaining how to do this. Perhaps you can find one, we've had quite a few of them I suppose.

To summarise though, this is what you'll need to do:
1) make a bootable SD, but not Manjaro.  I like to use the Debian Desktop image from the wiki.
2) take the bottom cover off the PBP.
3) switch the eMMC off
4) boot from SD
5) download a bootable eMMC image, preferably just use the same Debian image from step 1.
6) turn the eMMC on
7) "bind" the eMMC
8) install the new image to the eMMC
9) power down
10) reassemble the PBP
Thank you my friend. You saved my PBP. I managed to boot with Debian Desktop microSD card. Thank you so much.

I typed lsblk, and I believe my 64GB emmc is corrupted some how, here's what i got:
-mmcblk0p1 179:1 0 64M 0 part /boot.
Because the 654GB emmc cannot be 64M.

And meanwhile, I have to find in forum how to fix the problematic main charging port is not charging, only the USB-C is able to charge the PBP.

My friend, you are my savior. thanks. I will learn other software as well. But I will need to learn again how to setup the rclone.
  Reply
#6
mmcblk0p1 /boot being 64m is correct.

You should also have mmcblk0p0 as the boot code partition, and mmcblk0p2 as / (root).
At least that's what I think it should be. But perhaps mmcblk0p0 doesn't show up that way, and mmcblk0p2 maybe got clobbered.

As for the barrel charger port, it may be the wall wart that's bad rather than the PBP. At least, that's what I recall one other user reporting.

I'm glad it could help, and more glad you got it working. Have fun!
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Novice question: Pinebook Pro does boot (does it?) but black screen Gert V. 21 2,996 01-27-2021, 10:48 PM
Last Post: rimaille
  Screen flicker with USB-C charging bchenlee609 5 931 01-25-2021, 08:48 PM
Last Post: bchenlee609
  All White Screen on Manjaro I3 nomadicoder 1 722 12-31-2020, 11:44 AM
Last Post: nomadicoder
  Screen refresh delay with kernel errors shawnanastasio 30 12,555 11-16-2020, 06:46 PM
Last Post: Lyrixcaz
  Screen adjustment michael82 16 5,596 10-21-2020, 09:22 AM
Last Post: moonwalkers
Photo Remove activity manager bar on right side of screen - plasma kde motezart 3 1,052 10-20-2020, 10:36 AM
Last Post: motezart
  Everything on my computer screen has inlarged by 50% 20jasonduty20@yahoo.com 2 1,065 10-07-2020, 09:46 AM
Last Post: moonwalkers
  Screen won't shut off when fully closed ZxEfR 15 5,109 09-08-2020, 09:45 PM
Last Post: subalpine
  screen burn-in frofro 0 669 08-17-2020, 08:11 PM
Last Post: frofro
  Login screen issue. LinuXchoicE 2 1,188 07-07-2020, 09:06 AM
Last Post: LinuXchoicE

Forum Jump:


Users browsing this thread: 1 Guest(s)