Dark screen on boot up (?) on new Pinebook Pro with Manjaro
#11
Okay, I just have to laugh. I updated the packages on the SD card, rebooted it, and it came up with a dark screen. I can just re-image to the downgraded SD image for the card, and repeat the process, but an SD card image that can actually access the eMMC would be really nice right about now.

More importantly, thuis shows that this pitfall is still in the Manjaro package server, after other people have fallen for it. I am done with Manjaro at this point and will be looking for other OSes, and if they can't fix this, I think the Pinebook community should seriously consider moving to another distro
#12
The Ubuntu Fosse SD image boots the laptop with a working display and lets me access the eMMC.

SO now I just need to know what to put into /etc/ to get the backlight turned on during boot up.
#13
1. Just screen back-light not turning on?
2. Or LED over F2 key doesn't go GREEN from RED?

If case 2, you shold have done two "dd" commands for u-boot configuration after update (before reboot).
#14
(08-18-2020, 04:35 AM)cynist Wrote: 1. Just screen back-light not turning on? 
2. Or LED over F2 key doesn't go GREEN from RED?

If case 2, you shold have done two "dd" commands for u-boot configuration after update (before reboot).
Just the screen backlight.
#15
Boot ubuntu (SD) I assume it works?

edit/ make a file called "bright" (with sudo/su)
----------------------
#/usr/bin/bash
cd /sys/class/backlight/edp-backlight
echo 3200 > brightness
--------------------
(for some reason, space before and after ">" seems to be neccesary)
sudo chmod 777 bright

mount emmc (rootfs, not boot)
sudo cp bright to /mnt/emmc/root (replace emmc with appropriate)

shutdown, remove card
boot with emmc, ctr-alt-F2, do it twice (or more), wait until sure is booted
All this is blind, type carefully
login as root,,password ,, ./bright,, alt-F1 (preceding "./" is essential)

I have looked (grep) in /etc, trying to find where backlight values are stored, no luck
There is a systemd unit, seems dead or part of something else


Possibly Related Threads…
Thread Author Replies Views Last Post
  Kali Linux for Pinebook Pro Luke 97 115,621 01-30-2023, 02:46 PM
Last Post: dachalife
  Manjaro update broke hardware video acceleration with mpv myself600 2 190 01-25-2023, 09:12 AM
Last Post: myself600
  Issue with booting Manjaro from encrypted NVMe drive on pbp Cs137 0 79 01-19-2023, 01:47 PM
Last Post: Cs137
  Manjaro ARM 20.04 spikerguy 68 78,329 01-08-2023, 07:22 PM
Last Post: vandys
  org.kde.plasma.core not installed (Manjaro) twirlip 0 92 01-06-2023, 09:47 AM
Last Post: twirlip
  Help installing Manjaro on eMMC of Pinebook Pro pine4546464 2 254 12-31-2022, 12:18 PM
Last Post: pine4546464
  Armbian is [edit: no longer] dropping support for Pinebook Pro TRS-80 4 2,517 12-23-2022, 12:01 AM
Last Post: TRS-80
  Pinebook Pro wifi not working Queliffrel 1 382 11-30-2022, 06:30 AM
Last Post: myself600
  DiY - Installing Void Linux ARM On The Pinebook Pro vincele 1 339 11-28-2022, 05:03 PM
Last Post: tllim
  WiFi stopped on Pinebook Pro after update tkudog 3 739 11-24-2022, 04:32 PM
Last Post: tkudog

Forum Jump:


Users browsing this thread: 1 Guest(s)