Possible to run ArmV7 Apps on Manjaro?
that's correct, manjaro officially dropped armhf (you're correct, armhf covers armv7) support, but you can still use arch resources to do achieve your goal.

that walkthrough would likely work for your use case on a Debian build for the PBP, but if you install one, you might as well install the mrfixit Debian, which is already 32bit userland. Alternatively, if you want to try stay in Arch/Manjaro/aarch64, you could look into QEMU, too https://wiki.archlinux.org/title/QEMU its packages should be available in pamac under Manjaro. Another common method people have used, worked well to get armhf Chrome/Widevine, is to run the app from an armhf docker container.
It's all on hold at the moment,
got to step 8/9 last night, preparing to build box86.

Just powered the PBP on, and when entering the password to log on it just hangs and I cant log in.

So I've managed to bork the system somehow, (unless the updates it downloaded when i installed schroot and debootstrap are responsible).

I've downloaded manjaro again but it just shows the manjaro boot logo ad infinitum (seem to recall it used to do this but cant remember what to do to get past it, damn my old man brain, had to forget this to make space for new stuff!).

I have discovered that there is also box64 which maybe a better fit as I can build for amd64 (or download prebuilt amd64 release) which maybe a better option and "just work".

one step forward 2 steps back in this instance :-(
Linux n00b trying to learn.
Brute force and ignorance sometimes works!
| Pinebook Pro + Toshiba OCZ RC100 240GB |
I just wanted to say thanks for posting your updates here and that I'm watching your progress :)

At some point (when I have time) I will try to get Betaflight Configurator running on the Pinephone.

I will also try to post my results in this thread.
(01-05-2022, 08:59 AM)gandlers Wrote: I've downloaded manjaro again but it just shows the manjaro boot logo ad infinitum

i know the xfce or kde imgs did this quite often. iirc the easy solution was to hit Esc when stuck at that screen
I'm quite certain that I'd tried the ESC key (amongst all the F keys and other key mashing).
I ended up cracking the EMMC out and connected it to Pine64 EMMC-USB adaptor (essential item if you end up bricking the OS).

Once re-flashed I was back in business.

After fumbling around I made the discovery that "building" a release was beyond my understanding and googling ability as there doesnt seem to be much information on building NW.js packages on ARM64.

I did stumble over a solution though when I discovered that by running the gulpfile with the dist task that i could run betaflight configurator simply be running "nw ." in the dist folder.

I managed this for 10.7.2 as the new 10.8.0-RC2 which both appear to operate correctly.

So of the top of my head the process was.
Install the required version of node.js, there are binaries for ARM64 available from the node website. configurator 10.7 needs node v10 and 10.8.0 needs node v14
I also installed the chrome variant of NW.js from https://github.com/LeonardLaszlo/nw.js-a...2021-12-11

once NW.js and node.js were installed and paths added, yarn was installed following the instructions on betaflight-configurator github pages.

'yarn gulp dist' would then "build" the required files and modules into the dist folder.
'nw .' from withing the dist folder would then launch betaflight configurator.....result!
a .desktop file can be created to add icons to the KDE menus and desktop as icon to launch directly without having to use the terminal

So not quite a solution to the original question, but if you are hoping to run betaflight-configurator on ARM64 then it is possible.

Hope you can get it going on your PinePhone @matusmatus 
So thanks for all the advice guys, not that I ended up using it but it's widened my otherwise slim knowledge.
Linux n00b trying to learn.
Brute force and ignorance sometimes works!
| Pinebook Pro + Toshiba OCZ RC100 240GB |
For anyone else trying to run Betaflight Configurator on arm64, I've documented the steps taken to get v10.8.0-RC2 running on manjaro

Linux n00b trying to learn.
Brute force and ignorance sometimes works!
| Pinebook Pro + Toshiba OCZ RC100 240GB |

Possibly Related Threads…
Thread Author Replies Views Last Post
  Manjaro PBP stable update 2022-06-19 bricked wpeckham 1 100 06-21-2022, 06:13 PM
Last Post: wpeckham
  How to make manjaro sleep or hibernate? KDE? regretfulpineuser 0 59 06-20-2022, 12:56 AM
Last Post: regretfulpineuser
  Help with Kali Linux wifi not working but works with Manjaro PineSupporter 0 109 05-27-2022, 10:24 PM
Last Post: PineSupporter
  Manjaro and Arch repository with privacy oriented software as400 86 66,610 04-27-2022, 07:44 AM
Last Post: annahellrothsparent
  Fresh Manjaro does not boot from eMMC pentamassiv 6 839 03-27-2022, 11:01 AM
Last Post: xNix
  Dual boot Manjaro and Debian? dieselnutjob 3 480 03-26-2022, 07:17 AM
Last Post: dieselnutjob
  Pinebook Pro w/ Manjaro KDE Random Freeze/Crash BenniTec 1 469 03-18-2022, 04:03 PM
Last Post: BenniTec
  Manjaro Gnome on Pinebook Pro Review! - My New Favourite Pinebook Pro Distro! ImmyChan 0 486 02-18-2022, 12:59 PM
Last Post: ImmyChan
Question Manjaro with Full Disk Encryption and GRUB dumetrulo 0 530 02-11-2022, 04:21 PM
Last Post: dumetrulo
  Manjaro -box64 and wine -Help Mangled 1 898 01-27-2022, 01:13 PM
Last Post: Mangled

Forum Jump:

Users browsing this thread: 1 Guest(s)