Debian emmc installer
#1
I'm trying to install Debian on the emmc. I've tried building an image from the firmware and partition images here https://deb.debian.org/debian/dists/bull...rd-images/ and here https://d-i.debian.org/daily-images/arm6...rd-images/.

In both cases no network interfaces are detected at all and it appears wifi drivers are missing, meaning I can't complete the install.

Is it expected that those images don't contain the driver? (I thought the netboot spin included non-free?). What is the best way of getting that driver? Is there another image I should be using?
  Reply
#2
take a look on https://forum.pine64.org/showthread.php?tid=16862, maybe this gives an idea what needs to be done in your case
  Reply
#3
(08-15-2022, 10:09 AM)jsch Wrote: take a look on https://forum.pine64.org/showthread.php?tid=16862, maybe this gives an idea what needs to be done in your case

Thanks. I was hoping to avoid needing to buy a USB eth adapter but looks like it's the easiest (only?) way for now.
  Reply
#4
You could install the system without the wifi driver, use a usb-stick to copy the necessary packages over once debian is installed on the pinebook. My pinephone came with the dock, hence I chose this approach.
  Reply
#5
Generally speaking, Armbian is going to be far ahead of upstream (vanilla Debian) on any sort of SBC type device (including PBP) because Arm/SBC world is so different from x86.

Having said that, there is currently an issue with installing Armbian to eMMC. Not sure what's up with that, pretty sure it used to work. I hope to have my new PBP in my hands in a few more days, then I can maybe try and see what's happening. In the meantime, it should run well off SD card.
Cheers,
TRS-80

What is Free Software and why is it so important for society?

Protocols, not Platforms

For the most Linux-y experience on your Linux phone, try SXMO!
  Reply
#6
Right tried installing with a USB ethernet adapter (worked on the roght USB port only not the left), seema like everything installs fine but at the very end it fails to reboot and doesn't boot thereafter. I'm trying the guided partitioning with encrypted LVM, could that be an issue or is that expected to work fine?
  Reply
#7
Actually looks like it might be unrelated to luks after all, the same thing seems to happen with an unencrypted install
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Question Debian (Vanilla) no output on display after Kernel update (6.0.8-1) as365n4 0 50 11-25-2022, 08:28 AM
Last Post: as365n4
  Fix for Armbian not booting on PBP from eMMC agreenbhm 4 875 11-07-2022, 05:43 PM
Last Post: igorp
  How can I install Debian? ImmyChan 1 427 10-19-2022, 03:09 AM
Last Post: alpopa
  newer ""emmc-installer" images (manjaro xfce) magistral 1 268 10-10-2022, 06:22 AM
Last Post: maxjrh
  6/22 run of PBPs - is reimaging eMMC with new OS possible still? elitegamercody 29 2,345 10-04-2022, 07:55 PM
Last Post: wdt
  when i close my laptop lid the screen doesn't turn on? (debian bullseye based) computerc 3 469 09-23-2022, 08:37 PM
Last Post: computerc
  install debian on pbp jsch 3 973 09-21-2022, 10:28 PM
Last Post: Invictvs
  Unable to install Debian Bullseye because of missing wifi firmware Pino64 3 1,258 09-10-2022, 02:07 PM
Last Post: cypresstwist
  what is the magic dd incantation to copy the system from the sd card to the emmc? geokon 18 1,941 08-18-2022, 11:26 PM
Last Post: calinb
  Fresh Manjaro does not boot from eMMC pentamassiv 7 2,174 08-18-2022, 11:47 AM
Last Post: Bemo

Forum Jump:


Users browsing this thread: 1 Guest(s)