Audio 3.5mm Jack not working
#1
Hello,

I installed LibreElec on my new ROCKPRO64. I have a hi-fi stereo which I want to plug on the audio jack 3.5mm. It doesn't work, meaning I don't have any sound. I don't know from were the problem comes from and I don't know how to investigate.

I post in general forum because I don't know if it's an hardware or Linux issue.

Thanks in advance for your help Smile
  Reply
#2
(05-05-2020, 03:09 PM)clement Wrote: Hello,

I installed LibreElec on my new ROCKPRO64. I have a hi-fi stereo which I want to plug on the audio jack 3.5mm. It doesn't work, meaning I don't have any sound. I don't know from were the problem comes from and I don't know how to investigate.

I post in general forum because I don't know if it's an hardware or Linux issue.

Thanks in advance for your help Smile

Hi,
   I am not using LibreElec but Debian. But in order to enable the jack plug, I have first to enable the headphone mixer :

Code:
amixer set 'Right Headphone Mixer Right DAC' on
amixer set 'Left Headphone Mixer Left DAC' on

best regards.
LMM
  Reply
#3
Hi,

Sorry for the late answer, I didn't get notification by email.

Code:
# amixer set 'Right Headphone Mixer Right DAC' on
amixer: Unable to find simple control 'Right Headphone Mixer Right DAC',0

I have no idea how to adjust parameters.

If I understood properly, I can use

Code:
# amixer scontrols
# amixer scontents
to list the devices, but it doesn't return anything.

Code:
# amixer info
Card default 'HDMI'/'HDMI'
 Mixer name : ''
 Components : ''
 Controls      : 3
 Simple ctrls  : 0
  Reply
#4
(05-23-2020, 02:26 AM)clement Wrote: Hi,

Sorry for the late answer, I didn't get notification by email.

Code:
# amixer set 'Right Headphone Mixer Right DAC' on
amixer: Unable to find simple control 'Right Headphone Mixer Right DAC',0

I have no idea how to adjust parameters.

If I understood properly, I can use

Code:
# amixer scontrols
# amixer scontents
to list the devices, but it doesn't return anything.

Code:
# amixer info
Card default 'HDMI'/'HDMI'
 Mixer name : ''
 Components : ''
 Controls      : 3
 Simple ctrls  : 0

for me, amixer returns :

Code:
Card default 'rockchiprk3399'/'rockchip,rk3399'
 Mixer name : ''
 Components : ''
 Controls      : 35
 Simple ctrls  : 35
It seems that you are using hdmi output, therefore you have to switch the card.
You can probably use alsamixer command or
Code:
amixer -c 0 set Headphone playback 100% unmute
0 should be rockship sound card
  Reply
#5
Unfortunately,
Code:
# amixer -c 0 set Headphone playback 100% unmute
amixer: Unable to find simple control 'Headphone',0
  Reply
#6
(05-24-2020, 01:25 AM)clement Wrote: Unfortunately,
Code:
# amixer -c 0 set Headphone playback 100% unmute
amixer: Unable to find simple control 'Headphone',0

what do you have with:

Code:
cat /proc/asound/cards

(05-24-2020, 02:02 AM)LMM Wrote:
(05-24-2020, 01:25 AM)clement Wrote: Unfortunately,
Code:
# amixer -c 0 set Headphone playback 100% unmute
amixer: Unable to find simple control 'Headphone',0

what do you have with:

Code:
cat /proc/asound/cards
 and

Code:
amixer -c 0 scontrols
amixer -c 1 scontrols
  Reply
#7
It's odd:

Code:
# cat /proc/asound/cards

cat: can't open '/proc/asound/cards': No such file or directory

Code:
LibreELEC:~ # amixer -c 0 scontrols
LibreELEC:~ # amixer -c 1 scontrols
amixer: Mixer hw:1 load error: No such device or address
LibreELEC:~ #
  Reply
#8
(05-24-2020, 02:23 AM)clement Wrote: It's odd:

Code:
# cat /proc/asound/cards

cat: can't open '/proc/asound/cards': No such file or directory

Code:
LibreELEC:~ # amixer -c 0 scontrols
LibreELEC:~ # amixer -c 1 scontrols
amixer: Mixer hw:1 load error: No such device or address
LibreELEC:~ #

May be a problem specific to LibeELEC kernel (sound card module not loaded ?
Some things to try to search the config :
Code:
aplay -l # list the cards
lsmod | grep snd # list the loadable module
alsamixer # for configuring the mixer F6 to change card

you will find many information in /proc/asound (kernel version, ...)

you could try to install a new version of libreElec (if it is not updated)

Sorry, I am don't know very well libreELEC, I rather use ubuntu or debian. 

I am curious to know where the pb comes from. Try the chat room, you may have quick answers.
  Reply
#9
I have the last version of LibreElec. There is no update since I installed it. I also rather Ubuntu, however, video performance were terrible and each attempt to fix it lead to a broken system, and Kodi does pretty much everything I want.

The audio controller seems to be seen by the OS
Code:
# aplay -l
**** List of PLAYBACK Hardware Devices ****
card 0: HDMI [HDMI], device 0: ff8a0000.i2s-i2s-hifi i2s-hifi-0 []
 Subdevices: 1/1
 Subdevice #0: subdevice #0
card 1: ES8316 [ES8316], device 0: ff890000.i2s-ES8316 HiFi ES8316 HiFi-0 []
 Subdevices: 1/1
 Subdevice #0: subdevice #0

No sound module loaded, but I don't know how the kernel is build, maybe the driver was not compiled as module

Code:
LibreELEC:~ # lsmod | grep snd

LibreELEC:~ #


alsamixer was not installed. I installed it and tried to change sound card but alsamixer crashed


Code:
# alsamixer
cannot load mixer controls: No such device or address
  Reply
#10
I tried to rebuild LibreElec to check driver support on Linux kernel.

Code:
$ grep ES8316 LibreELEC.tv/build.LibreELEC-RK3399.arm-9.2-devel/linux-aa8bacf821e5c8ae6dd8cae8d64011c741659945/.config
CONFIG_SND_SOC_ES8316=y
So it is no surprise that
Code:
lsmod | grep snd
didn't return anything.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  No sound from rockpro64 audio jack. rahulsharma 2 846 11-18-2020, 04:46 AM
Last Post: Wizzard
  When did the wifi module start working? stormchaser3000 1 221 11-12-2020, 08:59 AM
Last Post: Darren
  micro SD Card Slot Spring not working, Cant boot mjembd 1 491 04-16-2020, 12:30 AM
Last Post: mjembd
  board not working kardanadm 7 1,358 08-31-2019, 07:37 AM
Last Post: kardanadm
  board not working with EMMC RockPro64Newbie 1 515 05-10-2019, 02:22 AM
Last Post: Unkn0wn
  PCIe SSD drive still not working ?? dr_ju_ju 7 2,011 04-15-2019, 04:16 PM
Last Post: tllim
  Only ttyS2 working with rockpro64. rahulsharma 1 523 01-15-2019, 12:33 AM
Last Post: rahulsharma
  Could use some help with 3,5 jack (no sound) Pepijn 2 676 12-23-2018, 01:52 PM
Last Post: Pepijn
  RockPro64 Features/options working/not working lavermil 9 2,339 10-23-2018, 02:48 AM
Last Post: lavermil
Question Android 7.1 on EMMC not working, suggestions? SmartDIYTech 4 1,148 06-01-2018, 03:00 PM
Last Post: Luke

Forum Jump:


Users browsing this thread: 1 Guest(s)