Manjaro 20.04 KDE update issue
#1
This is most probably due to my lack of familiarity with Arch/Manjaro but running Manjaro 20.04 KDE (from a sd-card flashed earlier today) I have a problem with an update. the system tells me there are 150 updates available and after pressing the key to start the update it starts downloading and checking integrity. Then it encounters an already exisiting file and quits with an error.
Installation of a single package halts with the same message:


Code:
conflicting files:
nss: /usr/lib/p11-kit-trust.so exists is this filesystem


(translated)

So basically I cannot update, but I can' t install packages either (like ntfs-3g, printer related packages and Thunderbird.

Can anybody help me resolve this, other then checking each individual package until I have found the culprit?

Thx!
#2
there was a little linking issue in the nss package a short while ago, that creates this problem (see: https://www.archlinux.org/news/nss3511-1...ervention/)

The solution is posted there, but the short version is: run

pacman -Syu --overwrite /usr/lib\*/p11-kit-trust.so
#3
(04-20-2020, 10:08 AM)mlentink Wrote: This is most probably due to my lack of familiarity with Arch/Manjaro but running Manjaro 20.04 KDE (from a sd-card flashed earlier today) I have a problem with an update. the system tells me there are 150 updates available and after pressing the key to start the update it starts downloading and checking integrity. Then it encounters an already exisiting file and quits with an error.
Installation of a single package halts with the same message:


Code:
conflicting files:
nss: /usr/lib/p11-kit-trust.so exists is this filesystem


(translated)

So basically I cannot update, but I can' t install packages either (like ntfs-3g, printer related packages and Thunderbird.

Can anybody help me resolve this, other then checking each individual package until I have found the culprit?

Thx!

It is always a good idea to visit the manjaro forums as they provide instructions to update (such as https://forum.manjaro.org/t/arm-stable-u...els/136479 ). The updates should be seamless but, you know, computers Smile
#4
(04-20-2020, 10:42 AM)e-minguez Wrote:
(04-20-2020, 10:08 AM)mlentink Wrote: This is most probably due to my lack of familiarity with Arch/Manjaro but running Manjaro 20.04 KDE (from a sd-card flashed earlier today) I have a problem with an update. the system tells me there are 150 updates available and after pressing the key to start the update it starts downloading and checking integrity. Then it encounters an already exisiting file and quits with an error.
Installation of a single package halts with the same message:


Code:
conflicting files:
nss: /usr/lib/p11-kit-trust.so exists is this filesystem


(translated)

So basically I cannot update, but I can' t install packages either (like ntfs-3g, printer related packages and Thunderbird.

Can anybody help me resolve this, other then checking each individual package until I have found the culprit?

Thx!

It is always a good idea to visit the manjaro forums as they provide instructions to update (such as https://forum.manjaro.org/t/arm-stable-u...els/136479 ). The updates should be seamless but, you know, computers Smile

Oh... I just deleted that file... That worked too Smile
#5
Thumbs Up 
(04-20-2020, 10:42 AM)e-minguez Wrote:
(04-20-2020, 10:08 AM)mlentink Wrote: This is most probably due to my lack of familiarity with Arch/Manjaro but running Manjaro 20.04 KDE (from a sd-card flashed earlier today) I have a problem with an update. the system tells me there are 150 updates available and after pressing the key to start the update it starts downloading and checking integrity. Then it encounters an already exisiting file and quits with an error.
Installation of a single package halts with the same message:


Code:
conflicting files:
nss: /usr/lib/p11-kit-trust.so exists is this filesystem


(translated)

So basically I cannot update, but I can' t install packages either (like ntfs-3g, printer related packages and Thunderbird.

Can anybody help me resolve this, other then checking each individual package until I have found the culprit?

Thx!

It is always a good idea to visit the manjaro forums as they provide instructions to update (such as https://forum.manjaro.org/t/arm-stable-u...els/136479 ). The updates should be seamless but, you know, computers Smile


Thanks.Simply deleting the offending file did the trick!
#6
(04-20-2020, 10:31 AM)gleachkr Wrote: pacman -Syu --overwrite /usr/lib\*/p11-kit-trust.so

Thanks, that command worked for me! I had the same problem after installing a new image on my upgraded emmc.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Possible to run ArmV7 Apps on Manjaro? gandlers 15 500 01-22-2022, 05:19 PM
Last Post: gandlers
  [Manjaro] u-boot won't boot from eMMC with (unbootable) SD card present zackw 0 66 01-10-2022, 03:58 PM
Last Post: zackw
  Working suspend on Manjaro brzegorz 3 1,347 12-03-2021, 01:39 PM
Last Post: rik-shaw
  Solution for issue with 'panfrost' module not initializing due to missing dependency cobratbq 0 178 12-02-2021, 05:26 PM
Last Post: cobratbq
  Manjaro -box64 and wine -Help Mangled 0 280 11-20-2021, 01:51 PM
Last Post: Mangled
  RAM deficiency after recent large Manjaro update? stozi 1 363 11-12-2021, 06:19 AM
Last Post: maxjrh
  Yubikey 5C on manjaro zeb11 3 746 10-02-2021, 09:33 AM
Last Post: zeb11
  Manjaro - Internet connection sharing requires dnsmasq (but the dep isn't declared) Dendrocalamus64 0 427 09-11-2021, 05:25 PM
Last Post: Dendrocalamus64
  Pinebook pro nearly unusable after using manjaro-arm-installer TheCounselor 2 1,462 09-07-2021, 08:34 PM
Last Post: TRS-80
  Manjaro and Arch repository with privacy oriented software as400 78 53,629 07-28-2021, 05:24 AM
Last Post: llsf

Forum Jump:


Users browsing this thread: 1 Guest(s)