Manjaro 20.04 released
#1
Read all the details from Manjaro itself here:

https://forum.manjaro.org/t/manjaro-arm-...sed/133374
#2
I’ve installed it smoothly. Been playing with the install now for the last 24 hours straight only bug I ran into is app installer crashes or freezes every once in while. /boot partition is now its own.


Sent from my iPhone using Tapatalk
Ne quid nimis

#3
(04-03-2020, 02:13 PM)mtlemmonrunner Wrote: I’ve installed it smoothly.  Been playing with the install now for the last 24 hours straight only bug I ran into is app installer crashes or freezes every once in while.  /boot partition is now its own.


Sent from my iPhone using Tapatalk

I wish the requirement to have to hit the ESC key after bootsplash 15+ seconds would go away. Would make it a lot more easier for novice and experienced types alike.
#4
I tried the Manjaro 20.04 xfce version on SD card and it worked well. Downloaded the emmc installer, installed fine and works well. But now I can't boot from any SD card in the reader or in USB port. I have tried SD cards with Debian, Ubuntu, and Armbian, all of which were booting and working before installing Manjaro xfce 20.04 to emmc.

Does anyone else see this problem?

Is there a way to to correct it?
#5
(04-02-2020, 08:18 PM)digeratus1. Wrote: Read all the details from Manjaro itself here:

https://forum.manjaro.org/t/manjaro-arm-...sed/133374

WOW!
Very impressive!
RockPro64 4Gb v2.1

/Faradn
#6
(04-05-2020, 09:28 AM)mainer Wrote: I tried the Manjaro 20.04 xfce version on SD card and it worked well. Downloaded the emmc installer, installed fine and works well. But now I can't boot from any SD card in the reader or in  USB port. I have tried SD cards with Debian, Ubuntu, and Armbian, all of which were booting and working before installing Manjaro xfce 20.04 to emmc.

Does anyone else see this problem?

Is there a way to to correct it?

Yes, this is happening to me as well except my out of the box latest Debian SD card does boot.  I just did a Manjaro install coming from the latest Debian I haven't figured out what is happening with the SD card or the eMMC install. This puts a damper on Manjaro 20.04 release ouch?
Ne quid nimis

#7
(04-05-2020, 01:21 PM)mtlemmonrunner Wrote:
(04-05-2020, 09:28 AM)mainer Wrote: I tried the Manjaro 20.04 xfce version on SD card and it worked well. Downloaded the emmc installer, installed fine and works well. But now I can't boot from any SD card in the reader or in  USB port. I have tried SD cards with Debian, Ubuntu, and Armbian, all of which were booting and working before installing Manjaro xfce 20.04 to emmc.

Does anyone else see this problem?

Is there a way to to correct it?

Yes, this is happening to me as well except my out of the box latest Debian SD card does boot.  I just did a Manjaro install coming from the latest Debian I haven't figured out what is happening with the SD card or the eMMC install. This puts a damper on Manjaro 20.04 release ouch?

Thank you for your conformation of my problem.

I have read the new posts at https://forum.manjaro.org/t/manjaro-arm-...sed/133374 and there seems to be at least one person with similar problems, but no conformation or solution at this time.

I have done some more testing to get a better understanding of what the situation is and would like to document what I have found so people on this forum will have some idea of what may happen after installing Manjaro (xfce version at least) to the eMMC.

1. I downloaded, created, and ran Manjaro xfce 20.04. It ran better than other distributions that I have tried so I decided to flash it to eMMC and use it as my default distribution. I use/need wireguard, firefox, thunderbird, and it seems to run them without issues or failures. It also does not become unresponsive at times as Bionic Mate and others do.

2. I downloaded the emmc installer version and flashed it to an SD card with (as root):
    xzcat Manjaro-ARM-xfce-pbpro-20.04-emmc.img.xz | dd bs=4M of=/dev/mmcblk0
That went well and I booted from the SD card created. I used the esc key during the boot to get past the glitch and the card copied the system to eMMC as it should. Rebooted and installed setting user, passwords, etc.  All went fine and the system boots and runs as expected. 

3. I tried booting some other distributions (that I had been running/testing) from SD cards, and none of them would boot. Manjaro boots and runs instead of the SD cards. I tried Bionic Mate, Debian Mate, and Armbian Mate, all with no success. I tried each of them in the SD card reader and all USB ports with no success.  I can read and write on the SD card or USB ports, but not boot.

4. I then tried the Manjaro xfce SD card I had been testing and it booted!

5. I downloaded Manjaro-ARM-kde-plasma-pbpro-20.04-emmc-installer-20.04.img.xz flashed it to a SD card and it booted (using the esc key) and offered to install.  I declined the install.

6. Just to be sure, I downloaded bionic-mate-pinebookpro-0.9.14-1159-armhf.img.xz and flashed it to a SD card. It would not boot.

I have no experience with or knowledge of uboot, but this appears to be a problem/incompatibility in the uboot systems used. I hope it can be fixed without loosing all of the effort put into other distributions or Manjaro xfce.

I am going to continue to use Manjaro xfce as it is the best and most complete distribution for my use case.  It does however severely limit the usefulness of the PBPro for experimenting with other distributions on SD cards.  

So, if you install Manjaro 20.04 (xfce at least) to eMMC you could loose the ability to boot other distributions on SD cards.

I will join the Manjaro forum and post this there as well.
#8
(04-05-2020, 10:42 PM)mainer Wrote:
(04-05-2020, 01:21 PM)mtlemmonrunner Wrote:
(04-05-2020, 09:28 AM)mainer Wrote: I tried the Manjaro 20.04 xfce version on SD card and it worked well. Downloaded the emmc installer, installed fine and works well. But now I can't boot from any SD card in the reader or in  USB port. I have tried SD cards with Debian, Ubuntu, and Armbian, all of which were booting and working before installing Manjaro xfce 20.04 to emmc.

Does anyone else see this problem?

Is there a way to to correct it?

Yes, this is happening to me as well except my out of the box latest Debian SD card does boot.  I just did a Manjaro install coming from the latest Debian I haven't figured out what is happening with the SD card or the eMMC install. This puts a damper on Manjaro 20.04 release ouch?

Thank you for your conformation of my problem.

I have read the new posts at https://forum.manjaro.org/t/manjaro-arm-...sed/133374 and there seems to be at least one person with similar problems, but no conformation or solution at this time.

I have done some more testing to get a better understanding of what the situation is and would like to document what I have found so people on this forum will have some idea of what may happen after installing Manjaro (xfce version at least) to the eMMC.

1. I downloaded, created, and ran Manjaro xfce 20.04. It ran better than other distributions that I have tried so I decided to flash it to eMMC and use it as my default distribution. I use/need wireguard, firefox, thunderbird, and it seems to run them without issues or failures. It also does not become unresponsive at times as Bionic Mate and others do.

2. I downloaded the emmc installer version and flashed it to an SD card with (as root):
    xzcat Manjaro-ARM-xfce-pbpro-20.04-emmc.img.xz | dd bs=4M of=/dev/mmcblk0
That went well and I booted from the SD card created. I used the esc key during the boot to get past the glitch and the card copied the system to eMMC as it should. Rebooted and installed setting user, passwords, etc.  All went fine and the system boots and runs as expected. 

3. I tried booting some other distributions (that I had been running/testing) from SD cards, and none of them would boot. Manjaro boots and runs instead of the SD cards. I tried Bionic Mate, Debian Mate, and Armbian Mate, all with no success. I tried each of them in the SD card reader and all USB ports with no success.  I can read and write on the SD card or USB ports, but not boot.

4. I then tried the Manjaro xfce SD card I had been testing and it booted!

5. I downloaded Manjaro-ARM-kde-plasma-pbpro-20.04-emmc-installer-20.04.img.xz flashed it to a SD card and it booted (using the esc key) and offered to install.  I declined the install.

6. Just to be sure, I downloaded bionic-mate-pinebookpro-0.9.14-1159-armhf.img.xz and flashed it to a SD card. It would not boot.

I have no experience with or knowledge of uboot, but this appears to be a problem/incompatibility in the uboot systems used. I hope it can be fixed without loosing all of the effort put into other distributions or Manjaro xfce.

I am going to continue to use Manjaro xfce as it is the best and most complete distribution for my use case.  It does however severely limit the usefulness of the PBPro for experimenting with other distributions on SD cards.  

So, if you install Manjaro 20.04 (xfce at least) to eMMC you could loose the ability to boot other distributions on SD cards.

I will join the Manjaro forum and post this there as well.

Did you use the "sync" command after dd-ing the bionic mate image?  If it will boot ANY SD card, it's likely not the eMMC installed image, but a problem with the sd card image.  Also, many, many sd cards fail, they are terrible -- I have 20 Raspberry Pi's in my lab and had to dump sandisk (75% failure rate) completely and ONLY buy Samsung sd cards (< 5% failure rate).

Otherwise, this thing is clocking in at 25-30 second cold boots (down from 90-120+ seconds), and has some nice performance improvements.  I'm very pleased with this, and hope I can eventually move to an encrypted partition eventually (now that /boot is separate).
#9
(04-05-2020, 11:36 PM)evantaylor Wrote:
(04-05-2020, 10:42 PM)mainer Wrote:
(04-05-2020, 01:21 PM)mtlemmonrunner Wrote:
(04-05-2020, 09:28 AM)mainer Wrote: I tried the Manjaro 20.04 xfce version on SD card and it worked well. Downloaded the emmc installer, installed fine and works well. But now I can't boot from any SD card in the reader or in  USB port. I have tried SD cards with Debian, Ubuntu, and Armbian, all of which were booting and working before installing Manjaro xfce 20.04 to emmc.

Does anyone else see this problem?

Is there a way to to correct it?

Yes, this is happening to me as well except my out of the box latest Debian SD card does boot.  I just did a Manjaro install coming from the latest Debian I haven't figured out what is happening with the SD card or the eMMC install. This puts a damper on Manjaro 20.04 release ouch?

Thank you for your conformation of my problem.

I have read the new posts at https://forum.manjaro.org/t/manjaro-arm-...sed/133374 and there seems to be at least one person with similar problems, but no conformation or solution at this time.

I have done some more testing to get a better understanding of what the situation is and would like to document what I have found so people on this forum will have some idea of what may happen after installing Manjaro (xfce version at least) to the eMMC.

1. I downloaded, created, and ran Manjaro xfce 20.04. It ran better than other distributions that I have tried so I decided to flash it to eMMC and use it as my default distribution. I use/need wireguard, firefox, thunderbird, and it seems to run them without issues or failures. It also does not become unresponsive at times as Bionic Mate and others do.

2. I downloaded the emmc installer version and flashed it to an SD card with (as root):
    xzcat Manjaro-ARM-xfce-pbpro-20.04-emmc.img.xz | dd bs=4M of=/dev/mmcblk0
That went well and I booted from the SD card created. I used the esc key during the boot to get past the glitch and the card copied the system to eMMC as it should. Rebooted and installed setting user, passwords, etc.  All went fine and the system boots and runs as expected. 

3. I tried booting some other distributions (that I had been running/testing) from SD cards, and none of them would boot. Manjaro boots and runs instead of the SD cards. I tried Bionic Mate, Debian Mate, and Armbian Mate, all with no success. I tried each of them in the SD card reader and all USB ports with no success.  I can read and write on the SD card or USB ports, but not boot.

4. I then tried the Manjaro xfce SD card I had been testing and it booted!

5. I downloaded Manjaro-ARM-kde-plasma-pbpro-20.04-emmc-installer-20.04.img.xz flashed it to a SD card and it booted (using the esc key) and offered to install.  I declined the install.

6. Just to be sure, I downloaded bionic-mate-pinebookpro-0.9.14-1159-armhf.img.xz and flashed it to a SD card. It would not boot.

I have no experience with or knowledge of uboot, but this appears to be a problem/incompatibility in the uboot systems used. I hope it can be fixed without loosing all of the effort put into other distributions or Manjaro xfce.

I am going to continue to use Manjaro xfce as it is the best and most complete distribution for my use case.  It does however severely limit the usefulness of the PBPro for experimenting with other distributions on SD cards.  

So, if you install Manjaro 20.04 (xfce at least) to eMMC you could loose the ability to boot other distributions on SD cards.

I will join the Manjaro forum and post this there as well.

Did you use the "sync" command after dd-ing the bionic mate image?  If it will boot ANY SD card, it's likely not the eMMC installed image, but a problem with the sd card image.  Also, many, many sd cards fail, they are terrible -- I have 20 Raspberry Pi's in my lab and had to dump sandisk (75% failure rate) completely and ONLY buy Samsung sd cards (< 5% failure rate).

Otherwise, this thing is clocking in at 25-30 second cold boots (down from 90-120+ seconds), and has some nice performance improvements.  I'm very pleased with this, and hope I can eventually move to an encrypted partition eventually (now that /boot is separate).

Yes, I did sync. 

Please note that I have 4 other SD cards that I have been using for weeks. None of them have ever failed to boot whin the default Debian image that came installed on the eMMC in the PBPro.  Now, only the Manjaro SD card boots and the other 3 will not boot at all.  I can reliably read and write from all 4 cards (all SD cards), just not boot the non Manjaro cards.  I expect that it is not the image, but the uboot that is the problem. 

By the way, I also only use Samsung sd cards for reliability and speed.
#10
Hi,

I am new to the Pine community and I am not sure whether this is the right thread to post this problem, so please forgive if this is deemed to be the wrong place.

I recently flashed Manjaro kde plasma 20.02 using the factory image and installer. The install went smoothly and I enjoyed Manjaro very much (smoothest OS experience on PBP so far).
The other day I uninstalled a some package using pacman (I can't remember exactly which one) and the window manager and touchpad during the froze during the de-install but I could get into the tty console using CTRl+F2 and do an orderly shutdown.

Since than PBP will show the boot splash and boot into the TTY console. At the login I can no longer login as the user (with sudo privileges) under which the crash happened but I can still login as root. So FS seems to be intact.

I tried to reflash Manjaro from the same mSD card I used a couple of weeks ago but it will not boot. On power on the red LED is on, then turns green but screen remains dark, pressing ESC when green LED is on does not help. I even reflashed the mSD card, no change.

Rebooting to console, logging in as root and inserting the mSD, the OS recognizes the card as /dev/mmsbl1 but I cannot mount it (giving an error message that mount to /mnt/sd failed and that helper programs may be needed)

Question 1:
Is there a way to recover this installation minimally invasive from the console ?

Question 2:
If not, how can run the installer without having to open the laptop to perform hardware hacks (I am an average Linux user)

Thank you very much for any advice.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Manjaro and Arch repository with privacy oriented software as400 86 63,713 04-27-2022, 07:44 AM
Last Post: annahellrothsparent
  Fresh Manjaro does not boot from eMMC pentamassiv 6 655 03-27-2022, 11:01 AM
Last Post: xNix
  Dual boot Manjaro and Debian? dieselnutjob 3 389 03-26-2022, 07:17 AM
Last Post: dieselnutjob
  Pinebook Pro w/ Manjaro KDE Random Freeze/Crash BenniTec 1 385 03-18-2022, 04:03 PM
Last Post: BenniTec
  Manjaro Gnome on Pinebook Pro Review! - My New Favourite Pinebook Pro Distro! ImmyChan 0 421 02-18-2022, 12:59 PM
Last Post: ImmyChan
Question Manjaro with Full Disk Encryption and GRUB dumetrulo 0 457 02-11-2022, 04:21 PM
Last Post: dumetrulo
  Manjaro -box64 and wine -Help Mangled 1 814 01-27-2022, 01:13 PM
Last Post: Mangled
  Possible to run ArmV7 Apps on Manjaro? gandlers 15 2,183 01-22-2022, 05:19 PM
Last Post: gandlers
  [Manjaro] u-boot won't boot from eMMC with (unbootable) SD card present zackw 0 433 01-10-2022, 03:58 PM
Last Post: zackw
  Working suspend on Manjaro brzegorz 3 2,148 12-03-2021, 01:39 PM
Last Post: rik-shaw

Forum Jump:


Users browsing this thread: 1 Guest(s)