Manjaro ARM 19.12 Official Release - PineBook Pro
#1
Hello Everyone,

I am please to inform that Manjaro ARM Team have officially released 19.12

Kindly check the Official post of Manjaro Forum.

Manjaro ARM 19.12 released!

Manjaro ARM Preview1 for Pinebook Pro!

manjaro ARM Preview2 is Release
Link: https://forum.manjaro.org/t/manjaro-arm-...=spikerguy

Known Issues:
  • No Bluetooth.
  • Unstable Wifi (might crap out after around 10 minutes) - Fix have been worked out.
  • No audio cards.
  • Brightness and Volume function keys do not work.
  • Does not power off completely from software.
  • Suspend does not work.
  • To show the OEM setup on the XFCE edition, wait until the bootsplash has run for 10-15 seconds, then press
Thanks to @Strit for all his time & effort and @tsys for sharing the Mainline Kernel patches.

Please try it out and share your experience & feedback's. It really helps the developers

Thank You.

Posted from PineBook Pro with Manjaro Linux
Manjaro ARM Team.
Devices: Pinebook Pro & PinePhone.
#2
This is the correct link...

https://forum.manjaro.org/t/manjaro-arm-...=spikerguy
#3
If we install this and keep our system up to date with pacman, will we automatically get the new fixes or is a clean flash required?
#4
You will get the automagically! Just be sure to reboot after your update


Sent from my iPhone using Tapatalk
#5
Absolutely love it! Runs very smooth and low on resources!
However as long as audio doesn't work not that usable Smile
#6
I'm testing Manjaro on my PBP.
I can't connect to the 5ghz WIFI.
I'm able to see only 2.4 ghz networks.
#7
I tested briefly last night and had issues with the wifi continuing to flake out after applying the powersave workaround and restarting the daemon and/or rebooting. Known issues aside the build seemed to work well, hard to do much with it with 10 minutes of network connectivity though.
#8
Question:  Obviously people are getting output on their powerbook screens, but I am not.  Output is fine through the serial uart; I can log into the initial boot (as root) and set up an account,  which I can then use  (through serial uart) when system reboots,  but there is never any output on the PBP, itself.  It doesn't matter whether I have the serial connection plugged into the headphone jack or not.  Are those of you who are succesfully getting output using  serial uart,(i.e. have switch 9 moved from its default position)?  Are you booting from SD?   

Thanks for any info/help.
#9
(11-08-2019, 08:36 PM)belfastraven Wrote: Question:  Obviously people are getting output on their powerbook screens, but I am not.  Output is fine through the serial uart; I can log into the initial boot (as root) and set up an account,  which I can then use  (through serial uart) when system reboots,  but there is never any output on the PBP, itself.  It doesn't matter whether I have the serial connection plugged into the headphone jack or not.  Are those of you who are succesfully getting output using  serial uart,(i.e. have switch 9 moved from its default position)?  Are you booting from SD?   

Thanks for any info/help.

I'm having this problem with Manjaro intermittently. I feel like it works fine for a while then i reboot and the screen never comes on. It does boot, just no screen.

They specifically pointed out that the display drivers are flakey, I'm accounting it to that.
#10
(11-08-2019, 04:16 PM)cristobalhdez Wrote: I'm testing Manjaro on my PBP.
I can't connect to the 5ghz WIFI.
I'm able to see only 2.4 ghz networks.

I have tried it and it works fine. I will try to do a more details test this time and get back to you.

(11-08-2019, 05:15 PM)Arglebargle Wrote: I tested briefly last night and had issues with the wifi continuing to flake out after applying the powersave workaround and restarting the daemon and/or rebooting. Known issues aside the build seemed to work well, hard to do much with it with 10 minutes of network connectivity though.
Yes it is just a workaround and not a complete fix. For most people it is working fine with the TLP workaround. We shall find a permanent fix soon.

(11-08-2019, 08:36 PM)belfastraven Wrote: Question:  Obviously people are getting output on their powerbook screens, but I am not.  Output is fine through the serial uart; I can log into the initial boot (as root) and set up an account,  which I can then use  (through serial uart) when system reboots,  but there is never any output on the PBP, itself.  It doesn't matter whether I have the serial connection plugged into the headphone jack or not.  Are those of you who are succesfully getting output using  serial uart,(i.e. have switch 9 moved from its default position)?  Are you booting from SD?   

Thanks for any info/help.
There are some users who have reported this. Thank you for reporting it here. I think this have something to do with the new LCD drivers. We have not found anything for this yet, Once we get some lead on this issue then we will be able to get a solution.

(11-08-2019, 10:17 PM)electriccrowbar Wrote:
(11-08-2019, 08:36 PM)belfastraven Wrote: Question:  Obviously people are getting output on their powerbook screens, but I am not.  Output is fine through the serial uart; I can log into the initial boot (as root) and set up an account,  which I can then use  (through serial uart) when system reboots,  but there is never any output on the PBP, itself.  It doesn't matter whether I have the serial connection plugged into the headphone jack or not.  Are those of you who are succesfully getting output using  serial uart,(i.e. have switch 9 moved from its default position)?  Are you booting from SD?   

Thanks for any info/help.

I'm having this problem with Manjaro intermittently. I feel like it works fine for a while then i reboot and the screen never comes on. It does boot, just no screen.

They specifically pointed out that the display drivers are flakey, I'm accounting it to that.
I think you're right Display drivers seems flakey but we're working on it and should be able to find some solution.

Currently we're working on finding s Wifi & Audio Fix.
Stay connected to get the update's & Thank you for all the feedback's.
Manjaro ARM Team.
Devices: Pinebook Pro & PinePhone.


Possibly Related Threads…
Thread Author Replies Views Last Post
  Yubikey 5C on manjaro zeb11 0 8 1 hour ago
Last Post: zeb11
  postmarketOS/Alpine edge image for the Pinebook Pro MartijnBraam 72 52,810 09-18-2021, 03:58 PM
Last Post: stozi
  Manjaro - Internet connection sharing requires dnsmasq (but the dep isn't declared) Dendrocalamus64 0 117 09-11-2021, 05:25 PM
Last Post: Dendrocalamus64
  Pinebook pro nearly unusable after using manjaro-arm-installer TheCounselor 2 741 09-07-2021, 08:34 PM
Last Post: TRS-80
  Official Debian support moonwalkers 54 7,125 08-28-2021, 01:31 PM
Last Post: alpopa
  Please help...Pinebook Pro Night Color / mode not working :( sushilsharma71@gmail.com 13 1,244 08-16-2021, 05:16 PM
Last Post: sushilsharma71@gmail.com
  which distro + DE are you using these days on the Pinebook Pro? halogen 19 2,225 08-01-2021, 03:25 AM
Last Post: gabeeg
  Working suspend on Manjaro brzegorz 2 532 07-30-2021, 06:21 AM
Last Post: vssz
  Manjaro and Arch repository with privacy oriented software as400 78 48,392 07-28-2021, 05:24 AM
Last Post: llsf
  Blobs on the Pinebook Pro globaltree 6 750 07-25-2021, 12:11 PM
Last Post: igorp

Forum Jump:


Users browsing this thread: 3 Guest(s)