MMS via Verizon quit working
#1
I've got an PinePhone (Evergreen) running Mobian Bookworm.  I got MMS messaging working in February after installing chatty v0.6.0-1 and it was fine until on or shortly before March 12 2022.  The messages seem to be retrieved and queued in ~/.mms/modemmanager/ but they don't get processed further and make their way into chatty anymore.

I've also got a Ting SIM with service via T-Mobile/Dish and MMS works fine with that.  I've switched SIMS back-and forth several times and the symptoms are persistent - Verizon always fails now and Ting works.

Here is the log for a 2nd attempt at processing a message:
Code:
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:process_request_queue() service 0x55ab13be70
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:process_request_queue() location http://63.55.64.151/servlets/mms?message-id=2105824508BB00007650000201
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:resolve_host() No active proxy
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:resolve_host_systemd() resolve_host_systemd
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:resolve_host_systemd() systemd-resolved host ip: 63.55.64.151
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:resolve_host() Using URI for request: http://63.55.64.151/servlets/mms?message-id=2105824508BB00007650000201
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:create_new_web_message() host: 63.55.64.151, port: -1
May 18 15:09:09 pine mmsdtng[5933]: GSocketClient: Starting new address enumeration
May 18 15:09:09 pine mmsdtng[5933]: GSocketClient: Address enumeration succeeded
May 18 15:09:09 pine mmsdtng[5933]: GSocketClient: Starting TCP connection attempt
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:soupmessage_network_event_cb() Socket 11 Binding to wwx0225d3683889 length 15
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:soupmessage_network_event_cb() Socket is bound to wwx0225d3683889
May 18 15:09:10 pine mmsdtng[5933]: GSocketClient: TCP connection successful
May 18 15:09:10 pine mmsdtng[5933]: GSocketClient: Starting application layer connection
May 18 15:09:10 pine mmsdtng[5933]: GSocketClient: Connection successful!
May 18 15:10:10 pine mmsdtng[5933]: Fail to get data (http status = 007)
May 18 15:10:10 pine mmsdtng[5933]: ../src/service.c:on_message_done() status: 007
May 18 15:10:10 pine mmsdtng[5933]: ../src/service.c:on_message_done() data size = 0
May 18 15:10:10 pine mmsdtng[5933]: ../src/service.c:on_message_done() request->result_cb=0x557625fdc0 vs. retrieve_conf=0x557625fdc0/send_conf=0x557625a180/notify_resp=0x557625cf64
May 18 15:10:10 pine mmsdtng[5933]: Fail to get data (http status = 007)
May 18 15:10:10 pine mmsdtng[5933]: ../src/service.c:on_message_done() On attempt 2
May 18 15:10:10 pine mmsdtng[5933]: ../src/service.c:on_message_done() Requeued Message
May 18 15:10:14 pine mmsdtng[5933]: ../src/service.c:service_retry_process_request_queue() Retrying Queue
   
After the "Connection successful!" message there should be some communication happening but instead I seem to get a timeout after one minute.  My MMS config has CarrierMMSC=http://mms.vtext.com/servlets/mms  and  MMS_APN=vzwinternet.

I've tried a varety of config changes in case this had something to do with DNS, and cleared nftables rules in case the firewall was interfering.  No joy.

Does anyone have a clue what's going on here?  Is there anyone for whom MMS & Verizon is working?

Edit 1: I have done regular dist-upgrades, including a couple days ago, and the symptoms don't seem to change.
  Reply
#2
(05-18-2022, 03:06 PM)treebeard Wrote: I've got an PinePhone (Evergreen) running Mobian Bookworm.  I got MMS messaging working in February after installing chatty v0.6.0-1 and it was fine until on or shortly before March 12 2022.  The messages seem to be retrieved and queued in ~/.mms/modemmanager/ but they don't get processed further and make their way into chatty anymore.

I've also got a Ting SIM with service via T-Mobile/Dish and MMS works fine with that.  I've switched SIMS back-and forth several times and the symptoms are persistent - Verizon always fails now and Ting works.

Here is the log for a 2nd attempt at processing a message:
Code:
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:process_request_queue() service 0x55ab13be70
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:process_request_queue() location http://63.55.64.151/servlets/mms?message-id=2105824508BB00007650000201
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:resolve_host() No active proxy
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:resolve_host_systemd() resolve_host_systemd
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:resolve_host_systemd() systemd-resolved host ip: 63.55.64.151
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:resolve_host() Using URI for request: http://63.55.64.151/servlets/mms?message-id=2105824508BB00007650000201
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:create_new_web_message() host: 63.55.64.151, port: -1
May 18 15:09:09 pine mmsdtng[5933]: GSocketClient: Starting new address enumeration
May 18 15:09:09 pine mmsdtng[5933]: GSocketClient: Address enumeration succeeded
May 18 15:09:09 pine mmsdtng[5933]: GSocketClient: Starting TCP connection attempt
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:soupmessage_network_event_cb() Socket 11 Binding to wwx0225d3683889 length 15
May 18 15:09:09 pine mmsdtng[5933]: ../src/service.c:soupmessage_network_event_cb() Socket is bound to wwx0225d3683889
May 18 15:09:10 pine mmsdtng[5933]: GSocketClient: TCP connection successful
May 18 15:09:10 pine mmsdtng[5933]: GSocketClient: Starting application layer connection
May 18 15:09:10 pine mmsdtng[5933]: GSocketClient: Connection successful!
May 18 15:10:10 pine mmsdtng[5933]: Fail to get data (http status = 007)
May 18 15:10:10 pine mmsdtng[5933]: ../src/service.c:on_message_done() status: 007
May 18 15:10:10 pine mmsdtng[5933]: ../src/service.c:on_message_done() data size = 0
May 18 15:10:10 pine mmsdtng[5933]: ../src/service.c:on_message_done() request->result_cb=0x557625fdc0 vs. retrieve_conf=0x557625fdc0/send_conf=0x557625a180/notify_resp=0x557625cf64
May 18 15:10:10 pine mmsdtng[5933]: Fail to get data (http status = 007)
May 18 15:10:10 pine mmsdtng[5933]: ../src/service.c:on_message_done() On attempt 2
May 18 15:10:10 pine mmsdtng[5933]: ../src/service.c:on_message_done() Requeued Message
May 18 15:10:14 pine mmsdtng[5933]: ../src/service.c:service_retry_process_request_queue() Retrying Queue
   
After the "Connection successful!" message there should be some communication happening but instead I seem to get a timeout after one minute.  My MMS config has CarrierMMSC=http://mms.vtext.com/servlets/mms  and  MMS_APN=vzwinternet.

I've tried a varety of config changes in case this had something to do with DNS, and cleared nftables rules in case the firewall was interfering.  No joy.

Does anyone have a clue what's going on here?  Is there anyone for whom MMS & Verizon is working?

Edit 1: I have done regular dist-upgrades, including a couple days ago, and the symptoms don't seem to change.

It looks like Verizon changed their MMS apn. I don't think it's vzwinternet anymore.

Read the comments here
  Reply
#3
Thanks dude, I can't believe I didn't see that before.  I've spent so many hours on this and it turned out to be something so simple.  It's a bit embarassing, really. Blush
  Reply
#4
Np, I did the same thing lol
  Reply
#5
(05-20-2022, 10:34 AM)cjhead Wrote: It looks like Verizon changed their MMS apn. I don't think it's vzwinternet anymore.

Read the comments here

See https://forum.pine64.org/showthread.php?...pid=110417

It looks like vzwapp might be working only for MMS while vzwinternet is required for general mobile data.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Receiving SMS stopped working treebeard 5 87 5 hours ago
Last Post: jsch
  Working video players? jojuma 10 441 06-10-2022, 01:13 AM
Last Post: as365n4
  How to get Pinetime working with Pinephone arkadione 10 566 06-09-2022, 09:16 AM
Last Post: Fish
  SMS quit - "Lost dbus connection" 98cwitr 0 73 06-09-2022, 06:42 AM
Last Post: 98cwitr
  Cellular data is working! drh 0 153 05-15-2022, 09:02 AM
Last Post: drh
  Telephony stopped working biketool 5 795 03-06-2022, 03:30 AM
Last Post: biketool
  Mobile internet via cellular network mostly not working Anna 17 2,246 02-28-2022, 02:51 PM
Last Post: TRS-80
  PIN not working (new?) anotherdavidlevin 0 248 01-31-2022, 12:41 PM
Last Post: anotherdavidlevin
  Phone mic isn't working at all D347h 2 537 01-26-2022, 07:34 AM
Last Post: D347h
  Programs unable to open display via sudo or pkexec (linssid not working) Zebulon Walton 4 1,751 01-17-2022, 01:58 AM
Last Post: vusra

Forum Jump:


Users browsing this thread: 1 Guest(s)