Squeekboard stopped working
After some recent updates I'm finding that squeekboard is no longer coming up when invoking the terminal or other programs needing keyboard input. I believe that sqeekboard is one of the packages that was updated.

However, if connecting remotely to the phone's GUI, squeekboard can be run manually in the terminal so it is there. When doing this, initially it displayed the following diagnostic:

Debug: Tried file "/home/mobian/.local/share/squeekboard/keyboards/terminal/us.yaml", but it's missing: No such file or directory (os error 2)

Info: Loaded layout Resource: terminal

It turned out that the file was actually located here:


So I created the "terminal" subdirectory and copied the file there, resulting in no more errors and a bit different keyboard layout. There are no function keys either way and switching between "English" and "Terminal" mode makes no difference.

Anyone know a fix for this?

I've been having so many problems with recent updates (many audio problems and now this) I'm thinking of restoring my image backup from nearly a month ago, which was pretty stable, and avoiding updates for a while.
Update, I found that the main problem with squeekboard is that it was just not starting up automatically in the background. So I added it to ~/.config/autostart and now it pops up as expected when running the terminal.

Still no function keys though and no difference between the "English (US)" and "Terminal" keyboard setting. I'm assuming that there's a layout missing for the latter which would have the function keys.

Also the audio problems are sporadic. Usually it works OK but every once in a while I find that ringing goes out the earphone instead of the speaker and for calls the audio just goes into the bit bucket. Rebooting the phone will usually "fix" this but it can take several reboots that take over a minute each so it's pretty annoying. (I do have a "known to work" SD card that hasn't been updated for quite a while that can be inserted if the eMMC installation goes off the deep end.)
OK, after searching for squeekboard configurations and testing a few I found one that I like though it looks like it's a couple of years old:


It has pretty much all the keys needed. A little awkward since the bottom row is a bit narrow for fumble-fingers and to get back to the alphabet keys from the function keys you have to go through the symbols. Those are just minor inconveniences though, functionality-wise this should do the trick. I set this layout up as both the US and terminal configs so it's always displayed when the keyboard pops up. (I don't need the stripped-down "US" configuration.) So the squeekboard issue is taken care of for now.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Mobile internet via cellular network mostly not working Anna 18 10,139 01-19-2024, 02:59 AM
Last Post: anonymous
Exclamation The internal speaker stops working anonymous 6 971 01-17-2024, 05:53 PM
Last Post: anonymous
  APN settings not working with new operator SIM card user641 1 1,015 03-01-2023, 04:43 PM
Last Post: anonymous
  Possible Solution for Microphone Not Working Ferriah 0 941 02-13-2023, 01:09 PM
Last Post: Ferriah
  Lock screen question: always squeekboard tuxcall 1 1,211 02-02-2023, 08:51 PM
Last Post: Haibara23
  suspend inhibit no longer working jsch 3 1,966 10-23-2022, 09:20 AM
Last Post: LibrePhoneUser
  Rescue Your Mobian post Update Aug22 faster fix to working guide biketool 9 4,699 09-05-2022, 12:10 AM
Last Post: biketool
  How to get Pinetime working with Pinephone arkadione 12 7,242 08-28-2022, 12:30 PM
Last Post: Fish
  Receiving SMS stopped working treebeard 11 5,468 08-12-2022, 10:31 AM
Last Post: treebeard
  PP keyboard not working at all jojuma 3 1,772 08-03-2022, 10:02 AM
Last Post: jojuma

Forum Jump:

Users browsing this thread: 1 Guest(s)