suspend inhibit no longer working
Listening to podcasts using gnome-podcasts (flatpak) was working fine until last weekend. It no longer prevents the system from suspend.
The log shows
xdg-desktop-por[1103]: A backend call failed: Inhibiting other than idle not supported
On Friday everything was fine, next time I started podcasts (on Monday) the system went to sleep after 5 minutes.
Between Friday and Monday ~40 packages were updated.
Any idea where to start hunting this issue?

List of updated (and added) packages
bat:arm64 0.21.0-2
curl:arm64 7.84.0-2
dbus:arm64 1.14.0-1
desktop-file-utils:arm64 0.26-1
ent:arm64 1.2debian-3
epiphany-browser:arm64 42.3-1
epiphany-browser-data:all 42.3-1
hicolor-icon-theme:all 0.17-2
initramfs-tools:all 0.142
initramfs-tools-core:all 0.142
iw:arm64 5.19-1
libcairo2:arm64 1.16.0-6
libcairo-gobject2:arm64 1.16.0-6
libcairo-script-interpreter2:arm64 1.16.0-6
libc-bin:arm64 2.33-7
libcurl3-gnutls:arm64 7.84.0-2
libcurl3-nss:arm64 7.84.0-2
libcurl4:arm64 7.84.0-2
libglib2.0-0:arm64 2.72.3-1
libksba8:arm64 1.6.0-3
libmbedcrypto7:arm64 2.28.1-1
libmbedtls14:arm64 2.28.1-1
libmbedx509-1:arm64 2.28.1-1
libmjpegutils-2.1-0:arm64 1:2.1.0+debian-7
libmm-glib0:arm64 1.18.10-1
libmpeg2encpp-2.1-0:arm64 1:2.1.0+debian-7
libmplex2-2.1-0:arm64 1:2.1.0+debian-7
libphonenumber8:arm64 8.12.51+ds-1
libprotobuf-c1:arm64 1.4.1-1
libqmi-glib5:arm64 1.30.8-1
libqmi-proxy:arm64 1.30.8-1
libsdl1.2debian:arm64 1.2.15+dfsg2-7
libupower-glib3:arm64 0.99.20-1
libwavpack1:arm64 5.5.0-1
libzbar0:arm64 0.23.92-6
mailcap:all 3.70+nmu1
man-db:arm64 2.10.2-1
megapixels:arm64 1.5.2-1
modemmanager:arm64 1.18.10-1
mutter-common:all 42.3-2
phosh:arm64 0.17.0-2.1
phosh-mobile-tweaks:all 0.17.0-2.1
udev:arm64 251.2-7
upower:arm64 0.99.20-1
zbar-tools:arm64 0.23.92-6
Looks like previously `gnome-session-inhibit` was enough to prevent suspend, and now `gnome-session-inhibit --inhibit suspend` is needed.
`gnome-session-inhibit --inhibit suspend` does indeed work for this purpose, but I don't think it's enough to inhibit suspend when the program is running. You should be able to pause the program and have your phone go to sleep, without completely quitting the program.

Sguard really is the perfect solution, as it only inhibits suspend when audio is playing. However, I can't get it to work:
(10-23-2022, 05:39 AM)3x5co Wrote: Sguard really is the perfect solution, as it only inhibits suspend when audio is playing. However, I can't get it to work:

sguard relied on a Pulseaudio command, so it no longer works now that Debian has switched to PipeWire. However, this is an easy fix. In sguard’s code, replace this line:

pacmd list sinks | grep -E "(s|S)tate: RUNNING$"

with this:

pactl list sinks | grep -E "(s|S)tate: RUNNING$"

I emailed sguard’s developer about this months ago, but received no reply.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Suspend on ram user641 2 130 09-25-2023, 01:44 PM
Last Post: user641
  System won't suspend due to suspention notification user641 6 209 09-24-2023, 05:47 AM
Last Post: user641
  Power Consumption on Suspend JudgeFudge 8 836 07-29-2023, 06:24 AM
Last Post: JudgeFudge
  Chatty does not work after suspend mode user641 4 1,103 07-18-2023, 10:43 AM
Last Post: alaraajavamma
  APN settings not working with new operator SIM card user641 1 707 03-01-2023, 04:43 PM
Last Post: anonymous
  Possible Solution for Microphone Not Working Ferriah 0 704 02-13-2023, 01:09 PM
Last Post: Ferriah
  Squeekboard stopped working Zebulon Walton 2 763 11-24-2022, 08:41 PM
Last Post: Zebulon Walton
  Rescue Your Mobian post Update Aug22 faster fix to working guide biketool 9 3,514 09-05-2022, 12:10 AM
Last Post: biketool
  How to get Pinetime working with Pinephone arkadione 12 5,468 08-28-2022, 12:30 PM
Last Post: Fish
  Receiving SMS stopped working treebeard 11 4,105 08-12-2022, 10:31 AM
Last Post: treebeard

Forum Jump:

Users browsing this thread: 1 Guest(s)