Problems installing/ booting a different Linux on PinebookPro
Hello community,

currently I'm using Armbian (Debian/ Bullseye) on my PinebookPro and I've been pretty ok with it. Yes, it is slow, and yes, internal speakers are terrible, and true, suspend does not work (in a usable fashion that's not quickly draining the battery), and well, occasionally the screen just stays blank when trying to boot... but the device is light and quiet.

But since I read on this forum that "my" Armbian was not supported anymore, and also hoping I'd get a U-Boot version with graphical output, I tried to install a different Linux this weekend. In conclusion I gave up for the time being, deciding my system was good enough for now, and I'd probably better soon switch to a 2013 ThinkPad 440s with twice the RAM, which I happened to get some time after having bought the PinebookPro.

I tried the Manjaro image writer script, and I tried downloading and booting the Manjaro image. First I tried SD cards with my Armbian still on the emmc, which would not boot. I kind of remembered (from my experience one, two years back) that this was probably the u-boot from the SD card trying to boot the system from the emmc (?).

Well, no problem, I thought, since I purchased the emmc to usb adapter some time last year: I'll just write the image straight to the emmc. This did work to some extend: I had u-boot output, the screen would switch to the Manjaro boot logo... and get stuck there. I could press escape and get system messages, though:

Waiting 10 seconds for device /dev/disk/by-partuuid/57[...] ...
ERROR: device 'PARTUUID=57[...]' not found. Skipping fsck
[not?] mounting 'PARTUUID=57[...]' on real root.
Mount: /new_root: can't find PARTUUID=57[...].
Your are now being dropped into an emergency shell.
?h: Can't access tty; job control turned off
[rootfs ]#

(Sorry, the left of the photo I took from the screen was not entirely readable.)

Strange, I thought, and tried to fix it by taking out the emmc again, and modifying the /etc/fstab on it. I changed the UUIDs for "/boot/" and "/" so they'd correspond to what was shown in "/dev/disk-by-uuid". This made the process get further, with "/" apparently being ok now, but "/boot" still would not get mounted, and so booting still failed, still giving me no keyboard input. The /boot partition UUID was suspiciously short, maybe due to the vfat file system on it.

This was where I had enough for now. I thought I'd still write it down in the forum, so maybe someone can use this feedback to improve the documentation and/ or the software. If someone can point out a simple way of installing a working Linux, I might also try that some time soon.

I read on the forum there's a new Armbian maintainer. Now it is based on Ubuntu, which would be fine with me once 22.04LTS is out.

But what's the right way of installing it? Do I have to "hide" the emmc by either overriding the partition (thus destroying my working system before having an alternative ready), or by taking it out/ disabling it with the hardware switch? The latter is quite annoying, since already my Pinebook case is damaged from: one screw has come through the now widened hole, and I ripped one of the speaker cables out by accident (not terrible, since I'm mostly using an external USB speaker anyways).
Try to write the MrFixit image to the eMMC.
I assume you can download it from here.

Write Manjaro to the SD and see if you can boot it.
Install manjaro-arm-flasher and run the installer from the SD to install on the eMMC.
You can still build a Debian image.  Even if not 'Supported' (which only means that pre-compiled images are no longer hosted on project infrastructure).

What is Free Software and why is it so important for society?

Protocols, not Platforms

For the most Linux-y experience on your Linux phone, try SXMO!

I am (nominally) the Armbian Maintainer for PineBook Pro (although severely lacking in time these days).
(03-06-2022, 05:50 AM)jiyong Wrote: Try to write the MrFixit image to the eMMC.
I assume you can download it from here.

Write Manjaro to the SD and see if you can boot it.
Install manjaro-arm-flasher and run the installer from the SD to install on the eMMC.

I think it's now called manjaro-arm-installer. The manjaro-arm-flasher was deprecated if I am not mistaken.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Attempting to install Void Linux, boots into a black screen 9a3eedi 0 59 02-18-2024, 08:54 AM
Last Post: 9a3eedi
  Help installing Manjaro on eMMC of Pinebook Pro pine4546464 4 1,773 12-13-2023, 07:22 PM
Last Post: trillobite
  Issue with booting Manjaro from encrypted NVMe drive on pbp Cs137 1 864 08-18-2023, 01:58 AM
Last Post: juliamenendez
  Would a Pinebook Pro be good for a Linux newbie? cassado10 6 1,228 08-08-2023, 04:58 AM
Last Post: moobythegoldensock
  Kali Linux for Pinebook Pro - stuck on the login screen owaspfap 0 576 07-13-2023, 05:21 PM
Last Post: owaspfap
  Kali Linux for Pinebook Pro Luke 100 152,464 05-03-2023, 06:10 AM
Last Post: dachalife
  Fix for Armbian not booting on PBP from eMMC agreenbhm 7 3,479 04-01-2023, 02:58 PM
Last Post: TRS-80
  unsuccessful re-install of OS for PineBookPro Valiance 3 1,128 02-14-2023, 12:49 PM
Last Post: Valiance
  Big bluetooth problems ColoBill 2 994 12-15-2022, 01:38 PM
Last Post: ColoBill
  DiY - Installing Void Linux ARM On The Pinebook Pro vincele 1 1,076 11-28-2022, 05:03 PM
Last Post: tllim

Forum Jump:

Users browsing this thread: 1 Guest(s)