[Urgent] RMA request for PineTime.
#1
Information 
I purchased the PineTime smart watch from www.fabtolab.com, a seller in India, as recommended by people on the PineTime matrix server. I purchased this watch on 15th of July, and received it on 19th of July. The day I got it, I tried to press the button to see if the watch came with any battery, nothing happened, so I assumed the battery was dead. Then I put it on charging, the screen turned on, I saw the PineTime logo, and I left it there for about 5-10 mins. I then again checked to see if got charged enough to be usable. I press the button and nothing happens. I tried a couple of times but no luck. Then I asked on the PineTime matrix server to see if someone could help me. So people on the server replied saying that it could be the bug that was in older firmware, that the watch freezes in its sleep, and only way to wake it up again, is to let the battery drain and the watch to reset it self. So I waited 5-6 days, and finally on Sunday 24th of July, it turned on again. And as suggested by the matrix server, I didn't let the watch screen go to sleep, and connected it to my phone, and flashed the new firmware. Everything was successful at this point, only when I went navigating around the watch's interface, I noticed I could not go back out of some menu's as the button does nothing when presses, short or long presses. So I think the button is broken or damaged.

I posted a RMA request on the seller's site, and they asked me to post this here, so people can confirm that this is  a manufacturing defect.

I posted the question on Matrix server the same day I received the product, there must be some history of chat, that can be used to verify this.
  Reply
#2
Sounds like yeah the button is not functional for some reason.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Pinetime Screen issue after bootloop troubles Spater 12 424 09-15-2022, 05:03 PM
Last Post: wibble
  PineTime Sleep Tracking any_mouse 10 3,520 09-12-2022, 01:25 PM
Last Post: wibble
  PineTime CE conformity pt1 2 975 08-30-2022, 10:05 AM
Last Post: pt1
  Pinetime stuck at infinitime logo monto 3 482 08-27-2022, 11:26 AM
Last Post: monto
  PineTime Touch Screen Stopped Working BlunderingBushcraft 3 797 07-30-2022, 04:19 PM
Last Post: headgr
  can anyone suggest their working Linux bluetooth USB dongles to connect to Pinetime? jahway603 4 403 07-27-2022, 07:38 PM
Last Post: jahway603
  Pinetime almost dead... only shows Infinitime logo. lightweight 6 1,729 06-18-2022, 03:21 AM
Last Post: bboett
  Any plans for a revised PineTime? nixcamic 0 619 05-16-2022, 11:14 AM
Last Post: nixcamic
Lightbulb Feature Request duilns 8 1,968 05-10-2022, 08:19 AM
Last Post: ITCactus
  Any hope for PineTime. lakotaubp 5 1,410 04-25-2022, 07:49 AM
Last Post: lakotaubp

Forum Jump:


Users browsing this thread: 1 Guest(s)