Intermittent Mobile Data
#1
Greetings:
Just went to T-Mobile in Greece, NY this past Friday to have my new Pine64 phone activated. 

To make a long story short, when you first boot it up, in Cellular Networks tab under settings, it shows APN as fast.t-mobile.com. But when you try to access the internet, it doesn't work (I forget the error message right now). But if I wait long enough it will connect to the internet. HOWEVER if I let it sit long enough, it will lose network connectivity altogether. It will show nothing under Access Points or SIM Cards. It's running Manjaro-ARM that it shipped with. KDE Plasma version 5.21.2. KDE Frameworks Version 5.79.0. Qt version 5.15.2. Kernel 5.11.3-1Majaro-ARM. Not sure which, if any, you needed. I attempted to do an update, but it errored out concerning dependencies. 

I'm new to this. What should I do? 

If it makes a difference, I'm currently in Orangeburg, SC at this time. I drive truck.
  Reply
#2
> if I let it sit long enough, it will lose network connectivity altogether.

That might be unrelated if "sit long enough" includes the phone suspending. IME the closed modem firmware wigs out during suspend.
  Reply
#3
I would advise you to update from the terminal with `sudo pacman -Syu` and reboot or even better flash it with the latest image and set the APN again.

It seems that the phone either loses the communication with the modem or with the SIM, it may be software related or something wrong with the hardware.
  Reply
#4
That sounds like a Crust related issue. It is a known bug being worked on. It can partially be fixed by excecuting the following commands in terminal:

sudo rm /var/lib/pacman/db.lck
sudo pacman -Syyu

Click yes, if prompts show up to replace certain files.
That should fix your dependencies and update your device. But, the crust issue is not yet resolved, only improved.
  Reply
#5
We are not getting Internet anywhere that is out of range of Wi-Fi (work, home, etc.) Is this related to the crust issue?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  GCI data on Pine Phone nelstomlinson 0 39 09-26-2021, 04:04 PM
Last Post: nelstomlinson
  How did you get data working on PureTalk? nelstomlinson 2 56 09-26-2021, 03:50 PM
Last Post: nelstomlinson
Question Mobile Carriers 67comet 29 7,820 07-14-2021, 11:47 PM
Last Post: rocket2nfinity
  T-mobile USA region celluar issue FOSSagent0 6 1,317 06-07-2021, 06:02 AM
Last Post: FOSSagent0
  Cellular Data, Mobian - "No WWAN Adapter Found" justneedsomedatathanks 2 711 05-03-2021, 03:08 PM
Last Post: awaittrot
  New Zealand network providers mobile data Linux2thabone 2 835 04-30-2021, 07:54 PM
Last Post: Linux2thabone
  LG is shutting down their mobile production daniel_mazurkiewicz 4 1,025 04-07-2021, 05:16 PM
Last Post: dsimic
  Data downloading not working with SIM IMSAI8080 4 1,263 03-15-2021, 08:39 AM
Last Post: IMSAI8080
  Problems updating KDE Plasma Mobile OS IMSAI8080 1 656 03-07-2021, 01:12 PM
Last Post: mark1250
  Mobile Data, KDE Community Edition and pinephone-modem-setup plaristote 1 771 02-15-2021, 10:59 PM
Last Post: C0ffeeFreak

Forum Jump:


Users browsing this thread: 1 Guest(s)