PBP won't boot
#1
Hi!

Yesterday, I rebooted my PBP and it did not boot again. The green power led is not on.

I have 2 power supplies, and I see that the red light is not lit with the one I used yesterday. I have created a support ticket for this defective power supply.
So it could be I drained the battery to 0%.
I plugged the PBP all the night to recharge the battery.

I tried to unplug the battery and use the bypass cable, long press on the power button, press the reset button, but no success.

I tried to boot a SD card but no success too.

Before this state, the OS on the eMMC and on the SDCard were working fine (Gentoo like all my PC and other ARM servers).

I don't have the official debug cable, but I can make one with a USB FTDI cable and a hacked jack cable.  Or do you have any reference I can use instead? or wait until it's available on the Pine Store?

I did NOT flash the SPI nor U-BOOT, they are working and I don't want to brick the boot process. I only did a repartition on the existing Manjaro, keeping the start offset of the first partition.

What operation can I do to unbrick it?

Thank you very much!

Kind regards,
Xavier
Kind regards,
Xavier Miller.
  Reply
#2
luckily the pbp is unbrickable, so you can recover it. If you drained your battery down to 0, overnight likely isn't a long enough recharge. i've always had to let mine recharge (from 0) for 18-24h.
  Reply
#3
Hi!

you give me hope :-)

Do I need to wait until the battery is full or can I try it half-charged?

Do I need to find/build a debug cable?
Do you have any reference that is OK ? Many of those I see are reverted (Tx on tip), or at 5V...

This Delock cable ?
https://www.reichelt.com/de/en/cable-usb...63097.html
Kind regards,
Xavier Miller.
  Reply
#4
I found one at amazon fr : https://www.amazon.fr/gp/product/B08VS46V91/
Let's hope it's OK

This cable will permit me to fiddle with U-BOOT or SPI
Kind regards,
Xavier Miller.
  Reply
#5
Hi!

I got a working debug cable and I can access to the boot process.
I have a boot loop. Do I need to go into recovery mode and reset U-BOOT ?

Code:
Usb re Boot. 18097204
SoftReset
DDR Version 1.20 20190314
In
soft reset
SRX
channel 0
CS = 0
MR0=0x98
MR4=0x3
MR5=0xFF
MR8=0x8
MR12=0x72
MR14=0x72
MR18=0x0
MR19=0x0
MR24=0x8
MR25=0x0
CS = 1
MR0=0x18
MR4=0x3
MR5=0xFF
MR8=0x8
MR12=0x72
MR14=0x72
MR18=0x0
MR19=0x0
MR24=0x8
MR25=0x0
channel 1
CS = 0
MR0=0x98
MR4=0x3
MR5=0xFF
MR8=0x8
MR12=0x72
MR14=0x72
MR18=0x0
MR19=0x0
MR24=0x8
MR25=0x0
CS = 1
MR0=0x18
MR4=0x2
MR5=0xFF
MR8=0x8
MR12=0x72
MR14=0x72
MR18=0x0
MR19=0x0
MR24=0x8
MR25=0x0
channel 0 training pass!
channel 1 training pass!
change freq to 400MHz 0,1
channel 0
CS = 0
MR0=0x98
MR4=0x3
MR5=0xFF
MR8=0x8
MR12=0x72
MR14=0x72
MR18=0x0
MR19=0x0
MR24=0x8
MR25=0x0
CS = 1
MR0=0x18
MR4=0x3
MR5=0xFF
MR8=0x8
MR12=0x72
MR14=0x72
MR18=0x0
MR19=0x0
MR24=0x8
MR25=0x0
channel 1
CS = 0
MR0=0x98
MR4=0x82
MR5=0xFF
MR8=0x8
MR12=0x72
MR14=0x72
MR18=0x0
MR19=0x0
MR24=0x8
MR25=0x0
CS = 1
MR0=0x18
MR4=0x2
MR5=0xFF
MR8=0x8
MR12=0x72
MR14=0x72
MR18=0x0
MR19=0x0
MR24=0x8
MR25=0x0
channel 0 training pass!
channel 1 training pass!
change freq to 800MHz 1,0
Channel 0: LPDDR4,800MHz
Bus Width=32 Col=10 Bank=8 Row=15/15 CS=2 Die Bus-Width=16 Size=2048MB
Channel 1: LPDDR4,800MHz
Bus Width=32 Col=10 Bank=8 Row=15/15 CS=2 Die Bus-Width=16 Size=2048MB
256B stride
ch 0 ddrconfig = 0x101, ddrsize = 0x2020
ch 1 ddrconfig = 0x101, ddrsize = 0x2020
pmugrf_os_reg[2] = 0x3AA1FAA1, stride = 0xD
OUT
Boot1: 2019-03-14, version: 1.19
CPUId = 0x0
ChipType = 0x10, 315
SdmmcInit=2 0
BootCapSize=100000
UserCapSize=59640MB
FwPartOffset=2000 , 100000
mmc0:cmd8,20
mmc0:cmd5,20
mmc0:cmd55,20
mmc0:cmd1,20
mmc0:cmd8,20
mmc0:cmd5,20
mmc0:cmd55,20
mmc0:cmd1,20
mmc0:cmd8,20
mmc0:cmd5,20
mmc0:cmd55,20
mmc0:cmd1,20
SdmmcInit=0 1
StorageInit ok = 70838
SecureMode = 0
SecureInit read PBA: 0x4
SecureInit read PBA: 0x404
SecureInit read PBA: 0x804
SecureInit read PBA: 0xc04
SecureInit read PBA: 0x1004
SecureInit read PBA: 0x1404
SecureInit read PBA: 0x1804
SecureInit read PBA: 0x1c04
SecureInit ret = 0, SecureMode = 0
atags_set_bootdev: ret:(0)
GPT 0x3380ec0 signature is wrong
recovery gpt...
GPT 0x3380ec0 signature is wrong
recovery gpt fail!
LoadTrust Addr:0x4000
LoadTrust Addr:0x4400
LoadTrust Addr:0x4800
LoadTrust Addr:0x4c00
LoadTrust Addr:0x5000
LoadTrust Addr:0x5400
LoadTrust Addr:0x5800
LoadTrust Addr:0x5c00
Addr:0x4000 No find trust.img!
LoadTrustBL error:-3
powerOn 97782
Usb re Boot. 6097777
DDR Version 1.20 20190314
In
channel 0
CS = 0
MR0=0x98
MR4=0x2
MR5=0xFF
MR8=0x8
MR12=0x72
MR14=0x72
MR18=0x0
MR19=0x0
MR24=0x8
MR25=0x0
CS = 1
MR0=0x18
MR4=0x2
MR5=0xFF
MR8=0x8
MR12=0x72
MR14=0x72
MR18=0x0
MR19=0x0
MR24=0x8
MR25=0x0
channel 1
CS = 0
MR0=0x98
MR4=0x2
MR5=0xFF
MR8=0x8
MR12=0x72
MR14=0x72
MR18=0x0
MR19=0x0
MR24=0x8
MR25=0x0
CS = 1
MR0=0x18
MR4=0x2
MR5=0xFF
MR8=0x8
MR12=0x72
MR14=0x72
MR18=0x0
MR19=0x0
MR24=0x8
MR25=0x0
channel 0 training pass!
channel 1 training pass!
change freq to 400MHz 0,1
channel 0
CS = 0
MR0=0x98
MR4=0x2
MR5=0xFF
MR8=0x8
MR12=0x72
MR14=0x72
MR18=0x0
MR19=0x0
MR24=0x8
MR25=0x0
CS = 1
MR0=0x18
MR4=0x2
MR5=0xFF
MR8=0x8
MR12=0x72
MR14=0x72
MR18=0x0
MR19=0x0
MR24=0x8
MR25=0x0
channel 1
CS = 0
MR0=0x98
MR4=0x2
MR5=0xFF
MR8=0x8
MR12=0x72
MR14=0x72
MR18=0x0
MR19=0x0
MR24=0x8
MR25=0x0
CS = 1
MR0=0x18
MR4=0x2
MR5=0xFF
MR8=0x8
MR12=0x72
MR14=0x72
MR18=0x0
MR19=0x0
MR24=0x8
MR25=0x0
channel 0 training pass!
channel 1 training pass!
change freq to 800MHz 1,0
Channel 0: LPDDR4,800MHz
Bus Width=32 Col=10 Bank=8 Row=15/15 CS=2 Die Bus-Width=16 Size=2048MB
Channel 1: LPDDR4,800MHz
Bus Width=32 Col=10 Bank=8 Row=15/15 CS=2 Die Bus-Width=16 Size=2048MB
256B stride
ch 0 ddrconfig = 0x101, ddrsize = 0x2020
ch 1 ddrconfig = 0x101, ddrsize = 0x2020
pmugrf_os_reg[2] = 0x3AA1FAA1, stride = 0xD
OUT
Boot1: 2019-03-14, version: 1.19
CPUId = 0x0
ChipType = 0x10, 249
SdmmcInit=2 0
BootCapSize=100000
UserCapSize=59640MB
FwPartOffset=2000 , 100000
mmc0:cmd8,20
mmc0:cmd5,20
mmc0:cmd55,20
mmc0:cmd1,20
mmc0:cmd8,20
mmc0:cmd5,20
mmc0:cmd55,20
mmc0:cmd1,20
mmc0:cmd8,20
mmc0:cmd5,20
mmc0:cmd55,20
mmc0:cmd1,20
SdmmcInit=0 1
StorageInit ok = 70600
SecureMode = 0
SecureInit read PBA: 0x4
SecureInit read PBA: 0x404
SecureInit read PBA: 0x804
SecureInit read PBA: 0xc04
SecureInit read PBA: 0x1004
SecureInit read PBA: 0x1404
SecureInit read PBA: 0x1804
SecureInit read PBA: 0x1c04
SecureInit ret = 0, SecureMode = 0
atags_set_bootdev: ret:(0)
GPT 0x3380ec0 signature is wrong
recovery gpt...
GPT 0x3380ec0 signature is wrong
recovery gpt fail!
LoadTrust Addr:0x4000
LoadTrust Addr:0x4400
LoadTrust Addr:0x4800
LoadTrust Addr:0x4c00
LoadTrust Addr:0x5000
LoadTrust Addr:0x5400
LoadTrust Addr:0x5800
LoadTrust Addr:0x5c00
Addr:0x4000 No find trust.img!
LoadTrustBL error:-3
powerOn 96251
Usb re Boot. 6096248
Usb re Boot. 12096251
Usb re Boot. 18096256
SoftReset
Kind regards,
Xavier Miller.
  Reply
#6
SOLVED: I got access to maskrom mode, empty the SPI flash, then flash U-BOOT from Manjaro to SPI and the system is back!
Kind regards,
Xavier Miller.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  boot order straightwalker 6 257 07-22-2021, 12:31 AM
Last Post: wdt
  My pbp is a sleek, black, flat brick, and won't boot from any kind of media rotwang 14 1,367 07-19-2021, 06:30 PM
Last Post: rotwang
  U-Boot, video console, and visual artifacts dsimic 14 1,135 07-19-2021, 07:22 AM
Last Post: zackw
Tongue Hello my frend. How to fix my boot problem? carinosa 6 387 07-04-2021, 04:01 AM
Last Post: jiyong
  U-Boot with direct NVMe boot support for eMMC/SPI Flash pcm720 119 103,033 06-24-2021, 11:59 AM
Last Post: sepp
  cannot boot SD card : "unable to select a mode" alchemist 0 196 06-18-2021, 02:03 AM
Last Post: alchemist
  Pinebook Boot CharlesBunders 14 2,371 06-15-2021, 07:40 PM
Last Post: James Good
  Broken Boot djhnsn 15 1,821 05-05-2021, 04:14 PM
Last Post: djhnsn
  PBP won't boot (no amber or green LED) ian-s-mcb 46 12,578 04-15-2021, 09:58 AM
Last Post: SnowyMountainWeb
  PIneBook Pro - Boot from SD mcdomx 12 11,528 03-29-2021, 01:13 AM
Last Post: 5825bc9762

Forum Jump:


Users browsing this thread: 1 Guest(s)