can't get file transfer working. Help, please!
Replace known_hosts to known_hosts.bak and try again

Wysłane z mojego CLT-L29 przy użyciu Tapatalka
a useful idea, streak. Unfortunately, still no go. Confused

walter1950: my problem is the pinephone doesn't show up as an option. I can ping it, but all the packages (easyssh, filezilla, sftp, ftp for that matter) don't see it. Usually the error message after entering manually is something like "hostname not specified." It's mobian@mobian, isn't it? So: user: mobian, hostname: mobian

Obviously, if I have that wrong, then that's a problem.... :/

I think you're right about "overconfigured"!
- - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - - -
OS: Debian 11/Bullseye. KDE. Pinephone Braveheart from 2020-02-11. Currently running Mobian.
@quixote, if you're using the hostname "mobian" do you have its IP address in your /etc/hosts or local DNS? (I have my home DHCP server set up so the Pinephone is always assigned the same IP address when it boots up. Makes things easier.)
For anyone reading this thread to figure out file transfer via ssh on mobian I recommend you ignore the above and start here.

Install openssh-server on the pinephone.

1. Generate a key (on the client machine) and copy it up to mobian:

  *** (IMPORTANT NOTE: When prompted for a yes/no answer by openssh always type the FULL word.. for example type "yes" not just "y".)

   OPTIONAL: Use USB-C instead of WiFi: (highly recommended):

2. (On the client machine) Add a "Bookmark" to your favorite File Manager that points to: "sftp://mobian@" (modify IP address accordingly)

   OPTIONAL: You can set (on the client machine) an alias(s) for your ssh server(s). Here is a guide: . Then your file manager bookmark will look more like "sftp://mobian/"

(05-28-2021, 08:59 AM)MtnSk8 Wrote:    OPTIONAL: You can set (on the client machine) an alias(s) for your ssh server(s). Here is a guide: . Then your file manager bookmark will look more like "sftp://mobian/"

My preference is to use avahi and .local hostnames, so that any machine on the lcoal network can resolve the hostname no matter what its IP address.

On mobian:
apt-get install avahi-daemon libnss-mdns

Then whatever the hostname is (e.g. "mobian"), I can access it at mobian.local, no other configuration required.

libnss-mdns is installed to enable the reverse, resolving local hostnames from the Pinephone.
If you have the docking station, just connect a usb stick with your files and do a '/mount/sda1 /home/*'

Possibly Related Threads…
Thread Author Replies Views Last Post
  Keyboard stopped working on disk encryption screen on Mobian after update cowsay 0 44 07-28-2021, 05:46 PM
Last Post: cowsay
  Programs unable to open display via sudo or pkexec (linssid not working) Zebulon Walton 3 243 07-24-2021, 06:11 PM
Last Post: Zebulon Walton
  firefox-esr stopped working after June 18 update HLing 17 1,890 07-21-2021, 02:40 PM
Last Post: dante404
  mobile data on mobian not working synaption 1 336 06-02-2021, 03:16 PM
Last Post: Aberts10
  chats not working rvh 0 237 05-18-2021, 07:48 AM
Last Post: rvh
  Installing Mobian --> "Resizing file system" forever Anna 9 2,279 05-01-2021, 07:51 PM
Last Post: jonnicholson
  Run Mobian Unstable without risking being stuck without a working phone C0ffeeFreak 3 1,124 04-23-2021, 01:10 PM
Last Post: RTP
  File transfer from Linux Desktop and PinePhone livanti21 18 13,081 03-09-2021, 08:15 PM
Last Post: MtnSk8
  UFW (uncomplicated firewall) Start On Boot - Mobian (working) theD0ctor 2 700 02-28-2021, 09:58 PM
Last Post: theD0ctor
  some flatpaks not working sfb 2 675 02-15-2021, 10:31 AM
Last Post: C0ffeeFreak

Forum Jump:

Users browsing this thread: 1 Guest(s)