Another Newb Unable to Boot From microSD
I'm not reallly a Linux newb.  I used to be a sysadmin with a farm of RedHat & Gentoo servers, and I've been toying around with various distros as home servers, all over a 20y timespan.  I only really have experience with Mint/Cinnamon as a desktop system, though (7-8y).  I am a total Pine newb, though.  Beta quality open source hardware is making me feel like a first-timer, to be sure.

My factory Manjaro install on eMMC seems to work fine, though it won't sleep; the magnet issue, presumably, but that's for another time.  My initial PEBCAK is that I opened my shiny new delivery while I was dead tired (I work the graveyard shift these days).  I did the initial setup immediately.  I used a 3-word combo for the root pw, and when I woke up that evening, I only remembered the first two words.  SMH.  The kids & I have been playing with it without issue in my user account for 2 months, but man are the software updates piling up without root access. lol

I bought a microSD card (SanDisk Extreme Plus, 128GB, XC1, V30, U3, A2 are all of the markings on it).  I've tried imaging to it with DD (CygWin on our current Win7 desktop), vanilla Etcher, and then finally the Pine64 installer version of Etcher.  I've tried imaging most of the available distros found on the PBP wiki.  None will boot.  I have not opened the case or otherwise tried to disable the eMMC.  I saw in my early reading that the microSD card comes first in the boot order.  Regardless of distro/image or warm/cold boot, I get the same result; about 10s of amber power light, followed by green, at which point the screen appears to power on (dead black to backlit but still black).  Then, nothing.  I tried increasing the screen brightness just to make sure. =)

If I insert the imaged SD card into the PBP while it's running Manjaro, and scope out the SD with Dolphin, I can see that the image appears to be intact, insofar as I see all of the expected Linux file structure.

My reading showed that SD quality could be an issue.  I downloaded H2testw on the Windows desktop and tested this card.  It wrote and verified without issue, but the write speed was a consistent 17.6MB/s, which seemed kind of slow compared to the 50ish that I see in other threads.  I'm using a little multi-card USB reader, plugged into the USB hub in my monitor.

I'd really like to just get it back to its factory state and put in a root pw that I, you know, remember.  Where shall I go next?

Thanks for reading, and sorry for being long-winded, but I didn't want to skip over any small but important items.
Are none of your users in sudo group?,,, sudo su ; passwd ,, or if all fails, edit /etc/shadow
but to do this you have to be root from a SD boot if you don't have sudo...... (id shows what groups and id you have)
Some of the manjaro uboots are a bit flaky, it is hit and miss,, some have no problems,
others have put a bsp uboot on (vrs mainline),, essential for s3 sleep (uboot-pinebookpro-bsp)
Bootrom, searches installed media at 64 sectors, its search order is SPI(at 0), emmc, SD (and usb for writing)
bootrom is searching for idbloader, then uboot gets loaded, its search order(varies) is SD, nvme, usb, emmc, network
strings uboot |grep _target,,,, uboot is looking for boot.scr/extlinux.conf, strings shows where
1st uboot found is one used, 1st boot.scr/extlinux found is also the one used, all others ignored
systemsettings5 ->power management ->button handling checked ->lid switch ignore, pwr button ask
With mainline uboot, s2idle is barely better than screen blanking, you want suspend 3 (dmesg), bsp uboot
This is not at all clear
And BTW, updates usually want your user password, yes for pacman you have to be root
Oh yes, for good SD speed is has to be ALL usb3,, and large blocks, 4k and 16k are usually pathetic,
even then an image write usually ends up at ~40 MB/s
I left windows behind 12 - 15 years ago,     but I am still a basic GUI Linux user.
  That said,   I do use a few different Linux Distro's,    Mint,  Debian Edition is one of my favorites.
I use Balena Etcher to flash my micro-sd cards and I have had no problems booting my Brave Heart or my multiple PMOS convergent phone(s).

1) download the O.S. you wish to try,  (do NOT extract ! )
 (You may wish to occasionally zero wipe your sd card but that is not usually required) 
2) Using Etcher, pick your desired downloaded operating system, and flash to your sd card.
3) put sd card into your pine phone and boot into the O.S. you have installed.
    (Remember to note the default user and password when downloading)

I have not had any problems when following these steps.

Having expensive fast sd cards is not really helpful ( but, does not hurt )  but the Pine phone reads
sd cards at about 23mbps... so high speed expensive cards is not really a plus.
   Donate to $upport
your favorite OS Team
SMH again. Since I never added myself to wheel, it never occurred to me that I'd be a member automatically. But you're right, bcnaz, I am. I feel like Dorothy; "You've had root all along!" Easiest solve ever. Thanks for your replies, folks. I'm grateful.

Possibly Related Threads…
Thread Author Replies Views Last Post
  3 days in, slow/stuck or no boot. lgmpbp2 6 558 8 hours ago
Last Post: tophneal
  upgrading u-boot--what version? where to get it? bsammon 11 1,288 05-22-2024, 09:33 AM
Last Post: wdt
  uboot wont boot to SD card after upgrade jbradley419 7 1,553 01-19-2024, 02:29 PM
Last Post: wdt
  Video Flashing/adjusting on boot and reboot jbradley419 0 493 01-16-2024, 09:17 AM
Last Post: jbradley419
  Brand new Pinebook Pro doesn't boot after Manjaro update johnboiles 8 2,986 12-15-2023, 02:11 PM
Last Post: wdt
  PBP won't boot after trying to reinstall Manjaro ARM soupgirl 3 1,097 12-13-2023, 08:17 PM
Last Post: trillobite
  Various freezes during boot & while running several Linux distros - hardware error? donuts 1 848 11-22-2023, 11:47 AM
Last Post: fxc
  Cannot boot to Kali SD card after uboot upgrade jbradley419 4 1,587 09-19-2023, 08:48 AM
Last Post: dachalife
  Does latest Tow-Boot install/work correctly for everyone? tophneal 4 2,410 08-03-2023, 03:30 PM
Last Post: tophneal
  Boot into NVME drive, no wifi, sound, buttons... PaulQ 0 962 07-13-2023, 01:50 PM
Last Post: PaulQ

Forum Jump:

Users browsing this thread: 1 Guest(s)