[Solved] SD Card strange boot behaviour
#1
I have a pinebook pro running the Manjaro KDE default install everything is working fine. I'm very pleased with the device. I had ordered an additional eMMC of 128GB to replace the 64GB eMMC with. So I installed an other OS, Manjaro I3 SD card image, on a micro SD card I owned (samsung micro sd hc card of 32 GB read and write speeds not known..) and I am experiencing some weird boot issues.

Here are the scenario's:
- If I shutdown the pinebook pro insert the SD Card and power it on, I get the orange light, turning green, but the device won't boot from the SD-card.
- If I boot from the eMMC, insert the SD Card, mount the boot partition of the SD-card and restart the device, it boots without any issues from the SD-card.

Now if I want to replace the eMMC with the 128GB one I am not able to boot from the SD-card as it won't boot from a 'cold' start.

Might this be an issue with the SD-card being to slow? or is this some other problem? I've done the above two scenario's many times over and over again and it always succeeds when first booting up from eMMC, inserting the SD Card, mounting the boot partition of the SD-card and reboot.
#2
(06-29-2020, 02:55 AM)benderni Wrote: I have a pinebook pro running the Manjaro KDE default install everything is working fine. I'm very pleased with the device. I had ordered an additional eMMC of 128GB to replace the 64GB eMMC with. So I installed an other OS, Manjaro I3 SD card image, on a micro SD card I owned (samsung micro sd hc card of 32 GB read and write speeds not known..) and I am experiencing some weird boot issues.

Here are the scenario's:
- If I shutdown the pinebook pro insert the SD Card and power it on, I get the orange light, turning green, but the device won't boot from the SD-card.
- If I boot from the eMMC, insert the SD Card, mount the boot partition of the SD-card and restart the device, it boots without any issues from the SD-card.

Now if I want to replace the eMMC with the 128GB one I am not able to boot from the SD-card as it won't boot from a 'cold' start.

Might this be an issue with the SD-card being to slow? or is this some other problem? I've done the above two scenario's many times over and over again and it always succeeds when first booting up from eMMC, inserting the SD Card, mounting the boot partition of the SD-card and reboot.
Try mounting your SD card boot partition, and editing the extlinux/extlinux.conf file for the SD card to add two dots before each slash as in this post: https://forum.manjaro.org/t/arm-stable-update-2020-04-02-kde-plasma-5-18-4-xorg-server-1-20-8-plasma-mobile-uboots-and-kernels/133266/2 

I
 know it's not supposed to be required on a fresh image, but it solved it for me when I was in your exact scenario.
#3
(06-29-2020, 09:21 AM)carlosqueso Wrote:
(06-29-2020, 02:55 AM)benderni Wrote: I have a pinebook pro running the Manjaro KDE default install everything is working fine. I'm very pleased with the device. I had ordered an additional eMMC of 128GB to replace the 64GB eMMC with. So I installed an other OS, Manjaro I3 SD card image, on a micro SD card I owned (samsung micro sd hc card of 32 GB read and write speeds not known..) and I am experiencing some weird boot issues.

Here are the scenario's:
- If I shutdown the pinebook pro insert the SD Card and power it on, I get the orange light, turning green, but the device won't boot from the SD-card.
- If I boot from the eMMC, insert the SD Card, mount the boot partition of the SD-card and restart the device, it boots without any issues from the SD-card.

Now if I want to replace the eMMC with the 128GB one I am not able to boot from the SD-card as it won't boot from a 'cold' start.

Might this be an issue with the SD-card being to slow? or is this some other problem? I've done the above two scenario's many times over and over again and it always succeeds when first booting up from eMMC, inserting the SD Card, mounting the boot partition of the SD-card and reboot.
Try mounting your SD card boot partition, and editing the extlinux/extlinux.conf file for the SD card to add two dots before each slash as in this post: https://forum.manjaro.org/t/arm-stable-update-2020-04-02-kde-plasma-5-18-4-xorg-server-1-20-8-plasma-mobile-uboots-and-kernels/133266/2 

I
 know it's not supposed to be required on a fresh image, but it solved it for me when I was in your exact scenario.

Thanks for the info, the extlinux/extlinux.conf file already contained the two dots before each slash. I tried /boot/ also instead of the two dots. But that didn't work either. So I'm still stuck on the cold boot issue from my SD card. I also updated the /boot/extlinux/extlinux.conf to contain the two dots. But that didn't help to boot from the SD card either.

Any other suggestions?
#4
I got nothin'. That worked for me, so hopefully someone smarter than I will have a solution for you.
#5
(06-29-2020, 05:31 PM)carlosqueso Wrote: I got nothin'.  That worked for me, so hopefully someone smarter than I will have a solution for you.

The solution you mentioned did work, upgraded to 128GB eMMC and was able to install via emmc installer image on the sdcard

A big thank you for pointing me in the right direction!


Possibly Related Threads…
Thread Author Replies Views Last Post
  My pbp is a sleek, black, flat brick, and won't boot from any kind of media rotwang 2 66 2 hours ago
Last Post: KC9UDX
  cannot boot SD card : "unable to select a mode" alchemist 0 41 Yesterday, 02:03 AM
Last Post: alchemist
  Pinebook Boot CharlesBunders 14 1,496 06-15-2021, 07:40 PM
Last Post: James Good
  U-Boot, video console, and visual artifacts dsimic 3 230 06-11-2021, 12:16 PM
Last Post: jamie22
  U-Boot with direct NVMe boot support for eMMC/SPI Flash pcm720 118 95,152 06-08-2021, 11:04 PM
Last Post: calinb
  PBP won't boot alchemist 5 318 06-07-2021, 09:31 AM
Last Post: alchemist
Video Problem Booting from SD card ezryder324r 0 162 05-19-2021, 02:42 PM
Last Post: ezryder324r
  Broken Boot djhnsn 15 1,292 05-05-2021, 04:14 PM
Last Post: djhnsn
  PBP won't boot (no amber or green LED) ian-s-mcb 46 11,000 04-15-2021, 09:58 AM
Last Post: SnowyMountainWeb
  PIneBook Pro - Boot from SD mcdomx 12 10,785 03-29-2021, 01:13 AM
Last Post: 5825bc9762

Forum Jump:


Users browsing this thread: 1 Guest(s)