Unable to initialize message in chatty
#11
(07-06-2020, 11:45 AM)bcnaz Wrote: ...,  however on incoming phone calls, it does not show the callers name.
  ( July 03 nightly build )

Damn, for some reason it works for some people and not for others. Out of curiosity:
Do you have the locale set to where you live in Settings->Region & Language->Formats ?

There might be something going on with the contact matching depending the selected locale (I will probably dig into this soon-ish).
#12
(07-06-2020, 04:41 PM)devrtz Wrote:
(07-06-2020, 11:45 AM)bcnaz Wrote: ...,  however on incoming phone calls, it does not show the callers name.
  ( July 03 nightly build )

Damn, for some reason it works for some people and not for others. Out of curiosity:
Do you have the locale set to where you live in Settings->Region & Language->Formats ?

There might be something going on with the contact matching depending the selected locale (I will probably dig into this soon-ish).
You are a genius! I had my region set to the United States but my language was 'unspecified'. Once set to 'English (US) everything is working normally now. Thank you very much!
#13
(07-06-2020, 07:58 PM)livanti21 Wrote:
(07-06-2020, 04:41 PM)devrtz Wrote:
(07-06-2020, 11:45 AM)bcnaz Wrote: ...,  however on incoming phone calls, it does not show the callers name.
  ( July 03 nightly build )

Damn, for some reason it works for some people and not for others. Out of curiosity:
Do you have the locale set to where you live in Settings->Region & Language->Formats ?

There might be something going on with the contact matching depending the selected locale (I will probably dig into this soon-ish).
You are a genius! I had my region set to the United States but my language was 'unspecified'. Once set to 'English (US) everything is working normally now. Thank you very much!

Same here :
  I had region  US
but language 'unspecified'
Now incoming calls from contacts are identified.
 However, it may or may not be connected to another problem ?
   Since correcting that problem my text messages have went berserk.
  many (but not all) of my messages from July have disappeared.?  leaving the ones from may ?
    that does not make any sense,  as I installed July 03 release.?
     MOST of my messages now read  ' 31.05.79 '   ? ?
#14
Setting the region and language did seem to fix some of the issues I had with the Chatty app. However, I still have issues with creating a new SMS. Looking at the output from the mmcli it looks like chatty is trying to format the phone number for me in a way that the modem doesn't like. For example the phonenumber of texts that are able to be sent out are formatted as 1112223333, which is how I have my contacts saved to prevent this issue. However, chatty seems to reformat them to (111) 222-3333. Has anyone else noticed this or found a way to tell Chatty to not re-format the numbers?

Edit: Nevermind, its the +x country code issue that fixed it.
#15
(07-06-2020, 04:41 PM)devrtz Wrote:
(07-06-2020, 11:45 AM)bcnaz Wrote: ...,  however on incoming phone calls, it does not show the callers name.
  ( July 03 nightly build )

Damn, for some reason it works for some people and not for others. Out of curiosity:
Do you have the locale set to where you live in Settings->Region & Language->Formats ?

There might be something going on with the contact matching depending the selected locale (I will probably dig into this soon-ish).

Mobian 20200707 Nightly :
( Now I do fill in both blanks, region & Language many thanks for that )

SMS texting is working good now with one small problem, in chatty preferences you only have two choices, neither is SMS.?
                                                                                                                                      ( XMPP or Telegram )         
I cannot start my SMS text App if I have no new messages after a fresh boot.
   I can text the pine phone from my second phone, then it works fine, until the next reboot.
Once the SMS is opened, you can close and re-open the SMS App no problem...  until the next boot.

Is there another blank that needs to be changed or answered differently  ?
#16
(07-07-2020, 10:36 PM)bcnaz Wrote:
(07-06-2020, 04:41 PM)devrtz Wrote:
(07-06-2020, 11:45 AM)bcnaz Wrote: ...,  however on incoming phone calls, it does not show the callers name.
  ( July 03 nightly build )

Damn, for some reason it works for some people and not for others. Out of curiosity:
Do you have the locale set to where you live in Settings->Region & Language->Formats ?

There might be something going on with the contact matching depending the selected locale (I will probably dig into this soon-ish).

Mobian 20200707 Nightly :
( Now I do fill in both blanks, region & Language many thanks for that )

SMS texting is working good now with one small problem, in chatty preferences you only have two choices, neither is SMS.?
                                                                                                                                      ( XMPP or Telegram )         
I cannot start my SMS text App if I have no new messages after a fresh boot.
   I can text the pine phone from my second phone, then it works fine, until the next reboot.
Once the SMS is opened, you can close and re-open the SMS App no problem...  until the next boot.

Is there another blank that needs to be changed or answered differently  ?
I do not know if this is somehow related to any of the aforementioned issues but I didn’t want to start a new thread if it is. I can send and receive texts fine. I have appended the country to code to all my contacts already. When I get a reply from anyone in my contacts list the message shows up as a new thread under the their phone number instead of their contact name. I have my contacts starting with 01 (I’m in the US) and my reply threads show the number I initially texted as a +1 number. How can I get chat threads straight? If I’ve worded something poorly let me know and I’ll try and rephrase or get some images some how (how do you screenshot btw?). Thanks in advance. And keep up the amazing work, you devs are working fast!!
#17
(07-17-2020, 03:02 PM)Captain1ndustry Wrote:
(07-07-2020, 10:36 PM)bcnaz Wrote:
(07-06-2020, 04:41 PM)devrtz Wrote:
(07-06-2020, 11:45 AM)bcnaz Wrote: ...,  however on incoming phone calls, it does not show the callers name.
  ( July 03 nightly build )

Damn, for some reason it works for some people and not for others. Out of curiosity:
Do you have the locale set to where you live in Settings->Region & Language->Formats ?

There might be something going on with the contact matching depending the selected locale (I will probably dig into this soon-ish).

Mobian 20200707 Nightly :
( Now I do fill in both blanks, region & Language many thanks for that )

SMS texting is working good now with one small problem, in chatty preferences you only have two choices, neither is SMS.?
                                                                                                                                      ( XMPP or Telegram )         
I cannot start my SMS text App if I have no new messages after a fresh boot.
   I can text the pine phone from my second phone, then it works fine, until the next reboot.
Once the SMS is opened, you can close and re-open the SMS App no problem...  until the next boot.

Is there another blank that needs to be changed or answered differently  ?
I do not know if this is somehow related to any of the aforementioned issues but I didn’t want to start a new thread if it is. I can send and receive texts fine. I have appended the country to code to all my contacts already. When I get a reply from anyone in my contacts list the message shows up as a new thread under the their phone number instead of their contact name. I have my contacts starting with 01 (I’m in the US) and my reply threads show the number I initially texted as a +1 number. How can I get chat threads straight? If I’ve worded something poorly let me know and I’ll try and rephrase or get some images some how (how do you screenshot btw?). Thanks in advance. And keep up the amazing work, you devs are working fast!!
It looks like there has been some fixes in in the purple-mm-sms repository, which Chatty relies on, that should fix the need for the country code to get chatty to send texts. So when the version 0.1.6 of purple-mm-sms works its way into Mobian that problem *should* go away. I have my contacts stored as just 10 digit numbers to prevent this issue since thats how the numbers show up from the modem manager.


Possibly Related Threads…
Thread Author Replies Views Last Post
Sad Chatty can no longer start since the last update anonymous 6 382 05-23-2022, 06:47 AM
Last Post: Anna
  chatty v0.6 in Bookworm at last! treebeard 13 1,791 02-13-2022, 05:21 PM
Last Post: treebeard
  Programs unable to open display via sudo or pkexec (linssid not working) Zebulon Walton 4 1,661 01-17-2022, 01:58 AM
Last Post: vusra
  Chatty, SMS does not work - could hardware be at fault? AntonReiser 36 6,879 11-02-2021, 03:42 AM
Last Post: AntonReiser
  How Do I Perform a Chatty Application Reinstall? rrholmes 2 1,083 07-13-2021, 01:11 AM
Last Post: rrholmes
  Unable to play videos ("bitstream error") pietenpol 1 1,055 06-14-2021, 07:58 AM
Last Post: Gribouille
  Unable to turn off auto brightness at times motox6 0 719 05-05-2021, 07:56 PM
Last Post: motox6
  "Unable to download updates: The following packages have unmet dependencies:" bitnick 13 5,728 04-23-2021, 09:45 PM
Last Post: ryo
  Unable to send SMS on US Mobile GSM (T-Mobile MVNO) NoahAndrews 17 11,547 12-06-2020, 07:03 PM
Last Post: NoahAndrews
  Chatty remotely pawlinski 1 1,500 10-20-2020, 05:31 AM
Last Post: wibble

Forum Jump:


Users browsing this thread: 1 Guest(s)