Signal Desktop Builds for Manjaro aarch64
#21
Sorry if this counts and dredging up an old topic. I was curious if this has been attempted on a PinePhone by anyone or if there was a place other than this forum thread where it is being maintained? I tried installing the package. It installed perfectly, however I get a blue window with the menus like others have mentioned. The output from the terminal doesn't have any obvious errors.

I've tried this on the KDE Plasma and Lomiri. I'd love to get Signal working on my PinePhone.


I understand this is not the PinePhone forums, but I thought someone might have a clue since this topic was already opened. Thanks!
#22
As I now am an owner of a PinePhone as well, I'll try to see if I can pick up the previous work on electron-ozone and thus signal-ozone to see if I can add it to the pile of things to regularly build for aarch64 – I'll report back if something comes from it Wink
#23
Ubuntu Touch has a (mostly working) Signal client:
https://open-store.io/app/textsecure.nanuc
#24
Current progress with signal-desktop:

I've managed to get a build of a current electron-ozone working and managed to package signal-desktop-ozone. Somewhat hacky (pretty much just launching it directly with electron-ozone), but I'll tackle with electron-builder to directly bundle and build with electron-ozone on another day.

Unfortunately, this does not seem to be enough – the current signal-desktop code does not seem to be compatible with electron 10 (and the most obvious fix for that was not sufficient), so… I need to get an electron-ozone 9 built instead and try again.

We'll be getting there, I hope ^^
#25
Just a quick update: I've now built and tried electron-ozone 8, 9 and 10, which was a rather horrible experience – each version brought different kinds of horrors and required different workarounds /o\

Unfortunately it seems signal-desktop itself does not work with electron 10; electron 9 (and thus signal-desktop) threw some odd gles2_cmd_decoder-errors and electron 8 broke for some other reason as well.

So for now, I'll give this a rest – I don't think getting this to work (and then maintaining it) is feasible for now; this might change should proper wayland/ozone-support land in upstream electron. Until then, it's probably better to look at Axolotl – which looks like significantly less madness than the whole node-electron-etc.-mess, albeit it might lack some of the more advanced features (RTC, video/voice calls etc.).
#26
Interestingly, things miiiight get better somewhat more soonish than I would've thought:

https://github.com/electron/electron/pull/26022

(initial wayland support got merged a few days ago)


Possibly Related Threads…
Thread Author Replies Views Last Post
  Manjaro update broke hardware video acceleration with mpv myself600 2 186 01-25-2023, 09:12 AM
Last Post: myself600
  Issue with booting Manjaro from encrypted NVMe drive on pbp Cs137 0 78 01-19-2023, 01:47 PM
Last Post: Cs137
  Manjaro ARM 20.04 spikerguy 68 78,233 01-08-2023, 07:22 PM
Last Post: vandys
  org.kde.plasma.core not installed (Manjaro) twirlip 0 92 01-06-2023, 09:47 AM
Last Post: twirlip
  Help installing Manjaro on eMMC of Pinebook Pro pine4546464 2 250 12-31-2022, 12:18 PM
Last Post: pine4546464
  slarm64 (unofficial slackware) Pinebook Pro RK3399 (aarch64) mara 39 27,387 11-12-2022, 01:06 PM
Last Post: mara
  PineBook HOW TO REINSTALL ARCH-Manjaro. Ice-O-Star 0 404 10-22-2022, 10:46 AM
Last Post: Ice-O-Star
  newer ""emmc-installer" images (manjaro xfce) magistral 1 410 10-10-2022, 06:22 AM
Last Post: maxjrh
  Webcam not working in Manjaro with Cheese, but works in Armbian petaramesh 1 363 09-30-2022, 10:09 AM
Last Post: crazyquark
  manjaro on pinebook pro low audio quality over jack alcck 1 410 09-22-2022, 11:31 AM
Last Post: petersen77

Forum Jump:


Users browsing this thread: 1 Guest(s)