Can't boot up Manjaro 20.04 eMMc image from SD card...
#1
Hello,
I'm trying to replace the original Debian OS with Manjaro 20.04. I use the latest image (eMMC version) installed to the SD card with Etcher. It starts Manjaro but I never get past the splash screen. I can flash the SD with a non-eMMC image and boot to Manjaro and run off the SD no problem. But trying to get the Manjaro image (eMMC version) to allow me to install on the PBP...Won't go....

Can someone point me to a "how to" so I can get this right? Many Thanks!! :-)
  Reply
#2
Try hitting any key at the splash screen. Maybe it will advance.
  Reply
#3
(06-10-2020, 09:12 PM)Samurai_Crow Wrote: Try hitting any key at the splash screen.  Maybe it will advance.
Thanks for the suggestion, but it doesn't seem to work. Very odd. 
I'm sure there must be something I'm missing..

This is one of the first hundred  PBP. Wondering if there's something different about this one that is causing an issue?
  Reply
#4
(06-11-2020, 06:59 AM)rick1959 Wrote: Thanks for the suggestion, but it doesn't seem to work. Very odd. 
I'm sure there must be something I'm missing..

This is one of the first hundred  PBP. Wondering if there's something different about this one that is causing an issue?

There has been at least one reported instance where the user couldn't get past the splash screen for ~20-30m. During that time ESC did nothing or cancelled the installer running in the background. After that time elapsed, hitting ESC allowed them to complete installation.

Which eMMC installer are you using, for KDE or XFCE? You might try using the other one.

If you can boot Manjaro from SD without an issue, you could use that same .img and write it directly to the eMMC, also.

There shouldn't be any major differences in the older/newer PBPs, aside from some cosmetics, like the strength/brittleness of the plastics. I have a PBP from the first and second public batches, and neither shows any difference in how they run OSes.
  Reply
#5
(06-11-2020, 07:12 AM)tophneal Wrote:
(06-11-2020, 06:59 AM)rick1959 Wrote: Thanks for the suggestion, but it doesn't seem to work. Very odd. 
I'm sure there must be something I'm missing..

This is one of the first hundred  PBP. Wondering if there's something different about this one that is causing an issue?

There has been at least one reported instance where the user couldn't get past the splash screen for ~20-30m. During that time ESC did nothing or cancelled the installer running in the background. After that time elapsed, hitting ESC allowed them to complete installation.

Which eMMC installer are you using, for KDE or XFCE? You might try using the other one.

If you can boot Manjaro from SD without an issue, you could use that same .img and write it directly to the eMMC, also.

There shouldn't be any major differences in the older/newer PBPs, aside from some cosmetics, like the strength/brittleness of the plastics. I have a PBP from the first and second public batches, and neither shows any difference in how they run OSes.
Thanks for that info Top!!
KDE....I like Manjaro for many computer uses. So if KDE works, it'll be a big boost for me.
 I'm going to work on my patience and let it take its time.
Will report back later...Many Thanks again!! :-)
  Reply
#6
(06-11-2020, 07:12 AM)tophneal Wrote:
(06-11-2020, 06:59 AM)rick1959 Wrote: Thanks for the suggestion, but it doesn't seem to work. Very odd. 
I'm sure there must be something I'm missing..

This is one of the first hundred  PBP. Wondering if there's something different about this one that is causing an issue?

There has been at least one reported instance where the user couldn't get past the splash screen for ~20-30m. During that time ESC did nothing or cancelled the installer running in the background. After that time elapsed, hitting ESC allowed them to complete installation.

Which eMMC installer are you using, for KDE or XFCE? You might try using the other one.

If you can boot Manjaro from SD without an issue, you could use that same .img and write it directly to the eMMC, also.

There shouldn't be any major differences in the older/newer PBPs, aside from some cosmetics, like the strength/brittleness of the plastics. I have a PBP from the first and second public batches, and neither shows any difference in how they run OSes.
P.S. which partition would you install the img file to on the PBP eMMC? Thanks! :-)
  Reply
#7
(06-11-2020, 09:26 AM)rick1959 Wrote: P.S. which partition would you install the img file to on the PBP eMMC? Thanks! :-)

The image contains all the partitions needed, so do not write it to any partition, but the drive itself. ie mmcblk0 not mmcblk0p1
  Reply
#8
[attachment=1893 Wrote:
.png   Screenshot at 2020-06-11 11-53-46.png (Size: 101.15 KB / Downloads: 166)
.png   Screenshot at 2020-06-11 11-53-46.png (Size: 101.15 KB / Downloads: 166)
.png   Screenshot at 2020-06-11 11-53-46.png (Size: 101.15 KB / Downloads: 166) tophneal pid='68136' dateline='1591881173']
(06-11-2020, 06:59 AM)rick1959 Wrote: Thanks for the suggestion, but it doesn't seem to work. Very odd. 
I'm sure there must be something I'm missing..

This is one of the first hundred  PBP. Wondering if there's something different about this one that is causing an issue?

There has been at least one reported instance where the user couldn't get past the splash screen for ~20-30m. During that time ESC did nothing or cancelled the installer running in the background. After that time elapsed, hitting ESC allowed them to complete installation.

Which eMMC installer are you using, for KDE or XFCE? You might try using the other one.

If you can boot Manjaro from SD without an issue, you could use that same .img and write it directly to the eMMC, also.

There shouldn't be any major differences in the older/newer PBPs, aside from some cosmetics, like the strength/brittleness of the plastics. I have a PBP from the first and second public batches, and neither shows any difference in how they run OSes.
Perfect!! It works!!! :-)
Now, which partition does it get written to? Is it the last one? I included a screenshot....Many Thanks!! :-)
.png   Screenshot at 2020-06-11 11-53-46.png (Size: 101.15 KB / Downloads: 166)

(06-11-2020, 09:28 AM)tophneal Wrote:
(06-11-2020, 09:26 AM)rick1959 Wrote: P.S. which partition would you install the img file to on the PBP eMMC? Thanks! :-)

The image contains all the partitions needed, so do not write it to any partition, but the drive itself. ie mmcblk0 not mmcblk0p1
Sorry I missed this...Many Thanks!! :-)
  Reply
#9
(06-11-2020, 09:28 AM)tophneal Wrote:
(06-11-2020, 09:26 AM)rick1959 Wrote: P.S. which partition would you install the img file to on the PBP eMMC? Thanks! :-)

The image contains all the partitions needed, so do not write it to any partition, but the drive itself. ie mmcblk0 not mmcblk0p1
Interesting...
There is no mmcblk0....There is mmcblk1 and mmcblk2, one of which is the SD card. And then there are also the choice's for the mmcblk0p1 and mmcblk0p2, which are the wrong choices.
But even if I select the non-SD card choice and hit enter, it takes me to the next page which says "no image available" and a command line prompt......
Maybe I should try XFCE version...?
I'm concerned about bricking the computer....Many Thanks for your time...:-)
  Reply
#10
(06-11-2020, 11:00 AM)rick1959 Wrote: Interesting...
There is no mmcblk0....There is mmcblk1 and mmcblk2, one of which is the SD card. And then there are also the choice's for the mmcblk0p1 and mmcblk0p2, which are the wrong choices.
But even if I select the non-SD card choice and hit enter, it takes me to the next page which says "no image available" and a command line prompt......
Maybe I should try XFCE version...?
I'm concerned about bricking the computer....Many Thanks for your time...:-)

mmcblk0 was just an example. the numbering of emmc and sd aren't universal across different OSes for the PBP. One OS could show it as mmcblk1, and another will show it as mmcblk0. determine which mmcblk is the drive you want to write to, and then write your downloaded .img to it. If you're writing to your emmc, be sure to download and use a live .img (you wouldn't want to write manjaro's emmc flash img to you emmc.)
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  eMMC frequently not found by Linux kernel (especially on low battery) v-man 11 4,298 03-31-2021, 10:28 AM
Last Post: mattpenn
  Manjaro and Arch repository with privacy oriented software as400 72 34,184 03-26-2021, 03:51 AM
Last Post: llsf
  Controlling CPU Frequency On Manjaro? ImmyChan 0 129 03-24-2021, 04:47 PM
Last Post: ImmyChan
  postmarketOS/Alpine edge image for the Pinebook Pro MartijnBraam 63 36,326 03-14-2021, 05:26 AM
Last Post: MartijnBraam
Heart PBP Arrives Tmmro, Manjaro 20.12 xfce, Seeking Install Notes/Tips/Tricks/Advice SpaceLord 4 408 03-01-2021, 06:00 PM
Last Post: SpaceLord
  Manjaro ARM 20.04 spikerguy 65 37,586 02-23-2021, 03:22 PM
Last Post: markifi
Question Manjaro arm + sway - battery indicator broken mfashby 6 910 02-20-2021, 04:07 AM
Last Post: mfashby
  Manjaro Dim Display (Brightness 40%) After Every System Reboot runlinux.run 2 383 02-15-2021, 07:04 PM
Last Post: MtnSk8
  PBP won't boot from eMMC or SD card: a saga archaicmeander 18 1,898 02-06-2021, 07:40 PM
Last Post: wdt
  Recalbox Image is available Luke 8 4,477 01-31-2021, 12:00 PM
Last Post: rimaille

Forum Jump:


Users browsing this thread: 3 Guest(s)