DOA Pinecil?
#1
My Pinecil arrived this morning and it doesn't seem to be working.

When I power it up, the main screen pops up and I can go through the menus, but as soon as I try to turn the heat on, it blinks off and then restarts.

I tried updating the firmware, but got an error message when I tried to flash it:


Invalid DFU suffix signature A valid DFU suffix will be required in a future dfu-util release!!! Error during special command "MASS_ERASE" get_status 
DFU-Util exited with error code 74!
Flashing failed.


Any suggestions on how to get it working?
  Reply
#2
(01-26-2021, 08:30 PM)foobarney Wrote: My Pinecil arrived this morning and it doesn't seem to be working.

When I power it up, the main screen pops up and I can go through the menus, but as soon as I try to turn the heat on, it blinks off and then restarts.

I tried updating the firmware, but got an error message when I tried to flash it:


Invalid DFU suffix signature A valid DFU suffix will be required in a future dfu-util release!!! Error during special command "MASS_ERASE" get_status 
DFU-Util exited with error code 74!
Flashing failed.


Any suggestions on how to get it working?

Please make sure that your power supply is not under power and trigger self protection when pinecil try to heat up.

For DFU error, please visit this thread: https://github.com/Ralim/IronOS/issues/820[url=https://github.com/Ralim/IronOS/issues/820][/url]
  Reply
#3
(01-27-2021, 04:19 PM)tllim Wrote:
(01-26-2021, 08:30 PM)foobarney Wrote: My Pinecil arrived this morning and it doesn't seem to be working.

When I power it up, the main screen pops up and I can go through the menus, but as soon as I try to turn the heat on, it blinks off and then restarts.

I tried updating the firmware, but got an error message when I tried to flash it:


Invalid DFU suffix signature A valid DFU suffix will be required in a future dfu-util release!!! Error during special command "MASS_ERASE" get_status 
DFU-Util exited with error code 74!
Flashing failed.


Any suggestions on how to get it working?

Please make sure that your power supply is not under power and trigger self protection when pinecil try to heat up.

For DFU error, please visit this thread: https://github.com/Ralim/IronOS/issues/820[url=https://github.com/Ralim/IronOS/issues/820][/url]
  Reply
#4
I checked with multiple power supplies--when I plug in a 12V supply the little numbers on the right of the display ramp up to 12; when I plug in a 60W USB-C PD supply, they ramp up to 20. So I don't think the Pinecil thinks it's undervolted.

And I don't think the power connector is loose, because it works fine in the menus; it only happens when I go to solder.

I tried pulling out and reseating the tip just to confirm that it wasn't the problem--no change.
  Reply
#5
(01-27-2021, 10:17 PM)foobarney Wrote: I checked with multiple power supplies--when I plug in a 12V supply the little numbers on the right of the display ramp up to 12; when I plug in a 60W USB-C PD supply, they ramp up to 20. So I don't think the Pinecil thinks it's undervolted.

And I don't think the power connector is loose, because it works fine in the menus; it only happens when I go to solder.

I tried pulling out and reseating the tip just to confirm that it wasn't the problem--no change.

If the unit is tripping off as soon as you attempt to heat the tip this is most likely a poor power supply or a bad tip.
  Reply
#6
[quote pid='88457' dateline='1611829297']


If the unit is tripping off as soon as you attempt to heat the tip this is most likely a poor power supply or a bad tip.
[/quote]

Ive tried multiple power supplies (both barrels and usb-c), so that seems an unlikely culprit.

Unfortunately, I don't have another tip to test with.

Would there be a log somewhere I could dump?

If it's the tip, how do I go about replacing it? I haven't seen any RMA/support info on Pine's website.


Thank you!
  Reply
#7
I tried the USB-PD with another cable and it seems to be working.

Not sure why the barrel connector did the same thing, though. I'm looking for another high-enough-power adapter with a 5025 connector to really test it.

Thanks, all...
  Reply
#8
Just a follow-up...working nicely thru USB-C. I'm not sure whether the problem w the barrel connector is the iron or the power supply...I'll need to get a decent 5025 adapter to try.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
Question Can Pinecil Read USB-C Cable E-Marker Chips? Garywoo 1 256 05-13-2024, 01:31 PM
Last Post: tllim
  Connecting a power supply to the Pinecil jon_bondy 1 520 02-29-2024, 07:37 PM
Last Post: Okedokey
  Crippling noise from inside pinecil during a few minutes high power soldering. dreieck 2 951 01-31-2024, 12:34 AM
Last Post: suga7
Question Pinecil Tempaerature Reading jumps to Y400°C when active but stays normal when cold H3wastooshort 0 458 12-24-2023, 05:45 PM
Last Post: H3wastooshort
  Asus laptop power supply can also power Pinecil biketool 9 8,638 11-17-2023, 12:57 PM
Last Post: killingmesmalls
  Mass problem Pinecil V2 Harrysteed 0 773 11-02-2023, 09:11 AM
Last Post: Harrysteed
Question Pinecil v2 power cycles at higher voltages? clemon79 2 1,434 10-09-2023, 10:10 PM
Last Post: clemon79
  PD resets during heat up tip [Pinecil V2] Neitron4ik 2 1,695 10-09-2023, 01:22 AM
Last Post: Neitron4ik
  [Hackaday Article] All About USB-C: Pinecil Soldering Iron vajak 1 1,588 02-02-2023, 11:45 AM
Last Post: VaZso
  Brand new Pinecil v2 won't boot on PD jhutch 1 2,390 12-14-2022, 01:03 AM
Last Post: River

Forum Jump:


Users browsing this thread: 1 Guest(s)