RockPro64 has bad Memory (Software sogfaults and kernel panics)
#1
Hello,

I just purchased a rockpro64, and I am having some very odd issues with it:

- I attempted to install the Debian official image twice, and I caused it to kernel panic with the official image.

- I also attempted to use Armbian, and when I tried to update it, I got a segmentation fault on dpkg.

I have looked around and I have not seen anyone complain about these issues.

EDIT:

This is caused bybad memory. I ran as root on Armbian minimal install:

Code:
#memtester 3400M 1

It is on Rockpro64 V2.1 2018-07-02, 4GB variant, date code 4719

Pine64 has get to RMA my device despite me using support and contacting sales over a week ago.

UPDATE 16 Oct:

I hate to say, I have not heard anything useful since I opened up this issue on 4 Oct. I filed a Paypal dispute in the hopes that will get them to respond. This is frankly beyond disappointing. I have been very happy with the Pinephone, and that was the reason I have the RockPro a chance over the RaspPi. This whole ordeal sours my interest in buying anything from Pine again.
  Reply
#2
I didn't run in to that problem when I installed Debian on a RockPro64.

Could it be related to the firmware accessing memory behind the kernel's back?

https://forum.pine64.org/showthread.php?...9#pid55839

https://wiki.pine64.org/index.php/ROCKPr...sed_memory

https://github.com/ayufan-rock64/linux-b...-578410380

Could it be a problem in the Debian kernel version you're using?
  Reply
#3
(10-04-2020, 03:33 PM)foresto Wrote: I didn't run in to that problem when I installed Debian on a RockPro64.

Could it be related to the firmware accessing memory behind the kernel's back?

https://forum.pine64.org/showthread.php?...9#pid55839

https://wiki.pine64.org/index.php/ROCKPr...sed_memory

https://github.com/ayufan-rock64/linux-b...-578410380

Could it be a problem in the Debian kernel version you're using?

I was using the offical debian image and I got my Rockpro64 a week ago....it had 5.8 being installed on it.
  Reply
#4
Well I figured out why. I ran a memory tester on my chip and there are hard errors on my DDR. I will need to exchange it.
  Reply
#5
(10-07-2020, 09:52 AM)kop316 Wrote: Well I figured out why. I ran a memory tester on my chip and there are hard errors on my DDR. I will need to exchange it.

Hi kop316,

Could you please detail how you tested the memory of your RockPro?

I am also seeing seg faults that always occur at some point regardless of the used image or SD card.
  Reply
#6
I tried to run the memtester on my board with fresh image and sure enough there seem to be memory issues in the part of memory it tested.
Resuts: https://pastebin.pl/view/00e8b2d7

Hardware I am using:
Rockpro64 V2.1 2018-07-02, 4GB variant, date code 52 19
running of SD card, tall heatsink installed, powered by Pine 5A power supply

For OS image I used ayufan's buster-minimal-rockpro64-0.10.12-1184-arm64 image.
I believe this one uses recent enough u-boot that does not use the binary blob in RAM.

Command used:
Code:
sudo memtester 3G 1

I tried the same on other SBC's I have with no errors so there is definitely something going on with this RockPRO board.
  Reply
#7
(10-12-2020, 07:38 AM)richese Wrote: I tried to run the memtester on my board with fresh image and sure enough there seem to be memory issues in the part of memory it tested.
Resuts: https://pastebin.pl/view/00e8b2d7

Hardware I am using:
Rockpro64 V2.1 2018-07-02, 4GB variant, date code 52 19
running of SD card, tall heatsink installed, powered by Pine 5A power supply

For OS image I used ayufan's buster-minimal-rockpro64-0.10.12-1184-arm64 image.
I believe this one uses recent enough u-boot that does not use the binary blob in RAM.

Command used:
Code:
sudo memtester 3G 1

I tried the same on other SBC's I have with no errors so there is definitely something going on with this RockPRO board.


Sorry I just saw this. I did the same thing you did. I got a minimal Armbian image and run as root:

Code:
memtester 3400M 1


And I got DDR Errors. My RockPro64
Rockpro64 V2.1 2018-07-02, 4GB variant, date code 4719
  Reply
#8
I'm also experiencing the same issue. ROCKPro64_v2.1, 2018-07-02, 4GB variant, date code 5219, powered by a known good 12V 5A power supply.

Running Armbian Focal or Buster, any time I go to use apt update I get a segmentation fault. I've been unable to run memtester as of yet as I need to find an image with it preinstalled as I can't download anything using apt.

I've got 2 other RockPro64s of the same revision, one with date code 4719 and one with date code 5119. I'll be testing those right now and reporting back.
  Reply
#9
I cracked open the two other boards and ran memtest on them with no errors reported. I then transplanted that eMMC module onto the date code 5219 board and ran the test again. I was presented with a slew of errors. It's evident that, that ROCKPro64 (v2.1, 2018-07-02 5219) is also defective and will warrant an RMA.
  Reply
#10
(11-19-2020, 12:36 AM)wildering Wrote: I cracked open the two other boards and ran memtest on them with no errors reported. I then transplanted that eMMC module onto the date code 5219 board and ran the test again. I was presented with a slew of errors. It's evident that, that ROCKPro64 (v2.1, 2018-07-02 5219) is also defective and will warrant an RMA.

I ran memtest with Debian an it seems ok. (v2.1, 2018-07-02). What is noticeable is the high temperature reached (70°C) in spite of a heatsink. Then I put it over a fan and it dropped below 50°C after 9 min

(11-19-2020, 12:27 PM)LMM Wrote:
(11-19-2020, 12:36 AM)wildering Wrote: I cracked open the two other boards and ran memtest on them with no errors reported. I then transplanted that eMMC module onto the date code 5219 board and ran the test again. I was presented with a slew of errors. It's evident that, that ROCKPro64 (v2.1, 2018-07-02 5219) is also defective and will warrant an RMA.

I ran memtest with Debian an it seems ok. (v2.1, 2018-07-02). What is noticeable is the high temperature reached (70°C) in spite of a heatsink. Then I put it over a fan and it dropped below 50°C after 9 min

I don't know if it is a good practice (and a good idea) but I cut the conductive pad in order to be able to double the layer on the DDR chip to make the contact with the heatsink. Otherwise it probably does not
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  GPIO on the RockPro64 - all pins high? colinmarc 2 202 11-18-2022, 10:20 AM
Last Post: colinmarc
  ROCKPro64 DOA ajtravis 8 3,079 11-08-2022, 03:40 AM
Last Post: ajtravis
  RockPro64 not booting up mvicha@gmail.com 0 315 09-19-2022, 07:35 AM
Last Post: mvicha@gmail.com
  ROCKPro64 with 16 ports SATA controller ZeblodS 18 17,808 09-17-2022, 09:20 PM
Last Post: caroljames972022
  GPIO Expander HAT for ROCKPro64 and Quartz64 CounterPillow 7 2,447 07-18-2022, 10:05 PM
Last Post: zer0sig
  RockPro64 premium aluminium casing justwantin 2 772 05-27-2022, 06:51 PM
Last Post: justwantin
  charging 3 rockpro64 from single source rpt312 1 625 05-16-2022, 02:34 AM
Last Post: dukla2000
  help or suggestions removing RockPro64 Playbox please? jahway603 2 970 03-22-2022, 12:17 PM
Last Post: jahway603
  rockpro64 13 megapixel camera Aycaramba 9 9,334 01-24-2022, 02:47 PM
Last Post: solbs
  RockPro64 doesn't boot when PCIe to M.2 adapter is installed Cerberus 3 1,900 11-27-2021, 11:38 PM
Last Post: Cerberus

Forum Jump:


Users browsing this thread: 1 Guest(s)