Recovery without Tow Boot
#1
Brick 
I’ve been at this for days now and I think it’s safe to say that despite the number of detailed walkthroughs and guides, I’m still unable to get this thing figured out.

Some context: 
PinePhone Pro w/ RE button, purchased Dec 2023. It was loaded with TowBoot, rk2aw and SailfishOS.

What have I done: 
So, I believe my attempt to flash a Kali image to the eMMC failed. No big deal, I’ll wipe the eMMC and start again. All I need is an image on my SD card, right?

Regardless of what I do now, my phone only boots to a blank screen with a steady green LED. No SD card image will boot. It doesn’t matter if I short press or long press the power or RE button. I’ve tried USB-C plugin combos and 6-8 different distros (Kali, UT, Manjaro, Arch, Mobian, Arch, Rhino)

The only time I’ve managed to break out of this hopeless loop is when I load the factory test builds for either hardware or battery testing. When I use the hardware test build it boots to a barebones Android distro, however I can’t see eMMC storage. When I hold the power up button (while booting the factory test build) I can boot to the bootloader that mentions side loading from ADB etc, however my PPP isn’t recognised by either of my machines when in this state.

With the factory build loaded my machine recognises the device as a tablet but I can’t access or view the eMMC. My device is only visible in lsusb and never lsblk. I have also tried using rk2aw to see if I could figure a workaround, however this only helps me to boot into Masked ROM mode and I have no idea how to recover with such limited access.

What am I missing? I’ve read through so many of these posts thinking the answer is right here somewhere. If someone could help me solve this I would love to help document this whole fix because it shouldn’t be this difficult. 

Thank you in advance.
  Reply
#2
Have you tried re-installing towboot?

https://tow-boot.org/devices/pine64-pinephonePro.html

https://github.com/Tow-Boot/Tow-Boot/releases
  Reply
#3
i don't have a pro but what about jumpdrive ?

ezik
  Reply
#4
(01-06-2024, 06:04 PM)apink Wrote: Have you tried re-installing towboot?

https://tow-boot.org/devices/pine64-pinephonePro.html

https://github.com/Tow-Boot/Tow-Boot/releases

I have tried, however once I get Towboot on an SD card, I can't get my PPP to boot. No matter what I do I get a black screen and a steady green LED until I power it off. I can't seem to get my device to boot to a stage where I can then install Towboot, or any other software for that matter.
  Reply
#5
(01-06-2024, 10:54 PM)shulamy Wrote: i don't have a pro but what about jumpdrive ?

ezik

I've heard jumpdrive isn't available for the Pro, that's why Towboot is pushed as an alternative.
  Reply
#6
(01-07-2024, 01:07 AM)b34ux Wrote:
(01-06-2024, 06:04 PM)apink Wrote: Have you tried re-installing towboot?

https://tow-boot.org/devices/pine64-pinephonePro.html

https://github.com/Tow-Boot/Tow-Boot/releases

I have tried, however once I get Towboot on an SD card, I can't get my PPP to boot. No matter what I do I get a black screen and a steady green LED until I power it off. I can't seem to get my device to boot to a stage where I can then install Towboot, or any other software for that matter.

A week ago I tried to reinstall Tow-Boot using an SD card and also couldn't boot it. Then I realized, I made a mistake and I flashed the whole .tar.xz to the SD. There was an spi.installer.img file in the archive which should be used to flash to SD.

Than I had troubles to write to the SPI (a red screen with some error messages showed up). It helped to purge everything from EMMC (plugged via USB to Notebook and zeroed using dd command). After I was able to write new Tow-Boot.
  Reply
#7
Perhaps someone in a chat room can help.  I have found more active feedback there:

https://matrix.to/#/#pinephone:matrix.org
  Reply
#8
(01-07-2024, 03:03 PM)apink Wrote: Perhaps someone in a chat room can help.  I have found more active feedback there:

https://matrix.to/#/#pinephone:matrix.org

Thanks for this, my friend. I’ll head over shortly to see if I can get some guidance in real time. I appreciate you.

(01-07-2024, 11:42 AM)jezek Wrote:
(01-07-2024, 01:07 AM)b34ux Wrote:
(01-06-2024, 06:04 PM)apink Wrote: Have you tried re-installing towboot?

https://tow-boot.org/devices/pine64-pinephonePro.html

https://github.com/Tow-Boot/Tow-Boot/releases

I have tried, however once I get Towboot on an SD card, I can't get my PPP to boot. No matter what I do I get a black screen and a steady green LED until I power it off. I can't seem to get my device to boot to a stage where I can then install Towboot, or any other software for that matter.

A week ago I tried to reinstall Tow-Boot using an SD card and also couldn't boot it. Then I realized, I made a mistake and I flashed the whole .tar.xz to the SD. There was an spi.installer.img file in the archive which should be used to flash to SD.

Than I had troubles to write to the SPI (a red screen with some error messages showed up). It helped to purge everything from EMMC (plugged via USB to Notebook and zeroed using dd command). After I was able to write new Tow-Boot.

Thankfully I avoided the misstep of flashing the wrong file to my SD card. I tried it on both a Mac and Linux machine, using both Balena Etcher and the dd method.

In regard to the eMMC, I (believe) I have already zeroed it as you’ve mentioned. Following this change I was expecting my PPP to boot from the SD card exclusively. Instead I seem to have put my phone into a state where I can no longer view or access my eMMC.

I’ve seen a few posts where it seems that users have been where I’ve been. I just can’t figure out what the next step is to join them in PinePhone Playland.
  Reply
#9
b34ux, I thought you might already have been there today. megi and giorez were discussing things that sounded like your issues.
  Reply
#10
(01-05-2024, 12:42 PM)b34ux Wrote: I’ve been at this for days now and I think it’s safe to say that despite the number of detailed walkthroughs and guides, I’m still unable to get this thing figured out.

Some context: 
PinePhone Pro w/ RE button, purchased Dec 2023. It was loaded with TowBoot, rk2aw and SailfishOS.

What have I done: 
So, I believe my attempt to flash a Kali image to the eMMC failed. No big deal, I’ll wipe the eMMC and start again. All I need is an image on my SD card, right?

Regardless of what I do now, my phone only boots to a blank screen with a steady green LED. No SD card image will boot. It doesn’t matter if I short press or long press the power or RE button. I’ve tried USB-C plugin combos and 6-8 different distros (Kali, UT, Manjaro, Arch, Mobian, Arch, Rhino)

The only time I’ve managed to break out of this hopeless loop is when I load the factory test builds for either hardware or battery testing. When I use the hardware test build it boots to a barebones Android distro, however I can’t see eMMC storage. When I hold the power up button (while booting the factory test build) I can boot to the bootloader that mentions side loading from ADB etc, however my PPP isn’t recognised by either of my machines when in this state.

With the factory build loaded my machine recognises the device as a tablet but I can’t access or view the eMMC. My device is only visible in lsusb and never lsblk. I have also tried using rk2aw to see if I could figure a workaround, however this only helps me to boot into Masked ROM mode and I have no idea how to recover with such limited access.

What am I missing? I’ve read through so many of these posts thinking the answer is right here somewhere. If someone could help me solve this I would love to help document this whole fix because it shouldn’t be this difficult. 

Thank you in advance.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Tow-Boot, a new U-Boot option for Pinephone Pro and other devices Ulfnic 60 46,857 02-13-2024, 02:54 PM
Last Post: fxc
  What to do if your PinePhone Pro does not boot fxc 19 20,222 09-10-2023, 03:19 AM
Last Post: fxc
  Pine Phone won't boot into recovery mode ninjapig26@gmail.com 3 1,915 02-18-2023, 06:14 PM
Last Post: fxc
  tow-boot installation problem techariah 2 1,609 02-16-2023, 02:50 PM
Last Post: techariah
  create tow boot .img fox95 6 3,230 10-21-2022, 11:40 AM
Last Post: fox95
Question Recovery/Live image? Greendrake 0 887 07-18-2022, 02:09 AM
Last Post: Greendrake
  No display on early boot after Manjaro update robocone 0 883 07-07-2022, 05:47 AM
Last Post: robocone
  Latest Manjaro-Phosh and Arch-Phosh won't boot grinzie 6 4,038 07-01-2022, 02:01 PM
Last Post: Chief
  Manjaro update, no boot, just noise. wilmarcdw 2 1,754 05-09-2022, 07:24 AM
Last Post: wilmarcdw
  Can't boot from a microSD card WhyNotHugo 5 3,291 04-10-2022, 09:15 AM
Last Post: WhyNotHugo

Forum Jump:


Users browsing this thread: 1 Guest(s)