Keyboard case stopped working on pacman update
Hey everyone,
After my keyboard case happily working for the last few weeks/month or so, I ran a pacman -Syyu a few days ago (Friday I think) and on reboot the keyboard stopped responding. Did I miss something in the install messages? Am I just waiting for some kernel fix to make its way down to me?

The one odd-ball thing about my setup is I disabled sddm and have been using Emptty to boot into Awesome (pinephone = tiny linux desktop).

Only other clue is the power button on the keyboard case seems to still kick the phone on, so it's not like there's no contact between the phone and the keyboard. (I did try popping the phone out and back in just in case, but that pin-connecting issue isn't one I've had.)

Happy to wait for an update to come down, but I don't want to sit here with no working keyboard if I just forgot to edit some settings or something.

i didn't notice anything special. do you have "linux-pinephone" package and not other kernels?
reinstallation of some packages might work.
(04-18-2022, 08:28 PM)zetabeta Wrote: i didn't notice anything special. do you have "linux-pinephone" package and not other kernels?
reinstallation of some packages might work.

Damn, that's what I didn't want to hear. But thanks for the response! 

Yeah, I haven't messed around with any other kernels. I'll try re-installing some packages, but it sounds like it's time to flash a clean OS on an SD and boot that to see what happens.
Yeah, kb case works fine under a clean OS boot on the SD card, so something just went screwy with my software setup. Oh well. I got a good long run out of this one without having to setup from scratch, a few months at least! Which is much longer than many of my other OS setups on the pinephone.
Argh! It happened again!

I just got the pinephone re-setup back the way I wanted it last week. It was working fine, then a big update from pacman -Syyu, and the keyboard case stopped working again! Typing -- battery seems to be working fine, the phone boots if I give the wake button a single press.

Anyone have any ideas on this?

Or even a suggesting of what packaged might be the culprit here?
I reinstalled linux-pinephone and rtl8723bt-firmware-megi

Since nobody else seems to be running into this, and the big difference in my setup from most people is I've been disabling sddm and booting to console, maybe it's related to that? But... keyboard not responding in console? How could that be? Plus re-enabling sddm doesn't get the keyboard working.

Oh, here's another (maybe better) direction to consider, because I want to boot to console with the keyboard, I've been editing /boot/boot.txt with fbcon=rotate:1 to rotate the console. Maybe uboot is doing something on upgrade with the non-default boot.txt that is breaking the keyboard?

Thanks for any clues!
Solved (mostly), instructions here:

Possibly Related Threads…
Thread Author Replies Views Last Post
  manjaro-pinephone / plasma-mobile-dev: Update broken Uturn 32 14,534 07-28-2022, 12:40 PM
Last Post: johaennessen
Sad Latest Manjaro breaks Keyboard Case (Again)? hollerpots 4 501 06-17-2022, 07:48 AM
Last Post: hollerpots
  How to disable automatic update checks bdicewk 4 379 06-12-2022, 08:10 AM
Last Post: bdicewk
  Locked out after update bnbcwllc 2 271 06-08-2022, 04:46 AM
Last Post: bnbcwllc
  No keyboard in Signal Desktop Kimberley van Buyten 0 176 06-04-2022, 01:57 AM
Last Post: Kimberley van Buyten
  Vivaldi Browser doesn't start keyboard for text entry tckosvic 1 842 05-24-2022, 11:32 PM
Last Post: grump_fiddle_reinstall
  How to convert your pinephone to a palmtop now that you have the clamshell keyboard rotwang 3 976 05-09-2022, 08:29 AM
Last Post: ragreenburg
  Pinephone stuck on 'something went wrong' after update gofishus 1 566 03-06-2022, 05:48 PM
Last Post: fxc
  Calls & SMS stopped working Schugy 3 983 12-28-2021, 05:00 AM
Last Post: Schugy
  Lockup during update, force shut down and try again? tgz 5 3,222 12-22-2021, 03:11 PM
Last Post: tk1107

Forum Jump:

Users browsing this thread: 1 Guest(s)