Debian emmc installer
I'm trying to install Debian on the emmc. I've tried building an image from the firmware and partition images here and here

In both cases no network interfaces are detected at all and it appears wifi drivers are missing, meaning I can't complete the install.

Is it expected that those images don't contain the driver? (I thought the netboot spin included non-free?). What is the best way of getting that driver? Is there another image I should be using?
take a look on, maybe this gives an idea what needs to be done in your case
(08-15-2022, 10:09 AM)jsch Wrote: take a look on, maybe this gives an idea what needs to be done in your case

Thanks. I was hoping to avoid needing to buy a USB eth adapter but looks like it's the easiest (only?) way for now.
You could install the system without the wifi driver, use a usb-stick to copy the necessary packages over once debian is installed on the pinebook. My pinephone came with the dock, hence I chose this approach.
Generally speaking, Armbian is going to be far ahead of upstream (vanilla Debian) on any sort of SBC type device (including PBP) because Arm/SBC world is so different from x86.

Having said that, there is currently an issue with installing Armbian to eMMC. Not sure what's up with that, pretty sure it used to work. I hope to have my new PBP in my hands in a few more days, then I can maybe try and see what's happening. In the meantime, it should run well off SD card.

What is Free Software and why is it so important for society?

Protocols, not Platforms

For the most Linux-y experience on your Linux phone, try SXMO!

I am (nominally) the Armbian Maintainer for PineBook Pro (although severely lacking in time these days).
Right tried installing with a USB ethernet adapter (worked on the roght USB port only not the left), seema like everything installs fine but at the very end it fails to reboot and doesn't boot thereafter. I'm trying the guided partitioning with encrypted LVM, could that be an issue or is that expected to work fine?
Actually looks like it might be unrelated to luks after all, the same thing seems to happen with an unencrypted install

Possibly Related Threads…
Thread Author Replies Views Last Post
  Official Debian support moonwalkers 63 54,775 05-16-2024, 11:00 PM
Last Post: rempfer
  Debian on Pinebook Pro u974615 7 1,760 03-31-2024, 10:11 AM
Last Post: u974615
  Help installing Manjaro on eMMC of Pinebook Pro pine4546464 4 2,489 12-13-2023, 07:22 PM
Last Post: trillobite
  Manjaro 20.04 not loading from SD (with Manjaro on eMMC) zaius 1 569 12-07-2023, 03:11 PM
Last Post: wdt
  install debian on pbp jsch 7 4,395 11-22-2023, 04:22 PM
Last Post: TRS-80
  How to mainline kernel on daniel thompson's debian installer? hellojack 14 8,093 09-07-2023, 09:38 PM
Last Post: Der Geist der Maschine
  [Manjaro] u-boot won't boot from eMMC with (unbootable) SD card present zackw 1 2,117 08-21-2023, 09:08 PM
Last Post: vanessadonald
  Unable to install Debian Bullseye because of missing wifi firmware Pino64 7 4,439 07-15-2023, 02:58 PM
Last Post: u974615
  Blank screen after Armbian 20.04 install to emmc? psychoacoustic 3 3,733 04-01-2023, 03:22 PM
Last Post: TRS-80
  Fix for Armbian not booting on PBP from eMMC agreenbhm 7 4,245 04-01-2023, 02:58 PM
Last Post: TRS-80

Forum Jump:

Users browsing this thread: 1 Guest(s)