New Pinebook Pro - no sound
#1
Sad 
Hello all,

Just received my PBP yesterday. I typically use Ubuntu, so the desktop will take a little getting used to. However, I created a new sudo user acct, which does not have sound playback at all. The default "rock" user does have sound playback.

I searched the forums and found a post about the alsamixer / selecting the correct sound device, but this did not work. How do I get sound playback for accounts other than the default "rock" user?

Thanks!
  Reply
#2
(01-15-2020, 11:05 AM)vve1505 Wrote: Hello all,

Just received my PBP yesterday. I typically use Ubuntu, so the desktop will take a little getting used to. However, I created a new sudo user acct, which does not have sound playback at all. The default "rock" user does have sound playback.


Welcome to Poettering's world

https://www.freedesktop.org/wiki/Softwar...ystemWide/
  Reply
#3
(01-15-2020, 11:38 AM)Der Geist der Maschine Wrote:
(01-15-2020, 11:05 AM)vve1505 Wrote: Hello all,

Just received my PBP yesterday. I typically use Ubuntu, so the desktop will take a little getting used to. However, I created a new sudo user acct, which does not have sound playback at all. The default "rock" user does have sound playback.


Welcome to Poettering's world

https://www.freedesktop.org/wiki/Softwar...ystemWide/
 
      Not sure I follow those instructions,

     So ?  is this what we put into terminal  ?
Code:
sudo systemctl --global disable pulseaudio.service pulseaudio.socket
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#4
You might find it easier to simply rename the rock user.

https://wiki.pine64.org/index.php/Pinebo...ame.2C_etc...
  Reply
#5
(01-16-2020, 05:42 AM)ioo Wrote: You might find it easier to simply rename the rock user.

https://wiki.pine64.org/index.php/Pinebo...ame.2C_etc...
 
    Actually,  should I do both ?

   one to correct the sound,    the second for the user account ?
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#6
(01-16-2020, 06:37 AM)bcnaz Wrote:
(01-16-2020, 05:42 AM)ioo Wrote: You might find it easier to simply rename the rock user.

https://wiki.pine64.org/index.php/Pinebo...ame.2C_etc...
 
    Actually,  should I do both ?

   one to correct the sound,    the second for the user account ?

My wild guess is that the newly created user is missing some groups privileges as the user rock.

Here is what I found from my pbp:

Code:
rock@Debian-Desktop:~$ id rock
uid=1000(rock) gid=1000(rock) groups=1000(rock),4(adm),27(sudo),29(audio),44(video),46(plugdev),106(input),111(ssh)

rock@Debian-Desktop:~$ cat /etc/group | grep rock
adm:x:4:rock
sudo:x:27:rock
audio:x:29:rock,pulse
video:x:44:rock
plugdev:x:46:rock
input:x:106:rock
ssh:x:111:rock
rock:x:1000:

So in order to have the same user profile as the user rock, one has to add those groups as secondary group to the newly created user.

For example, if I created a new user as newuser, I have to do the following:

Code:
$ sudo usermod -a -G adm, sudo, audio, video, plugdev, input, ssh newuser


or add them one by one

Code:
$ sudo groupmod -a -G adm newuser
$ sudo groupmod -a -G sudo newuser
$ sudo groupmod -a -G audio newuser
$ sudo groupmod -a -G video newuser
$ sudo groupmod -a -G plugdev newuser
$ sudo groupmod -a -G input newuser
$ sudo groupmod -a -G ssh newuser

or some people would like to use the adduser command instead

Code:
$ sudo adduser newuser adm
$ sudo adduser newuser sudo
$ sudo adduser newuser audio
$ sudo adduser newuser video
$ sudo adduser newuser plugdev
$ sudo adduser newuser input
$ sudo adduser newuser ssh

Chip
  Reply
#7
I was having the same issue, despite being in The sound group.

I tried bogamul's suggestion here: https://askubuntu.com/questions/1086658/...u-18-04lts

And it seemed to solve my audio problems.
  Reply
#8
(01-16-2020, 04:18 PM)chip ling Wrote:
(01-16-2020, 06:37 AM)bcnaz Wrote:
(01-16-2020, 05:42 AM)ioo Wrote: You might find it easier to simply rename the rock user.

https://wiki.pine64.org/index.php/Pinebo...ame.2C_etc...
 
    Actually,  should I do both ?

   one to correct the sound,    the second for the user account ?

My wild guess is that the newly created user is missing some groups privileges as the user rock.

Here is what I found from my pbp:

Code:
rock@Debian-Desktop:~$ id rock
uid=1000(rock) gid=1000(rock) groups=1000(rock),4(adm),27(sudo),29(audio),44(video),46(plugdev),106(input),111(ssh)

rock@Debian-Desktop:~$ cat /etc/group | grep rock
adm:x:4:rock
sudo:x:27:rock
audio:x:29:rock,pulse
video:x:44:rock
plugdev:x:46:rock
input:x:106:rock
ssh:x:111:rock
rock:x:1000:

So in order to have the same user profile as the user rock, one has to add those groups as secondary group to the newly created user.

For example, if I created a new user as newuser, I have to do the following:

Code:
$ sudo usermod -a -G adm, sudo, audio, video, plugdev, input, ssh newuser


or add them one by one

Code:
$ sudo groupmod -a -G adm newuser
$ sudo groupmod -a -G sudo newuser
$ sudo groupmod -a -G audio newuser
$ sudo groupmod -a -G video newuser
$ sudo groupmod -a -G plugdev newuser
$ sudo groupmod -a -G input newuser
$ sudo groupmod -a -G ssh newuser

or some people would like to use the adduser command instead

Code:
$ sudo adduser newuser adm
$ sudo adduser newuser sudo
$ sudo adduser newuser audio
$ sudo adduser newuser video
$ sudo adduser newuser plugdev
$ sudo adduser newuser input
$ sudo adduser newuser ssh

Chip

So my question is, why can't the system just have sound for all users. I'm going to read the SystemWide link now, but this whole thing seems kind of ridiculous to me.
  Reply
#9
 
  I am not sure about following all these different paths...

    I only see a Few posts where the users are running the OEM Debian/Mate and have the "NO SOUND"  problem.

   If I had changed the OS or made some major changes,  then maybe Making major changes to the OS could make sense.

    BUT,    I feel like I have a brand new car,     and I am being told   I MUST rebuild the engine. ?

   ** ***   If every new Pinebook Pro had the "NO SOUND"  problem,  maybe that could be true.     ***

     There must be a software switch or such that needs to be set properly or something like that.

     > Going to alsamixer through terminal and changing that setting from default to   ' es 8316-spk-sound '

              Seemed to be a partial fix,  I can hear most videos and some ads on youtube after that change,  but the controls

                 are still grayed out in preferences, and the 'Test Sound'  option does not work.

                                           ?   ?

      
      LINUX = CHOICES
         **BCnAZ**
               Idea
   Donate to $upport
your favorite OS Team
  Reply
#10
This is a different case.

The machine did arrive with sound and it is working under the user rock.

The thread poster tried to create a new user and the newly created user does not have sound.

The original user rock did have sound.
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Warning to anyone considering a Pinebook kickdog20 14 786 Yesterday, 05:02 PM
Last Post: bcnaz
  Pinebook Pro 'xtreme' bcnaz 49 5,896 08-11-2020, 09:38 PM
Last Post: Arwen
  Games compilation howto on the Pinebook-pro (Manjaro Linux and Debian native) astr0baby 170 33,553 08-10-2020, 08:55 PM
Last Post: Upokupo
Rainbow What did you name your Pinebook Pro? diodelass 42 3,418 08-06-2020, 03:39 PM
Last Post: PaulQ
  killed my pinebook pro with my pinephone jvlist 18 1,241 08-06-2020, 07:46 AM
Last Post: tophneal
  My Pinebook Pro after a month of use. Nobot 18 1,400 08-04-2020, 04:56 PM
Last Post: dieselnutjob
Exclamation Pinebook Pro structural integerity failing TDC_PBP 41 4,707 07-30-2020, 12:01 PM
Last Post: hdk
  Install TorBrowser on Pinebook pro 2020 edition BananaPekan 0 177 07-30-2020, 04:52 AM
Last Post: BananaPekan
Question Possible to order Pinebook Pro with 128Gb eMMC? KC9UDX 8 488 07-28-2020, 06:52 PM
Last Post: LittleWalter
  Pinebook Pro available in EU Wizzard 1 256 07-26-2020, 02:13 AM
Last Post: Wizzard

Forum Jump:


Users browsing this thread: 1 Guest(s)