Bricked PBP after writing image to eMMC?
#1
Hi all,

I got my PBP yesterday and I tried flashing it with a few images to see which one works best for me.

I tried the updated Debian one from mrfixit, but that ended up having broken (?) Mali drivers.
I decided to give ayufan's Ubuntu bionic images a shot next. However, after flashing the LXDE image, it seems like I can no longer boot.

I was running Debian from SD and flashed the Ubuntu from that one, but now I am greeted with an orange led & unlit screen when booting without an SD card.

When I put the SD card back in, the power LED turns green after a while, and flickers for a time indicating disk activity, but the screen also stays black.

Anyone else had this problem? What can I do to resolve this?

Edit: just tried logging in after booting from SD, and it seems like that's working, apart from not having any display output or backlight. I'm going to try the eMMC image next, see what happens.
  Reply
#2
Have you solved it ?

The fact that you can actually boot from SD card seems to indicate that you have not bricked the PinebookPro, but maybe just corrupted the emmc installation but without completely killing the uboot. The uboot is necessary to change the boot sequence from Sd card first, then emmc.

As you can boot from sd card as you say my first thought would be to try a different SD card or image?

If they all fail, in worst case you can switch the emmc of on the board. Check the tech spec in the wiki for the location of the switch. In that case the PinebookPro should boot purely from your SD card, and if the cord is ok have no problems.
  Reply
#3
Side question, is it possible to completely brick a Pinebook Pro? As I think it's not possible to brick it by just a SD card.
Find me in the forest, when I'm at my lowest. I don't really think you should continue..

HOLD YOUR BREATH.
  Reply
#4
(12-05-2019, 12:42 AM)Danct12 Wrote: Side question, is it possible to completely brick a Pinebook Pro? As I think it's not possible to brick it by just a SD card.

Define completely Tongue 

There are ways to corrupt the eMMC such that you cannot resolve the problem without removing the bottom cover of the machine. However recovery from eMMC corruption is tool free (except for the screwdriver)... it just requires a carefully timed flick of a switch.

Additionally there are ways to corrupt the on-board SPI in a manner that requires a bit of skill to recover. That is why non-expert uses are currently advised not to experiment with the SPI (it is very unlikely that you accidentally write a bad image into SPI). In principle even a bad SPI programming can be recovered with the aforementioned screwdriver, a paper clip and very steady hands but I've not seen anyone share a success report (and when/if I corrupt my SPI I plan to recover it with tools rather than a paper clip since I *don't* have steady hands).

PS Soft bricking through bad images in either eMMC or SPI are pretty obvious... the power LED doesn't come on.
PineTime: wasp-os and MicroPython, Pinebook Pro:  Debian Bullseye
  Reply
#5
I have similar problem burning manjaro arm on emmc and was caused by a bad sd card image.

Booting from a new sd card runs properly.
  Reply
#6
I have also shot myself in the foot with an attempt to write the Manjaro PinebookPro Preview 4 image to emmc.

To be honest I could have been easily avoided, I did not get it to install, but on the other side I should just have stopped there as SD boot was still fine. However, adventoritis got the better of me and after my failed attempt to istall to the emmc the emmc did not boot anymore, with actually a green light and the SD card did not boot at all with an angry green and red flashing power ID.

Removing the bottom cover of the PinebookPro and switching the emmc off (see wiki) helped and now i can boot at least from SD card again.

As far as I know I can reactivate the emmc booting from SD card and then turning the switch back on in the decisive moment between uboot load and kernel start. there is a 2 sec. pause there. If the timing is right the SD card is supposed to continue to boot and the kernel can find the emmc and it can be flashed with something working.

After my previous, slightly discouraging experience I will postpone that exercise until I know what I actually want to have on the emmc and also how to get it there safely.

For now the SD card works rather fine.

I am mostly writing all this to give people with a similar fate a bit of courage and avoid the heart attack I almost felt when I blundered it up myself...

Don't Panic
  Reply
#7
So, now have un-bricked my PinebookPro and write this from my new Debian versin from the emmc.

My situation was this:
- emmc was turned off on the board (see wiki)
- SD card did boot

So now to get the emmc back again.

Prep:
- Set a shortcut in your desktop environment to easily start a terminal. (see below)
- Get a tiny pin to switch the emmc back on, ideally isolated.
- Put your boot SD card in

1. Unscrew the 10 screws at the back. You need a tiny screw driver for that, don't force it. then gently remove the bottom part of the PBP cover.
2. There are some medium loose bits inside, so don't turn it back. (see wiki for the screw fixture for example, also the loudspeaker can move when open)
3. The Wiki mentions not to open the display, however to turn it you have to open the display a bit. I did not open it fully, more like a 70 degrees angle. Be careful.
4. now the first tricky bit. You have to turn on the PBP. As the PBP is upside down check where the powerbutton is. Then bring your pin into position on the emmc switch.
5. Turn the PBP on. Wait two seconds (you practice with the stopwatch in your smartphone a bit to get that right).
6. The PBP schould now boot without problems from the SD card. But has the kernel found the emmc ?
7. As you have to operate the PBP upside down you use your shortcut to open a teminal. Then use command `lsblk` to see which drives are found. There should be two main devices called mmcblkX (X can vary). your emmc is the one without the root mount. In my case this worked in the first try, however if the timing in step 5 is not quite right you might have to repeat this. From there.
8. With the emmc active I have now closed my laptop and screwed the bottom back on. 
9. Open the PBP normally (not upside down)
10 Download a PBP image. I have used the standard Debian release. links in the wiki
11. unpack the downloaded image file and dd it to the emmc (instructions in the wiki)
12. reboot. done

It probably sounds more complicated than it is. Use common sense and don't apply pressure on the PBP.
  Reply
#8
I'd like to note two things for people writing images:

First, add "conv=fsync" to your dd options -- this forces an fsync of the target device after dd is finished writing.

Second, on first boot both the Debian and Ubuntu images silently run a script that resizes the root filesystem to fill all remaining space on the sd/emmc storage they were written to. This can take several minutes (longer on slow sd cards!) during which time the screen will be blank. Don't interrupt this process by force-rebooting or you can damage the newly installed filesystem and render it unbootable. Yes, this probably should have some display output to tell the user something important is happening.

Edit, Bonus: You can compare/verify a flashed emmc/sd card with the image file you just dd'd onto it using the following to verify that the image was written without errors:

Code:
</dev/mmcblkX head -c "$(stat -c %s my.img)" | cmp - my.img
  Reply
#9
@Surehand53 thank you for sharing... I wish I'd read what you wrote a little earlier. I'm in exactly the same place - I misunderstood what you're supposed to do with the manjaro emmc installer, and dd'd that to the emmc instead of an sd card. It seemed to run ok, but then crashed out with a segfault at the end. If there's some instructions somewhere, I must have missed them. For anyone else reading - don't flash the emmc installer directly to your emmc, that's not how it's supposed to work!

I'm now at angry flashing red and green light with the sd card boot, as you describe. The steps you mention above, I don't get at what point you turn the mmc back on - it's after waiting two seconds?
  Reply
#10
Yes. It’s step 5

- turn the PBP on
- wait 2 seconds
- turn the emmc switch on the board




what happens is this:
- you turn the PBP on
- uboot loads, only sees an sd card (because the emmc is still off) and boots from the sd card
- there is a tiny pause after uboot load and before the kernel starts, this pause is what you are aiming for.
- you flip the emmc switch in the decisive moment and the emmc is on instantly 
- the short break is over and the kernel starts and hurray sees the emmc active
- the system boots with emmc active and now a new image can be flashed to the emmc, everyone happy..
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  Slow WiFi on Manjaro Default Image 20.04 for PBP SuperUJ 8 259 05-28-2020, 08:16 PM
Last Post: nekojet
  postmarketOS/Alpine edge image for the Pinebook Pro MartijnBraam 51 5,097 05-28-2020, 07:07 AM
Last Post: pmjohann
  Pinebook Pro Temps? 65C while playing music via youtube w nothing but a static image jazzmans 4 210 05-26-2020, 10:54 AM
Last Post: xmixahlx
  Using grub-image ? ScarFez 4 181 05-21-2020, 08:51 AM
Last Post: pgwipeout
  Link to the Official (from factory) manjaro image? gandlers 4 161 05-19-2020, 03:36 PM
Last Post: erchache2000
  Recalbox Image is available Luke 5 701 04-12-2020, 07:29 AM
Last Post: mschoolbus
  Manjaro Arm Encrypted EMMC detrexer 8 768 03-20-2020, 12:13 PM
Last Post: GloriousCoffee
Question Mount eMMC after booting from SD card Feakster 3 313 03-16-2020, 02:36 PM
Last Post: lxn
  Cant boot into home-rolled Arch Linux image craftkiller 4 325 02-25-2020, 12:58 PM
Last Post: craftkiller
  Using DD to Backup and Restore EMMC appdev46 6 443 02-05-2020, 04:31 PM
Last Post: FeMike

Forum Jump:


Users browsing this thread: 1 Guest(s)