Q4OS for PinebookPro
#31
(06-12-2020, 02:01 AM)q4osteam Wrote: @TDC_PBP , @jiyong , @diamndM
Anyone who has Manjaro on EMMC installed. Are you able to boot the new Armbian image "Armbian_20.05.2_Pinebook-pro_buster_legacy_4.4.213_desktop.img.xz" from an SD card ?
https://dl.armbian.com/pinebook-pro/arch...top.img.xz

I tried it, but same result.
I see the backlight of the screen is on, but nothing happens after 5 minutes.
I see no response from Caps Lock (led doesn't turn on).
  Reply
#32
We have released Q4OS 3.11 an updated iamge "q4os-3.11-pinebookpro.r1-testing3.zip", with a possible fix included, download: https://sourceforge.net/projects/q4os/files/testing/ . We would appreciate a testing of the image and a possible feedback, thanks everyone.
  Reply
#33
(06-16-2020, 09:04 AM)q4osteam Wrote: We have released Q4OS 3.11 an updated iamge "q4os-3.11-pinebookpro.r1-testing3.zip", with a possible fix included, download: https://sourceforge.net/projects/q4os/files/testing/ . We would appreciate a testing of the image and a possible feedback, thanks everyone.
I am still getting a blank screen when I try to boot Q4OS from both USB and MicroSD. Do you think it is possible Q4OS could avoid this problem by switching to mainline u-boot like Manjaro uses? Another benefit would be users who have Q4OS on their EMMC would be able to boot from USB as well as users who are using Manjaro.
  Reply
#34
Sad 
I just pulled down the latest and cannot boot to anything useful from 32G microSD.   Backlight on, capslock, numlock LEDs respond, but nothing on the screen.

To be fair, same can be said for almost every OS I've tried (incl arbian, bionic LXDE, Mate, Fedora, OpenSuse Gnome and XFCE).

The only two I can do anything useful (e.g. login) are Mr Fixit's Debian, and PostmarketOS (w/o DE)


I'm running PBP from this spring 2020 batch with Manjaro KDE.

HTH
  Reply
#35
Q4OS 3.11-r4 version for Pinebook Pro based on the fresh Armbian 20.08 release is available for download: https://sourceforge.net/projects/q4os/files/testing/ . Everybody is welcome to test the image and post an experience here.
  Reply
#36
q4os-3.11-pinebookpro.r1-testing4.img doesn't work for me.
I see a response from Caps Lock (led), but still no boot screen.
  Reply
#37
Just a backlit screen and a green power light. If I tap the power key the backlight turns off and power light turns red.
  Reply
#38
Seemed OK here, without a bit more information, a "did not boot"
is almost useless. For example,
what is on emmc (and, by implication uboot)? me, mrfixit
Did you try a vt (virtual terminal,,ctl-alt-F3)?
The red light seems to signify sleep, I don't know how well it will do
--edit--
And... not so well, maybe because of oldish kernel,, 15% in 6 hours
Something is not right in uboot, 2.7 is actually OK, works

In short,, blanked 1st 16M on emmc, restored mbr (emmc)
So, a "safe" way to test uboots, with blank SPI and blank emmc,, will use SD uboot

Both q4os and armbian (debian) behaved the same, green led, blank screen
After. a bit varied viz red led, but MUCH better than ones that "locked" pbp
(no leds, other than chrg, no response to pwr button, appeared dead)

If I didn't know "extra long press" ,, I would be cursing
I did learn that a good SD had to be in or it would not work
Just to be clear, q4os uboot did NOT lock pbp
lockers:
fedoraproject:fedora:32
ubuntu 20.04 LTS (Focal Fossa)
kali 2020.3
  Reply
#39
For me it started fine but no wifi (WPA Enterprise).
- couldn't save config with dialog saying maybe network manager is not running or dbus broken or something.
- saved if i didn't enter any identity/password
- modified once saved without to include identity/password
- didn't connect anyway.

Noticed the video playback performance is laggy compared with Manjaro. Not sure if this is some video driver issue or media player setup.

edit: wpa2 personal is working and I am editing from q4os. So Enterprise has issues (like the eduroam network).
I think this is because network manager requires aditional keyring stuff like gnome-keyring to store enterprise network details. Might be a trinity issue or just missing dependency if that's possible on a binary distribution.
  Reply
#40
Hi there,

I want to try Q4Os on my pinebook pro. Just wondering how to install it on a micro sd card. Can I use gnome disks utility to install the q4os iso images to the micro sd?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Possible to install KDE Neon on PinebookPro? Pinoideae 11 4,332 10-27-2020, 10:09 AM
Last Post: firefox-58
  pkgsrc framework on Pinebookpro Linux (manjaro) astr0baby 0 995 02-09-2020, 10:47 AM
Last Post: astr0baby
Sad pinebookpro-debian-desktop-mrfixit-190905 - audio output very noisy tmorin 3 2,593 11-14-2019, 03:20 PM
Last Post: tgrauss

Forum Jump:


Users browsing this thread: 1 Guest(s)