Problem booting from sd-card
#11
(05-24-2019, 02:44 AM)pfeerick Wrote:
(05-22-2019, 08:29 AM)giel Wrote: Thanks for your reply! How do I do that from commandline?

There's no need to format anything if you are writing a disk image... it will completely obliterate any prior file system and partition layouts if done properly.

After doing a dd, it may be a good idea to run 'sync' afterwards just to make sure everything has been written to the card before you remove it.

Which model pinebook is it? The original, or the 1080p one? As I gather you need to be using the right image for the different display, or at least change some settings...

It's a brand new 1080 one (11,6 ", I received the pb 2 weeks ago). I've been too busy to buy a new sd-card, which is the most likely cause of the problem I think....
The sd-card I use is working when i use it to store data, but maybe it's too old to use it for booting?
  Reply
#12
(05-24-2019, 06:58 AM)giel Wrote:
(05-24-2019, 02:44 AM)pfeerick Wrote:
(05-22-2019, 08:29 AM)giel Wrote: Thanks for your reply! How do I do that from commandline?

There's no need to format anything if you are writing a disk image... it will completely obliterate any prior file system and partition layouts if done properly.

After doing a dd, it may be a good idea to run 'sync' afterwards just to make sure everything has been written to the card before you remove it.

Which model pinebook is it? The original, or the 1080p one? As I gather you need to be using the right image for the different display, or at least change some settings...

It's a brand new 1080 one (11,6 ", I received the pb 2 weeks ago). I've been too busy to buy a new sd-card, which is the most likely cause of the problem I think....
The sd-card I use is working when i use it to store data, but maybe it's too old to use it for booting?

Er... I just looked at your dd command again... that image ain't gonna work for you!  Big Grin Big Grin 

simpleimage is (IIRC) basically a stub image that won't do anything at all as it only has uboot in it... don't quote me on it... it's been over a year since I touched the pine64 image builds!

Try one of the GUI desktop images... ie. https://github.com/ayufan-pine64/linux-b...140.img.xz
  Reply
#13
(05-25-2019, 04:59 AM)pfeerick Wrote: Try one of the GUI desktop images... ie. https://github.com/ayufan-pine64/linux-b...140.img.xz

I've got the same pinebook (11.6", 1080p, 2 weeks old) and using that image, you recomend, I couldn't login. After typing password "pine64", it tries to do something and then it goes back to login screen again. You are on that image?
  Reply
#14
(05-25-2019, 04:59 AM)pfeerick Wrote:
(05-24-2019, 06:58 AM)giel Wrote:
(05-24-2019, 02:44 AM)pfeerick Wrote:
(05-22-2019, 08:29 AM)giel Wrote: Thanks for your reply! How do I do that from commandline?

There's no need to format anything if you are writing a disk image... it will completely obliterate any prior file system and partition layouts if done properly.

After doing a dd, it may be a good idea to run 'sync' afterwards just to make sure everything has been written to the card before you remove it.

Which model pinebook is it? The original, or the 1080p one? As I gather you need to be using the right image for the different display, or at least change some settings...

It's a brand new 1080 one (11,6 ", I received the pb 2 weeks ago). I've been too busy to buy a new sd-card, which is the most likely cause of the problem I think....
The sd-card I use is working when i use it to store data, but maybe it's too old to use it for booting?

Er... I just looked at your dd command again... that image ain't gonna work for you!  Big Grin Big Grin 

simpleimage is (IIRC) basically a stub image that won't do anything at all as it only has uboot in it... don't quote me on it... it's been over a year since I touched the pine64 image builds!

Try one of the GUI desktop images... ie. https://github.com/ayufan-pine64/linux-b...140.img.xz

Succes! Thanks everyone!! I tried the q4os image for 1080 pinebook! It worked!
  Reply
#15
(05-25-2019, 08:56 AM)jezek Wrote: You are on that image?

No, I've got the older 11" pinebook, so that probably won't work for me. Hope you got it working... best bet is to join the IRC / discord and see if anyone knows what's going on... ayufan, the image developer, is often around also.
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  can't install a new OS with sd card. pinebook1080. ObviousHobbit 3 152 07-24-2019, 07:52 AM
Last Post: neilman
  pinebook black screen when booting with "different power mode than last used" penzoiders 9 498 06-06-2019, 02:02 PM
Last Post: Surehand53
  DietPi not booting WZ9V 5 386 02-01-2019, 09:06 AM
Last Post: smallfish
  Booting from eMMC with SD inserted? falcon15500 6 860 07-11-2017, 05:51 AM
Last Post: MarkHaysHarris777

Forum Jump:


Users browsing this thread: 1 Guest(s)