Latest images from different distros failing to boot from SD card
I've got a 2017 14" Pinebook with a 64 GB eMMC installed. When I got it, I put the standard Xenial Mate image to boot from eMMC and then didn't touch it for a while. I recently pulled it out and updated to the latest version of Mate available just through `do-release-upgrade`. But that seemed to break some things like the battery life indicator, so I decided to try to find a new image to flash instead.

First, I want to say that I'm pretty disappointed with the state of the wiki for the OG Pinebook. Lots of broken links and not very updated information.

After poking around looking for images to use, I decided to try out Armbian and Manjaro. I have tried the following images all with the same behavior:

  • Manjaro-ARM-i3-pinebook-20.04-emmc-installer-20.04.img.xz
  • Manjaro-ARM-i3-pinebook-20.08.img.xz
  • Manjaro-ARM-kde-plasma-pinebook-20.08.img.xz
  • Armbian_20.08.1_Pinebook-a64_focal_current_5.8.5_desktop.img
  • Armbian_20.08.1_Pinebook-a64_buster_current_5.8.5_desktop.img.xz
  • Armbian_20.08.1_Pinebook-a64_bionic_current_5.8.5.img (pretty sure this was the headless server)
Anyway, on each of these I would see the bootloader start up. If I pressed space during this I'd be taken to the uboot cli. I could sit at that cli for however long I wanted. If I didn't interrupt the bootloader, I would see a splash screen for the distro pop up and after 15 or so seconds the screen would flicker and go black. Even on the headless image without the splash screen, it would go through the startup sequence and at about the same amount of time the screen would flicker and go black. The screen would occasionally light up like it was waking from sleep but then would go back to black. This would last indefinitely, I left it over night one time and it was still occasionally lighting back up just to go back to black periodically.

To make sure it wasn't a power issue I bought a new cable and a new power supply. To make sure it wasn't an SD card, I bought a couple new SD cards. As a last ditch effort I flashed the original Xenial Mate image from the wiki (xenial-mate-pinebook-bspkernel-0.7.28-136.img) and that booted up just fine. It also boots totally fine from eMMC into the original Xenial image I've update there and I can use it and leave it powered on without the screen going black and becoming unresponsive. I even tried booting from a recent Android image (android-7.1-pine-a64-pinebook-v0.3.5-r61.img - is that recent? I don't know) and that worked just fine.

I'm assuming there's something in the most recent kernel that is not compatible with the original Pinebook? Is this a known issue and is there anyone that knows what the latest version of the kernel I can use for one of these images is? I will start trying to find one on my own, but it would be great if someone already knew.
Ok, I've gotten a little further on this. I booted up an older Armbian image, Armbian_19.11.3_Pinebook-a64_bionic_current_5.3.9_desktop. It didn't boot into the desktop environment (I assumed it would with the "desktop" designation, maybe I'm wrong). But the screen did flicker while going through the boot up process. However instead of just going blank after that, it came back with an error message:

PM: dpm_run_callback(): pm_generic_suspend+0x0/0x40 returns -38
PM: Device mmc1:0001:1 failed to suspend async: error -38
PM: Some devices failed to suspend, or early wake event detected
... (repeated a few times)

I was able to login and go through the user setup process, but this error would just keep popping up and interrupting. At least it would not go completely unresponsive. 

It would seem weird that it would be trying to suspend during the boot up, could this be an "early wake event" from the OS currently installed on the eMMC? I'm assuming mmc1:0001:1 is the eMMC, or could it be the SD card? How would I find out?
Same issues here on my 11.6" Pinebook with 720p screen. I tried both Armbian Focal and Buster. Both get up to the second splash screen and then go dark, nothing happens after that. I usually see if the system is responding by trying out CapsLock, and then see if I can get to a terminal window with CTRL-ALT-F1 thru F12... nothing works.

Why put out an image for a distro if it doesn't even work? Unless these images are all built as part of an automated "build process" and the put out there, and no one is even checking them to see if they ACTUALLY work on hardware. Most images for the OG Pinebook are a bust. Don't work. I just want the original Xenial Mate SD2eMMC image...can't even find that anywhere now.

Possibly Related Threads…
Thread Author Replies Views Last Post
  Are Pinebook images compatible with Pine64+? starcrescent 7 11,035 09-18-2019, 09:22 AM
Last Post: tophneal
  can't install a new OS with sd card. pinebook1080. ObviousHobbit 3 4,412 07-24-2019, 07:52 AM
Last Post: neilman
  Ethernet not found. error during boot Surehand53 1 3,223 07-24-2019, 05:00 AM
Last Post: ObviousHobbit
  Manjaro hangs on boot DAMO238 1 3,367 07-08-2019, 08:14 AM
Last Post: DAMO238
  Problem booting from sd-card giel 14 16,640 06-27-2019, 10:28 PM
Last Post: pfeerick
  Adding coherent_pool to boot.cmd on Xenial Mate by Ayufan causes boot loop k_mp 0 2,033 06-11-2019, 01:36 PM
Last Post: k_mp
  Blank Screen on Boot MECZero 4 7,321 05-12-2019, 11:54 AM
Last Post: tllim
  how do I boot to SD? (1080) tedder 7 8,650 11-16-2018, 03:15 AM
Last Post: Surehand53
  How to get text boot on KDE Neon maldus 5 7,182 11-13-2018, 04:29 AM
Last Post: maldus
  Xenial Images (Pinebook) 0.6.2-77 pineadmin 11 17,572 09-24-2018, 03:21 AM
Last Post: erchache2000

Forum Jump:

Users browsing this thread: 1 Guest(s)