DietPi not booting
#1
I saw that DietPi was highly recommended and had a Pinebook version.  I created a SD card with Etcher and the Pine64 Installer but neither will boot properly on my Pinebook 14 with the original 1366x768 display and the 64GB eMMC upgrade.

I see the same problem with the Dev Armbian using Kernel 4.19, so far other than the stock OS I have only been able to get Armbian Stable Kernel 3.10 to boot from SD and later install to the eMMC (had to format ext2 for it to work).

Any ideas?  I have the serial adapter on order to see if I can catch any messages on the serial console.
  Reply
#2
I have the exact same configuration and the exact same experience.

1. flashing DietPi to the SD card - boots and Pinebook turns off after several seconds

2. 
Code:
wget https://dietpi.com/downloads/images/DietPi_Pinebook-ARMv8-Stretch-Desktop.7z
7z x *.7z
dd if=$(find DietPi*.img) of=/dev/mmcblk2
The screen remains black, the Power LED glows

3. I used the emmc - USB adapter fro the Pine shop, and flashed the image right to the emmc module. No boot, dark screen, Power LED glows
  Reply
#3
I upgraded my LCD to a 1920x1080 one and it all works now. No idea why since they claim it’s supposed to support both the 1366x768 and 1920x1080 displays.
  Reply
#4
(01-13-2019, 10:03 AM)WZ9V Wrote: I upgraded my LCD to a 1920x1080 one and it all works now.  No idea why since they claim it’s supposed to support both the 1366x768 and 1920x1080 displays.

I have tried the Diet-Pi and the Manjaro builds from http://wiki.pine64.org/index.php/Pineboo...re_Release and the Manjaro build works fine whereas Diet-Pi is not booting up.

As this was a 2017 build, I expect I don't have the 1920x1080 LCD.
  Reply
#5
(01-13-2019, 10:03 AM)WZ9V Wrote: I upgraded my LCD to a 1920x1080 one and it all works now.  No idea why since they claim it’s supposed to support both the 1366x768 and 1920x1080 displays.

Which display did you use for the upgrade ? Are we sepaking about the 11" or the 14" Pinebook ?
  Reply
#6
Also having issue with Rock64 not booting with Dietpi.
System setup with power via POE splitter that the Pine64 site sells.
Downloaded Pine64 from Pine64 wiki site Debian Stretch minimal 64 bit (0.7.8) burnt to micro SD via Etcher.
Able to SSH in via putty after booting - all is good.

Flashed a second SD card with Dietpi_v6.0_rock64-ARMv8-stretch.img from Dietpi site.
Fire up and nothing happens. Ethernet leds and power led on and flashing. Waited 10 plus minutes. Rock64 is not seen on the network and has no IP. Can not use putty to SSH. Using class 10 SD cards from Samsung and Sandisk.
Help...........
  Reply


Possibly Related Threads...
Thread Author Replies Views Last Post
  pinebook black screen when booting with "different power mode than last used" penzoiders 9 319 06-06-2019, 02:02 PM
Last Post: Surehand53
  Problem booting from sd-card giel 13 281 05-27-2019, 04:49 AM
Last Post: giel
  DietPi for Pinebook Fourdee 10 2,465 01-09-2019, 08:38 AM
Last Post: WZ9V
  Booting from eMMC with SD inserted? falcon15500 6 770 07-11-2017, 05:51 AM
Last Post: MarkHaysHarris777

Forum Jump:


Users browsing this thread: 1 Guest(s)