NAS Box - fdisk not showing hard-drives w/pcie sata card
#1
Just getting my new pine64 NAS box up and running.
I've got the ayufan latest stable image loaded and running no issues (18.04 ubuntu).
I have the pcie sata card I bought from pine64.
I have them connected to two 3.5" Hitachi drives
The drives are powered and I did see a momentary light flash on the card but when I do a fdisk -L neither drive is listed.

Given all the hardware looks good does the ayufan built kernel not include that pcie board?

Why can't I see these drives?

hmm.   if I just cat dev/disks/by-id   I see them sda/sbd

Well something changed after a reboot I see the drives with fdisk now so ......nevermind Confused



Code:
rock64@rockpro64:/dev/disk/by-id$ ll
total 0
drwxr-xr-x 2 root root 280 Oct 12 17:17 ./
drwxr-xr-x 8 root root 160 Jan 18  2013 ../
lrwxrwxrwx 1 root root   9 Oct 12 17:17 ata-Hitachi_HUA723020ALA641_YFGPRJ9A -> ../../sda
lrwxrwxrwx 1 root root   9 Oct 12 17:17 ata-Hitachi_HUA723020ALA641_YFH93KTD -> ../../sdb
lrwxrwxrwx 1 root root  13 Oct 12 17:17 mmc-NCard_0x82f69016 -> ../../mmcblk1
lrwxrwxrwx 1 root root  15 Oct 12 17:17 mmc-NCard_0x82f69016-part1 -> ../../mmcblk1p1
lrwxrwxrwx 1 root root  15 Oct 12 17:17 mmc-NCard_0x82f69016-part2 -> ../../mmcblk1p2
lrwxrwxrwx 1 root root  15 Oct 12 17:17 mmc-NCard_0x82f69016-part3 -> ../../mmcblk1p3
lrwxrwxrwx 1 root root  15 Oct 12 17:17 mmc-NCard_0x82f69016-part4 -> ../../mmcblk1p4
lrwxrwxrwx 1 root root  15 Oct 12 17:17 mmc-NCard_0x82f69016-part5 -> ../../mmcblk1p5
lrwxrwxrwx 1 root root  15 Oct 12 17:17 mmc-NCard_0x82f69016-part6 -> ../../mmcblk1p6
lrwxrwxrwx 1 root root  15 Oct 12 17:17 mmc-NCard_0x82f69016-part7 -> ../../mmcblk1p7
lrwxrwxrwx 1 root root   9 Oct 12 17:17 wwn-0x5000cca223c9e05a -> ../../sda
lrwxrwxrwx 1 root root   9 Oct 12 17:17 wwn-0x5000cca223d23c42 -> ../../sdb
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Mainline U-Boot with SPI, NVMe and SATA boot support sigmaris 63 15,914 6 hours ago
Last Post: Bullet64
  Rockpro64 with PCI FC Card - Not booting (Sometimes) MSteam 1 166 10-25-2020, 07:42 PM
Last Post: MSteam
  fan continously runs on kernel 5.8 but I need to use 5. kernel for PCIe sata card GreyLinux 4 455 10-20-2020, 10:52 AM
Last Post: GreyLinux
  RockPro64 SSD Expansion Board/SATA Shield as0zial 5 855 10-18-2020, 08:05 PM
Last Post: revoman
  4pin Connector for dual SATA m.ekstrom 4 1,007 07-28-2020, 07:07 AM
Last Post: mabs
  PCIe x4 mode - Lane 3 failure acdkyn 1 715 04-24-2020, 01:32 PM
Last Post: kuleszdl
  micro SD Card Slot Spring not working, Cant boot mjembd 1 491 04-16-2020, 12:30 AM
Last Post: mjembd
  Defective? PCI-E -> SATA card no work good unregisteredidiot 11 3,347 02-19-2020, 09:08 AM
Last Post: fysa
  NAS Case and two hard drives? jsfrederick 7 1,668 12-21-2019, 09:14 AM
Last Post: hemertje
  for what purpose Pine64 added PCIEx4 card on this sbc ? seaurchin 4 1,000 11-25-2019, 11:33 AM
Last Post: dukla2000

Forum Jump:


Users browsing this thread: 1 Guest(s)