Rockpro64 with PCI FC Card - Not booting (Sometimes)
#1
Hi.

So i have FibreChannel PCIe x8 card, and i am trying to make it work with my RP64.

Most distros woun't boot with this card inserted, but I have found that Armbian 4.4.192 and MrFixit's debian build 4.4.180 will sometimes boot, and detect the card!

But it happens 1 time out of 6, and i have no idea why. Also I can't understand why this distros can run this card, and others just hang.

Anyway here is two bootlogs: succesful and the one that fails to boot.

If somone knows what is going on - please look at this logs.



Sucsess:
https://justpaste.it/8irfl

Fail:
https://justpaste.it/2oapd
#2
Edit!
I've find out that boot fail happening only if PCI addressees getting assigned by cpu0, cpu1, cpu2, cpu3!
If I get lucky (or disable cpus 0-3) and PCI address assigned by cpu4 or cpu5 - it will boot every time!

But how do i assign PCI address only by some specific cpu?


Possibly Related Threads…
Thread Author Replies Views Last Post
  ROCKPro64 sometimes doesn't Power On Pete Tandy 2 407 08-24-2021, 05:50 AM
Last Post: Pete Tandy
  Tutorial request: overclocking a rockpro64 Mentaluproar 1 388 08-15-2021, 01:35 PM
Last Post: dukla2000
  Did I brick my RockPro64 somehow? snarfel 1 600 07-20-2021, 01:40 PM
Last Post: dukla2000
  RockPro64 - EN62368 m.ekstrom 0 489 06-02-2021, 04:55 AM
Last Post: m.ekstrom
  RPI4 Vs Rockpro64 Performance help? Mangled 0 609 05-25-2021, 03:38 PM
Last Post: Mangled
  Booting my RockPro64 from NVMe drive PsySc0rpi0n 3 1,224 05-02-2021, 01:56 AM
Last Post: LMM
  Unusable ROCKPRO64 drenedo 3 1,686 03-24-2021, 06:47 AM
Last Post: GuyNoIRQ
  ROCKPro64 (4 GB) "In stock (can be backordered)" TRS-80 3 1,024 03-19-2021, 04:53 PM
Last Post: TRS-80
  Troubleshooting ROCKPro64 alephnull 3 1,583 03-04-2021, 03:58 AM
Last Post: alephnull
  Petitboot on RockPro64? new_to_arm 0 664 03-03-2021, 05:00 PM
Last Post: new_to_arm

Forum Jump:


Users browsing this thread: 1 Guest(s)