PCIE interface power on too late
#1
Hi,
   I have a rockpro64 v2.1 (2018-07-02) and use Armbian system. 
   In my local test, rockpro64 needs about 36seconds before start kernel. And the 5G device connected with the PCIE slot would be power on at that time.
   The 5G device would obey PBL->SBL->Kernel start progress. And the PCI driver would detect 5G device at 3.5 second after host kernel start even if the 5G device still in PBL stage. This would lead to the true VID/PID of PCIE device are not enumerated because device has difference VID/PID between PBL and Kernel stage.

    For reference, USB interface would be power on during about 10seconds. So could we ajust the power on time slot for PCIE slot to avoid above issue?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Automatic power on after power outage gechu 1 1,480 11-17-2022, 06:13 PM
Last Post: acj_
  After Power Loss feature working bdherouville 2 725 08-22-2022, 03:52 AM
Last Post: bdherouville
  enble boot after power loss/restore dkebler 11 3,521 06-22-2022, 09:39 PM
Last Post: dkebler
  PCIe gen1 timeout - how to debug tosi 3 3,159 03-10-2022, 05:06 PM
Last Post: db579
  PWM fan control low power Connar 0 936 12-12-2021, 05:58 AM
Last Post: Connar
  wifi interface on debian mruser1 2 1,605 10-14-2021, 09:07 AM
Last Post: mruser1
  ROCKPro64 sometimes doesn't Power On Pete Tandy 2 2,472 08-24-2021, 05:50 AM
Last Post: Pete Tandy
  Power Supply availability S265 2 2,867 06-07-2021, 09:20 PM
Last Post: S265
  Anyone try an NVIDIA GPU in the PCIe slot? Paraplegic Racehorse 0 1,324 04-15-2021, 11:46 AM
Last Post: Paraplegic Racehorse
  control RP64 power on LMM 0 1,456 04-15-2021, 02:59 AM
Last Post: LMM

Forum Jump:


Users browsing this thread: 2 Guest(s)