HDMI Video Resolution
#1
Hi,

Pine 64/2GBB running Arch Kernel (arch-pine64-bspkernel-20160304-1-xfce4.rar).

Boots very happily and is *very* fast (compared with other SBCs I have played with).

I am directly into a Samsung TV/Monitor via HDMI (this thing http://www.samsung.com/uk/support/model/UE22H5600AKXXU)

The issue is that the the image is too big for the screen, off every edge. I need to change resolution or size or something (BTW this works fine on all the RPi boards I have).

I have tried App Finder -> Display but nothing seems changeable there.

It's worth noting that the boot sequence messages are also falling off the LHS of the screen.

Any ideas how to fix please ?

Thanks !
  Reply
#2
The keyword is "Overscan" (google it for your TV) and it is not something you usually fix in the operating system (meaning your archlinux) but on your TV. Look for screen settings like scaling, or aspect ratio settings and see what is available. Usually the TV should have an option that will work.

No need to change the resolution.
  Reply
#3
Agreed, I had the same problem on one tv but not another. I went into the menus and found where the tv could do things like, zoom, stretch, dot for dot, etc. The fix was selecting dot for dot on mine.

Good luck
  Reply
#4
(04-03-2016, 08:31 AM)patmolloy Wrote: BTW this works fine on all the RPi boards I have

What does 'tvservice -s' show when the TV is connected to a Raspberry Pi running Raspbian?
  Reply
#5
(04-03-2016, 08:46 AM)Keex Wrote: The keyword is "Overscan" (google it for your TV) and it is not something you usually fix in the operating system (meaning your archlinux) but on your TV. Look for screen settings like scaling, or aspect ratio settings and see what is available. Usually the TV should have an option that will work.

No need to change the resolution.

Fantastic, buried 4 levels deep in a menu were some options I've never seen before .. "Picture Size = Screen Fit" has done the trick !!

Thanks ever so much for the quick and excellent help  Smile

(04-03-2016, 09:17 AM)HeadShot Wrote: Agreed,  I had the same problem on one tv but not another.  I went into the menus and found where the tv could do things like, zoom, stretch, dot for dot, etc.  The fix was selecting dot for dot on mine.

Good luck

Fixed too !!
  Reply
#6
(04-03-2016, 09:32 AM)patmolloy Wrote:
(04-03-2016, 08:46 AM)Keex Wrote: The keyword is "Overscan" (google it for your TV) and it is not something you usually fix in the operating system (meaning your archlinux) but on your TV. Look for screen settings like scaling, or aspect ratio settings and see what is available. Usually the TV should have an option that will work.

No need to change the resolution.

Fantastic, buried 4 levels deep in a menu were some options I've never seen before .. "Picture Size = Screen Fit" has done the trick !!

Thanks ever so much for the quick and excellent help  Smile

(04-03-2016, 09:17 AM)HeadShot Wrote: Agreed,  I had the same problem on one tv but not another.  I went into the menus and found where the tv could do things like, zoom, stretch, dot for dot, etc.  The fix was selecting dot for dot on mine.

Good luck

Fixed too !!

This isn't an acceptable solution. I have 2 TV's and the more expensive one doesn't have this option haha. (Both are 1080p)

On my gaming computer I always scaled it down. We need to be able to switch screen resolution and scale the monitor down. There's gotta be a terminal command for this?
(Running Ubuntu)
  Reply
#7
I had the same trouble and had to get out my TV remote and search through the Menu to fix the overscan.

Currently I am typing this with ArchLinuxArm running on my Pine64+.  The monitor resolution is 1920 X 1080.  This on a 1366 X 768 monitor (surprised this even works!), so it's just a little hard to read.

My understanding is that the GPU boots first and sets the video mode including resolution, then starts the CPU. This is why Applications > Settings > Display (on xfce4) doesn't let me change anything.  If a command existed to alter the screen resolution it would need to change files in /boot and change would take effect after rebooting.

I've searched through /boot and there doesn't appear to be anything I could edit to change this.  Anyone know? 1920 X 1080 is awesome, but the logical pixels are smaller (and more numerous) than the physical, so some disappear.

Cheers!
  Reply
#8
(05-05-2016, 06:44 PM)polypagan Wrote: My understanding is that the GPU boots first and sets the video mode including resolution, then starts the CPU. This is why Applications > Settings > Display (on xfce4) doesn't let me change anything.  If a command existed to alter the screen resolution it would need to change files in /boot and change would take effect after rebooting.

Nope. This is not a Raspberry Pi.

Currently only 1920x1080 are supported by the kernel every Linux image uses but this will change soon (thx to the great linux-sunxi community):

https://github.com/longsleep/linux-pine6...-hacks-1.2

https://github.com/longsleep/sunxi-disp-tool
  Reply
#9
(05-06-2016, 01:02 AM)tkaiser Wrote:
(05-05-2016, 06:44 PM)polypagan Wrote: My understanding is that the GPU boots first and sets the video mode including resolution, then starts the CPU. This is why Applications > Settings > Display (on xfce4) doesn't let me change anything.  If a command existed to alter the screen resolution it would need to change files in /boot and change would take effect after rebooting.

Nope. This is not a Raspberry Pi.

Currently only 1920x1080 are supported by the kernel every Linux image uses but this will change soon (thx to the great linux-sunxi community):

https://github.com/longsleep/linux-pine6...-hacks-1.2

https://github.com/longsleep/sunxi-disp-tool

Appreciate and solute to Sunxi community contribution.
  Reply
#10
I'm having this same problem in Debian, but my TV has no such options. Some suggestions I found online suggest using xrandr to set the underscan/overscan values. However, xrandr is giving me a strange output that seems to mean the wrong video driver is being used.

How can I check what video driver is installed, also what driver should be installed and where can I get it?
  Reply


Possibly Related Threads…
Thread Author Replies Views Last Post
  Video conferencing aproject oxoocoffee 1 424 03-31-2020, 09:24 PM
Last Post: Dendrocalamus64
  Pine HDMI -> DVI monitor Pineapple 4 1,274 09-10-2019, 11:28 AM
Last Post: Pineapple
  Here Is another mini-how-to to install Raspbian:DESKTOP/ETHERNET/HDMI speedro86 4 2,419 04-15-2018, 07:37 AM
Last Post: bunkerWHz
  HDMI "Format not supported" sam452 3 2,352 06-11-2017, 10:38 AM
Last Post: Beta_Ravener
  RESOLVED - LCD screen not working, HDMI does asuras 10 3,789 04-02-2017, 08:12 AM
Last Post: Luke
  HDMI and LCD hienhuynh1982 19 5,776 03-23-2017, 10:16 PM
Last Post: tllim
  HDMI-VGA adapter. Blank screen. trumad 10 5,139 03-05-2017, 03:17 AM
Last Post: pfeerick
  SSH works, but no video SvdSinner 8 2,326 12-08-2016, 12:59 PM
Last Post: MarkHaysHarris777
  no sound over HDMI mbjpine64 2 1,963 10-09-2016, 01:45 PM
Last Post: dicenicheserr
  Resolution help johnp28 1 701 09-05-2016, 03:41 PM
Last Post: ayufan

Forum Jump:


Users browsing this thread: 1 Guest(s)