Pine HDMI -> DVI monitor
#1
Got my Pine RockPro working and now actually wanted to use it in my garage with an old Monitor.

Today reveiceed the HDMI to DVI adapter and hapily connected everything together and no signal..... Huh   Plugged the HDMI cable in my laptop and the old Monitor comes a live. So the adapter is working but somehow not with the Pine board.

Did some research and I came across some old posts that this problem is known. Only thing as a solution found so far is what I found on the armbian site.

https://www.armbian.com/pine64/

They say:  If you use a DVI display don’t forget to define 
Code:
disp_dvi_compat=1
 in 
Code:
/boot/armbianEnv.txt
 (supported starting with 5.21).



Now I tried to put in the line and save but with no succes. Seems I have no permission? Huh
#2
(09-05-2019, 11:46 AM)Pineapple Wrote: Now I tried to put in the line and save but with no succes. Seems I have no permission? Huh

Do you mean you had problem saving the /boot/armbianEnv.txt ?

try it with "sudo nano /boot/armbianEnv.txt" ...
#3
(09-05-2019, 11:46 AM)Pineapple Wrote: Today reveiceed the HDMI to DVI adapter and hapily connected everything together and no signal..... Huh   Plugged the HDMI cable in my laptop and the old Monitor comes a live. So the adapter is working but somehow not with the Pine board.
I have trouble with a monitor or dvi adapter sending corrupt and/or blank edid and I have to force to work. On armbian I use:

Code:
extraargs=drm_kms_helper.edid_firmware=edid/1920x1080.bin
#4
(09-05-2019, 01:46 PM)martinayotte Wrote:
(09-05-2019, 11:46 AM)Pineapple Wrote: Now I tried to put in the line and save but with no succes. Seems I have no permission? Huh

Do you mean you had problem saving the /boot/armbianEnv.txt ?

try it with "sudo nano /boot/armbianEnv.txt" ...

(09-05-2019, 07:43 PM)evilbunny Wrote:
(09-05-2019, 11:46 AM)Pineapple Wrote: Today reveiceed the HDMI to DVI adapter and hapily connected everything together and no signal..... Huh   Plugged the HDMI cable in my laptop and the old Monitor comes a live. So the adapter is working but somehow not with the Pine board.
I have trouble with a monitor or dvi adapter sending corrupt and/or blank edid and I have to force to work. On armbian I use:

Code:
extraargs=drm_kms_helper.edid_firmware=edid/1920x1080.bin

Thanks Martinayotte that worked Smile

Evilbunny tried that but that isn't working Sad
Tried your same line. But also put in the resolution of the screen which I am using ( Dell 1909WF 1440x900 ) and still not working.

When I discontect the cable screen says no cable connected. When I plug in the cable it goes straight into power saving mode.


This is what I got now in the file.


verbosity=1
overlay_prefix=rockchip
rootdev=UUID=e6f2ace3-a9fd-4cb6-a5f5-c69dec4583d4
rootfstype=ext4
disp_dvi_compat=1
extraargs=drm_kms_helper.edid_firmware=edid/1440x900.bin
usbstoragequirks=0x2537:0x1066:u,0x2537:0x1068:u


edit... after I change something I did rebooted the Pine board. Smile

edit no 2... Seems it might be a DVI hot plug problem. Just measured Pin no.16 and there was no voltaged. Will try to solder a resistor in my screen this week to see if it will keep out of the sleep mode.
Source: http://philtechnicalblog.blogspot.com/20...ilema.html
#5
Even with separate hot plug connection no luck. Seems Pine isn't sending the DDC/EDID somehow to the screen?


Possibly Related Threads…
Thread Author Replies Views Last Post
  Pine phone & US carriers samiam 1 1,492 12-20-2020, 05:52 PM
Last Post: evilbunny
  how long until I get my pine phone dallytaur 2 1,544 11-13-2020, 11:13 PM
Last Post: MonCon
  pine store paulhide 1 1,369 09-17-2020, 04:13 AM
Last Post: bcnaz
  christmasssss pine phone ! YoGiB33r 2 1,869 08-14-2020, 01:30 AM
Last Post: YoGiB33r
  My optimal software configuration for pine A64(+) 2Gb Alkemyboy 3 2,138 03-18-2020, 08:41 AM
Last Post: tophneal
  PINE A64+ 4K Media Computer RWL 4 3,517 11-08-2018, 04:20 PM
Last Post: mindwave
  Multi Room Audio - Pine style mjgoode 4 4,560 09-19-2018, 10:30 AM
Last Post: mjgoode
  Here Is another mini-how-to to install Raspbian:DESKTOP/ETHERNET/HDMI speedro86 4 4,547 04-15-2018, 07:37 AM
Last Post: bunkerWHz
  Pine 64 LTS Schematic And R18 Reference Manual Akash Gajjar 2 2,867 12-26-2017, 07:01 PM
Last Post: tllim
  HDMI "Format not supported" sam452 3 3,929 06-11-2017, 10:38 AM
Last Post: Beta_Ravener

Forum Jump:


Users browsing this thread: 1 Guest(s)